Problem bei Clean Install: Kann SSD nicht mit APFS formatieren

compukortschnoi

Mitglied
Thread Starter
Mitglied seit
03.09.2004
Beiträge
207
Hallo Ihr,

habe hier große Probleme. Wollte einen Clean Install von Big Sur auf meinem 2018er Mac mini machen, aber die SSD lässt sich plötzlich nicht mehr mit APFS formatieren. Bei beiden Recovery-Varianten (CMD+R und CMD+Option+R) das gleiche Fehlerbild im Disk Utility, siehe Anhang. Mac OS Extended ginge, aber darauf kann ich ja weder Big noch Cat installieren...

Weiß einer Rat?

Beste Grüße
compukortschnoi
 

Anhänge

dg2rbf

Aktives Mitglied
Mitglied seit
08.05.2010
Beiträge
7.280
Hi,
im Festplatten Dienst Programm oben links die Darstellung auf alle Hardwaredevices umstellen.
Franz
 

OmarDLittle

Aktives Mitglied
Mitglied seit
21.05.2017
Beiträge
2.160
Das ist seltsam. Vielleicht hilft es die Partitionstabelle zu löschen. Du kannst das Terminal öffnen, mit diskutil list die Nummer der SSD raussuchen (als internal, physical bezeichnet mit der Gesamtgröße die deine SSD hat), also diskX und dann eingeben:

Code:
dd if=/dev/zero of=/dev/diskX bs=512k
Nach ein paar Sekunden kannst du das mit CTRL+C unterbrechen, es muss nur der Anfang der SSD gelöscht werden, nicht die gesamte.

Dann das Festplattendienstprogramm neu öffnen, und es sollte nur mehr die Platte mit der Bezeichnung Apple.. sichtbar sein, ohne Partitionen. Dann versuch es nochmal.
 

dg2rbf

Aktives Mitglied
Mitglied seit
08.05.2010
Beiträge
7.280
Hi,
auch ein SMC- und Pram-Reset kann solche Probleme lösen.
Franz
 

compukortschnoi

Mitglied
Thread Starter
Mitglied seit
03.09.2004
Beiträge
207
Das ist seltsam. Vielleicht hilft es die Partitionstabelle zu löschen. Du kannst das Terminal öffnen, mit diskutil list die Nummer der SSD raussuchen (als internal, physical bezeichnet mit der Gesamtgröße die deine SSD hat), also diskX und dann eingeben:

Code:
dd if=/dev/zero of=/dev/diskX bs=512k
Nach ein paar Sekunden kannst du das mit CTRL+C unterbrechen, es muss nur der Anfang der SSD gelöscht werden, nicht die gesamte.

Dann das Festplattendienstprogramm neu öffnen, und es sollte nur mehr die Platte mit der Bezeichnung Apple.. sichtbar sein, ohne Partitionen. Dann versuch es nochmal.
Das hat leider nix gebracht.

SMC-Reset und PRAM-Reset versuche ich gleich noch.
 

dg25

Mitglied
Mitglied seit
20.05.2015
Beiträge
72
Ähnliches Problem hatte ich auch. Es hat nur geholfen, über einen anderen Mac im Festplattenmodus darauf zuzugreifen und mit dem FDP die Partition neu anzulegen.
 

Didgeridoo

Neues Mitglied
Mitglied seit
16.05.2013
Beiträge
34
Wie alt ist den der Mac? Ich glaube es liegt an der Sicherheitseinstellung des t2 Chip. Du hast den Mac noch nicht von deinem Konto entfernt und daher erlaubt er dieses nicht. Ist ein Diebstallschutz, damit keiner deinen Mac klauen und ihn einfach neu aufsetzen kann.
 

compukortschnoi

Mitglied
Thread Starter
Mitglied seit
03.09.2004
Beiträge
207
Wie alt ist den der Mac? Ich glaube es liegt an der Sicherheitseinstellung des t2 Chip. Du hast den Mac noch nicht von deinem Konto entfernt und daher erlaubt er dieses nicht. Ist ein Diebstallschutz, damit keiner deinen Mac klauen und ihn einfach neu aufsetzen kann.
2018er Mac mini. Ist aber mit keinem Admin-Konto mehr verbunden.
 

OmarDLittle

Aktives Mitglied
Mitglied seit
21.05.2017
Beiträge
2.160
Kannst du die Installation mit HFS+ dennoch fortsetzen und danach wandelt der Installer automatisch? Wenn du die SSD gar nicht mit APFS formatiert bekommst, sieht es schlecht aus.
 

compukortschnoi

Mitglied
Thread Starter
Mitglied seit
03.09.2004
Beiträge
207
Ich hab’ mal mit HFS+ formatiert, aber der Catalina-Installer will dann nach Abnicken der Lizenzvereinbarung nicht weitermachen. Er zeigt da dann keine Volumes an.
 

lisanet

Aktives Mitglied
Mitglied seit
05.12.2006
Beiträge
2.942
Boote mal in die Recovery und starte dann das Startsicherheitsprogramm und verringere dort die Sicherheitseinstellungen und erlaube das Booten von externen Medien. Dann solltest du eigentlich via Recovery die SSD löschen können.

https://support.apple.com/de-de/HT208198
 

compukortschnoi

Mitglied
Thread Starter
Mitglied seit
03.09.2004
Beiträge
207
Da war ich schon. Ich kann die Einstellung nicht ändern, weil er keinen Admin-Account finden konnte.
 

MarcNRW

Aktives Mitglied
Mitglied seit
22.04.2015
Beiträge
1.313
Das geht aber glaub ich nur, wenn noch ein Betriebssystem mit Administrator installiert ist.

Edit: zu spät ;-)
 

MarcNRW

Aktives Mitglied
Mitglied seit
22.04.2015
Beiträge
1.313
Ich war auch vorgestern an diesen Punkt, das ich die SSD gelöscht hatte und nicht mehr in das Sicherheitsdienstprogramm reingekommen bin. Da half nur Internetrecovery und das alte System wieder draufspielen. So konnte ich ins Sicherheitsdienstprogramm und dort die Einstellungen ändern. Nur so konnte ich überhaupt mein MacBook Pro dazu bringen vom Stick zu starten. So konnte ich Big Sur dann mit Clean-Install installieren. Hinterher hab ich die Einstellungen im Sicherheitsdienstprogramm wieder "scharf" gestellt.

Das alles funktioniert aber natürlich nur, wenn sich die SDD noch entsprechend formatieren lässt.
 
Oben