PowerBook G4 12" Lüfterproblem: 2FAN/4/8: REAR MAIN ENCLOSURE

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.898
Ich habe hier ein PowerBook G4 12" liefen wo der Lüfter auf vollen Touren dreht. AHT gibt mit den Fehler: 2FAN/4/8: REAR MAIN ENCLOSURE. Und Google gibt mir dazu überhaupt nichts. Hat jemand eine Idee was hier los sein könnte?

Hmm Ich habe das hier gefunden: http://powerbook.micahgartman.com/diagnostics/AHT 252 Error Codes.pdf

Bringt mich aber nicht weiter.
 
Zuletzt bearbeitet:

akumetsu

Aktives Mitglied
Registriert
19.08.2011
Beiträge
2.295
Beim PDF krieg ich nur einen Timeout...

Ich würde auf einen defekten Temperatursensor tippen. Leider habe ich keinen Tipp den Fehler einzugrenzen oder zu beheben.

Welches OS läuft denn drauf? Gibts dafür vielleicht eine alte Version von MacsFanControl oder ähnliche Software? Ev. kannst du den Lüfter ja manuell regeln. Auf die Schnelle konnte ich leider nichts finden. Welche Temperaturen liefern die Sensoren?
 

dodo4ever

Aktives Mitglied
Registriert
20.10.2004
Beiträge
1.195
Ich würde auf einen defekten Temperatursensor tippen. Leider habe ich keinen Tipp den Fehler einzugrenzen oder zu beheben
Guter Tipp. Am besten die Temperatur mit einer alten Version der App „Temperature Monitor“ messen. Wird ein irre hoher Wert angezeigt, ist der Sensor kaputt. Passt der Sensor, muss evtl der Lüfter selbst als Ersatzteil gewechselt werden.
 

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.898
Alle Temperatursensoren funktionieren und sind auch nicht zu heiß. Es fehlt auch kein Sensorwert. Ich habe die werte mit meinem PB G4 verglichen. Ich habe jetzt mal einen anderen Lüfter angeschlossen, da passiert das gleiche. Der Lüfter fängt auch direkt nach dem einschalten an hoch zu drehen.

Ich habe g4Fancontrol ausprobiert, aber das hat nicht geholfen. https://macintoshgarden.org/apps/g4fancontrol.

In der PDF Datei die ich ober verlinkt habe (also bei mir funktioniert die) steht als Lösung - wie bei Apple logischer weise immer - Replace Logicboard.
 

Stargate

Aktives Mitglied
Registriert
27.02.2002
Beiträge
9.872
In der PDF Datei die ich ober verlinkt habe (also bei mir funktioniert die) steht als Lösung - wie bei Apple logischer weise immer - Replace Logicboard.

Schaltplan auftreiben, schauen ob es zu dem Lüfter einen analogen Regler auf dem Board gibt.
Wenn nicht steckt die Intelligenz dazu in einem Chip und damit wird es dann schwer.
 

akumetsu

Aktives Mitglied
Registriert
19.08.2011
Beiträge
2.295
Hm... Den üblichen Reset-Voodoo hast du vermutlich schon durch, oder? Weiß jetzt nicht mehr was es da beim G4 alles gab... :o
 

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.898
Also PMU und NVRAM Reset habe ich durch.
 

Madcat

Aktives Mitglied
Registriert
01.02.2004
Beiträge
16.812
Ich habe g4Fancontrol ausprobiert, aber das hat nicht geholfen. https://macintoshgarden.org/apps/g4fancontrol.
Was zeigt denn das für eine Drehzahl an beim Lüfter? Ich könnte mir vorstellen, dass der Lüfter keinen Feedback mehr liefert und die Lüfterregelung deshalb auf den Set-Wert: max Drehzahl hoch läuft.

Bringt mich aber nicht weiter.

Ich hab grad mal in das Dokument rein geschaut, da steht halt drin, dass man die "Check Main Logic Board - I " procedure durchführen soll. Wie gesagt, ich tippe auf defekten Lüfter.
 

Roman78

Aktives Mitglied
Thread Starter
Registriert
02.10.2006
Beiträge
4.898
Lüfter habe ich ja schon mal gewechselt. Der andere macht genau das gleiche. Was die Drehzalh sagt, muss ich mal nachsehen wenn ich da wieder dran bin. Also wahrscheinlich morgen Früh.
 

Madcat

Aktives Mitglied
Registriert
01.02.2004
Beiträge
16.812
Oha, dann könnte es an der Auswertung des Lüftersignals liegen (sofern du halt wirklich schon alle Temperatursensoren überprüft hast und alle OK sind). Das wäre dann in der Tat ein Logic Board defekt :(
 
Oben