Positionierungsproblem mit HTML Tabellen, etc

  1. joedelord

    joedelord Thread Starter MacUser Mitglied

    Mitglied seit:
    12.12.2002
    Beiträge:
    481
    Zustimmungen:
    0
    Hallo liebe Macuser

    Ich werke gerade an einer kleinen Seite und habe ein bis zwei Probleme mit dem MIcrosoft IE. Alle anderen Browser (Safari, Firefox, Opera) zeigen die Seite richtig an nur IE will nicht so recht.

    Die Struktur ist auf Tabellen aufgebaut (wahrscheinlich das letzte Mal, das ich Tabellen verwende) die verschieden ineinander verschachtelt sind... Kann ich irgendwie schwer erklären, ab besten ihr testet selber. Link

    Das zweite Problem ist das der IE 6.x unter XP bei <div> die Eigenschaft float:left ignoriert.

    Ich sehe schön langsam keinen Ausweg mehr, und ein komplettes Redesign ist ausgeschlossen. Vielleicht weiß jemand einen Rat.

    danke, joedelord

    edit: Die Seite ist html strict, und sollte valid sein.
     
    joedelord, 01.04.2005
    #1
  2. Erika

    Erika MacUser Mitglied

    Mitglied seit:
    03.01.2004
    Beiträge:
    232
    Zustimmungen:
    0
    Also, ein paar Kleinigkeiten sind mir aufgefallen, obwohl ich leider nicht unter Windows testen kann momentan:

    -> Die Tabellenzellen links (Bild, Menü,...) haben keine Höhenangaben und sind nicht ausgerichtet. Ich denke mal, das sich dann der Inhalt mittig verteilt.

    -> so: <div class="menue_green"><a href="">menuee Listing</a></div>
    statt so: <a href=""><div class="menue_green">menuee Listing</div></a>

    -> valign gibt es für <table> nicht

    <p class="menue" style="margin-bottom:0px;">
    -> Du hast doch eine css datei. Dann formatiere dort und ordne die Klasse der td zu. Und nimm die <p>-tags raus. Brauchst Du doch nicht, wenn Du mit Tabellen arbeitest.

    <div class="menue_line">
    <img class="menue_line" src="../../img/h_line.gif">
    </div>
    -> doppelt - wozu?

    <a herf=""><div class="menue_green">English</div></a>
    -> tippfehler: href

    <div class="label">
    <a href="mailto:simon.wallner@gmx.at"><img src="../../img/label72.gif" alt="Simon Wallner"></a>
    <div>
    -> muss </div> sein

    <td class="bottom">
    -> bottom ist reserviert und keine Klasse

    alt="" height="" width="" border=""
    -> fehlt in den <img>-tags

    -> float läßt Text umfliessen, Du hast aber nur 2 img´s - was also willst du tun?

    Noch ein Designwunsch: Lass der Überschrift links ein wenig Platz.
    Ansonsten sieht es gut aus.

    Erika
     
    Erika, 01.04.2005
    #2
  3. joedelord

    joedelord Thread Starter MacUser Mitglied

    Mitglied seit:
    12.12.2002
    Beiträge:
    481
    Zustimmungen:
    0
    Vielen Dank für die Bemühungen. Die meisten Fehler habe ich mittlerweile schon ausgebessert. Du hast mich auf einige gute Ideen gebracht, die ich gleich ausprobieren werde.

    danke, joedelord

    ps: wer kann mir dem mit den Tabellen helfen?
     
    joedelord, 02.04.2005
    #3
  4. joedelord

    joedelord Thread Starter MacUser Mitglied

    Mitglied seit:
    12.12.2002
    Beiträge:
    481
    Zustimmungen:
    0
    ich push das thema einmal nach oben. vielleicht kann mir jemand weiterhelfen
     
    joedelord, 04.04.2005
    #4
  5. Zwergenkönig

    Zwergenkönig MacUser Mitglied

    Mitglied seit:
    09.05.2004
    Beiträge:
    994
    Zustimmungen:
    16
    Probier mal XHTML strict... Musst du nur das ändern:

    Zeile:10 Spalte:1 Schließendes link-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:12 Spalte:1 Schließendes meta-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:33 Spalte:170 Schließendes img-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:33 Spalte:99 Schließendes img-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:33 Spalte:28 Schließendes img-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:38 Spalte:4 Schließendes img-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:46 Spalte:5 Schließendes img-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:48 Spalte:789 Schließendes br-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:48 Spalte:1242 Schließendes br-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:48 Spalte:2064 Schließendes br-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:48 Spalte:2283 Schließendes br-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:48 Spalte:3103 Schließendes br-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:48 Spalte:3320 Schließendes br-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:50 Spalte:5 Schließendes img-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:55 Spalte:6 Schließendes img-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:58 Spalte:6 Schließendes img-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:95 Spalte:4 Schließendes img-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:99 Spalte:6 Schließendes img-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:102 Spalte:6 Schließendes img-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.
    Zeile:118 Spalte:43 Schließendes img-Tag wurde nicht gefunden, obwohl dies zwingend notwendig ist.

    und dann mal als xhtml speichern..
     
    Zwergenkönig, 04.04.2005
    #5
  6. joedelord

    joedelord Thread Starter MacUser Mitglied

    Mitglied seit:
    12.12.2002
    Beiträge:
    481
    Zustimmungen:
    0
    Vielen dank für die Hilfe.

    ich habe jetzt die meisten tabellen rausgenommen, und das meiste mit <div>'s formatiert. fast alles funktioniert jetzt

    danke, joedelord
     
    joedelord, 08.04.2005
    #6
Die Seite wird geladen...
Ähnliche Themen - Positionierungsproblem HTML Tabellen
  1. DJBlue
    Antworten:
    15
    Aufrufe:
    1.361
    Olivetti
    29.11.2016
  2. nicoch
    Antworten:
    6
    Aufrufe:
    386
    mreball
    13.10.2016
  3. Critizz
    Antworten:
    2
    Aufrufe:
    477
    Critizz
    03.04.2015
  4. Oliver23
    Antworten:
    16
    Aufrufe:
    1.738
    Oliver23
    27.01.2015
  5. masterseye
    Antworten:
    1
    Aufrufe:
    1.981