Piepen im Xterm loswerden

  1. Yankee

    Yankee Thread StarterMacUser Mitglied

    Mitglied seit:
    27.02.2004
    Beiträge:
    155
    Zustimmungen:
    0
    Bei der Tab-Completion und einigen Meldungen gibt das Xterm ein Piepen von sich, das ich weder durch ein "xterm*visualBell: false" in der .Xdefaults noch durch setterm, was nämlich nicht einmal vorhanden ist, ändern konnte.
    Gibt es noch andere Möglichkeiten, die ich testen könnte?
     
    Yankee, 11.08.2005
  2. marc-zrh

    marc-zrhMacUser Mitglied

    Mitglied seit:
    07.08.2005
    Beiträge:
    56
    Zustimmungen:
    0
    Der Pieps nervt wirklich

    xset q (status ausgeben)
    xset b off (bell off)

    ...z.bsp. in Deiner Fenstermanager configdatei (bei mir .fvwmrc) einbauen,

    Gruss
    Marc
     
    marc-zrh, 12.08.2005
  3. Yankee

    Yankee Thread StarterMacUser Mitglied

    Mitglied seit:
    27.02.2004
    Beiträge:
    155
    Zustimmungen:
    0
    Mh es geht um das Terminal unter Mac OS X, ist das auch an einen Window-Manager gekoppelt? xset hatte ich auch schon ausprobiert, aber jeder aufruf desselben ergibt nur
    xset: unable to open display ""

    Bei einer früheren Installation hatte ich das schon mal hinbekommen, jetzt weiß ich natürlich nicht mehr wie ;)
     
    Yankee, 12.08.2005
  4. Yankee

    Yankee Thread StarterMacUser Mitglied

    Mitglied seit:
    27.02.2004
    Beiträge:
    155
    Zustimmungen:
    0
    Habe mal $DISPLAY auf 0:0 gesetzt, jetzt funktioniert xset.
    xset q ergibt unter anderem
    "bell percent: 0 bell pitch: 400 bell duration: 100"
    nachdem ich xset b off angewendet habe.
    Allerdings ist der Ton immer noch da.
     
    Yankee, 12.08.2005
  5. Incoming1983

    Incoming1983MacUser Mitglied

    Mitglied seit:
    23.07.2005
    Beiträge:
    7.545
    Zustimmungen:
    1
    Das, was ausgegeben wird, ist doch der "Warnton". Kann man diesen irgendwo komplett abschalten?
     
    Incoming1983, 12.08.2005
  6. Yankee

    Yankee Thread StarterMacUser Mitglied

    Mitglied seit:
    27.02.2004
    Beiträge:
    155
    Zustimmungen:
    0
    finkcommander gibt diesen Ton auch aus, das Terminal von X allerdings nicht ... seehr komisch.
     
    Yankee, 12.08.2005
  7. Yankee

    Yankee Thread StarterMacUser Mitglied

    Mitglied seit:
    27.02.2004
    Beiträge:
    155
    Zustimmungen:
    0
    ok es scheint in der Tat ein System-Piepen zu sein, das unabhängig vom Terminal ist, denn vorhin hat iTunes den gleichen Ton rausgebracht. Wo kann ich den denn global abstellen, wie incoming schon meinte?
     
    Yankee, 12.08.2005
  8. cilly

    cilly

    Terminal.app > Terminal > Window Settings > Emulation > Audible Bell

    oder:

    X11.app > Preferences > Output > Use System Alert Sounds
     
    cilly, 12.08.2005
  9. Yankee

    Yankee Thread StarterMacUser Mitglied

    Mitglied seit:
    27.02.2004
    Beiträge:
    155
    Zustimmungen:
    0
    <- total blind

    ich hab da echt zig mal in den menüs geschaut ... oh man
    danke :)
     
    Yankee, 12.08.2005
  10. cilly

    cilly

    gern geschehen, dazu ist das Forum ja da.

    Viele Augen sehen mehr...

    :cool:
     
    cilly, 12.08.2005
Die Seite wird geladen...
Ähnliche Themen - Piepen Xterm loswerden
  1. promille
    Antworten:
    3
    Aufrufe:
    710
    promille
    21.05.2011
  2. promille
    Antworten:
    2
    Aufrufe:
    1.357
    promille
    09.10.2009
  3. maceis
    Antworten:
    0
    Aufrufe:
    517
  4. HJOrtmann
    Antworten:
    8
    Aufrufe:
    2.668
    HJOrtmann
    26.07.2008