phpmyadmin krieg ich nicht zum Laufen ....

mactrisha

Mitglied
Thread Starter
Mitglied seit
27.11.2003
Beiträge
740
Hi all

ich verstehe das nicht und brauche dringend Hilfe. Endlich habe ich mein neues MacBook und habe jetzt PHP 5.2.5 aktiviert und mir MySQL5 installiert.

PHP läuft, das sagt mir die phpinfo.

Ich habe mir dann von mysql.com das .dmg "mysql-5.0.67-osx10.5-x86_64.dmg" runtergeladen und installiert. Mit StartupItem und prefPane.

prefPane in den Systemeinstellungen funktioniert, ich kann MySQL stoppen oder starten. Soweit müsste ja jetzt alles perfekt sein für die Installation von phpmyadmin.

Denkste!

phpmyadmin zu installieren ist doch kein Akt und trotzdem funktioniert es bei mir nicht.

FEHLERMELDUNG BEIM AUFRUFEN VON http://127.0.0.1/phpmyadmin/ IST:

Fehler
MySQL meldet: Dokumentation
#2002 - Der Server antwortet nicht. (evtl. ist auch der Socket des lokalen MySQL-Servers socket nicht korrekt konfiguriert)

Wenn ich das Setup-Skript von phpmyadmin auführe, dann schreibt mir das eine !!!LEERE!!! config.inc.php Datei in das vorher anzulegende Verzeichnis http://127.0.0.1/phpmyadmin/config und es geht natürlich nichts.

Was muss ich tun? Woran liegt das? MySQL läuft doch.

Bitte, Danke,
mactrisha.
 

maceis

Aktives Mitglied
Mitglied seit
24.09.2003
Beiträge
16.879
Ich würde im ersten Schritt einmal sicherstellen, ob MySQL wirklich läuft.
z.B. im Terminal mit folgendem Kommando:
Code:
ps auxwww | grep mysql
Das SetupSkript habe ich übrigens noch nie ausgeführt. Nur die vorhandene geringfügig angepasst (Benutzer, Passwort, socket). Den socket braucht man inzwischen nicht mehr anpassen, da auch unter Mac OS X der default Pfad verwendet wird.

Edit:
Ach so, noch was. Vielleicht magst Du Dir mal Sequel Pro anschauen.
 
Zuletzt bearbeitet von einem Moderator:

Jakob

Aktives Mitglied
Mitglied seit
05.01.2004
Beiträge
1.070
Einfacher als es im OS zu installieren und zu konfigurieren, geht’s mit MAMP. Gibt viele Diskussionen und Empfehlungen dazu hier im Forum, einfach mal suchen.

@maceis: Danke für den Tipp zu Sequel Pro.
 

Kaito

Aktives Mitglied
Mitglied seit
31.12.2005
Beiträge
7.020
Ich habe mir dann von mysql.com das .dmg "mysql-5.0.67-osx10.5-x86_64.dmg" runtergeladen und installiert. Mit StartupItem und prefPane.
Gibt aber 5.1.29, sagt zumindest die Page?
Und was? Das prefpan funktioniert? Bei mir tut es das nicht, hieß damals das wäre ein Fehler, musste den Server per Terminal starten.
Kann ich MySQL aktualisieren indem ich die neue Version einfach drüber "bügle"?
 

maceis

Aktives Mitglied
Mitglied seit
24.09.2003
Beiträge
16.879
Da fällt mir gerade auf: "...x86_64.dmg" Hast Du überhaupt einen 64 bit Rechner?
 

mactrisha

Mitglied
Thread Starter
Mitglied seit
27.11.2003
Beiträge
740
64 bit Rechner?
Hallo maceis,

ich weiß nicht, was ein 64 bit Rechner ist, ich habe das aktuelle MacBookPro 15,4 " Widescreen Intel.

Ich bin gerade dabei, alle Hinweise auszuprobieren.

Salü,
mactrisha.

P.S.: Im Übrigen hat die Installation keinen Fehler aufgeworfen und alles erfolgreich installiert.
 
Zuletzt bearbeitet:

mactrisha

Mitglied
Thread Starter
Mitglied seit
27.11.2003
Beiträge
740
Code:
ps auxwww | grep mysql
Hallo maceis,

wenn ich diesen Befehl ins Terminal eingebe, dann kommt die folgende Ausgabe, sagt das, dass mySQL läuft oder nicht?

Salü,
mactrisha.
 

Anhänge

Zuletzt bearbeitet:

mactrisha

Mitglied
Thread Starter
Mitglied seit
27.11.2003
Beiträge
740
Das prefpan funktioniert?
Hallo Kaito,

das prefPane funktioniert denk ich schon, wenn so aussieht, oder?

Salü,
mactrisha.

ICH DANKE EUCH SCHON MAL JETZT FÜR EURE BEITRÄGE. Jetzt versuche ich noch SequelPro.
 

Anhänge

mactrisha

Mitglied
Thread Starter
Mitglied seit
27.11.2003
Beiträge
740
Sequel Pro anschauen.
Hallo maceis,

wenn ich SequelPro installiere, dann bekomme ich diese Fehlermeldung.

Salü,
mactrisha.
 

Anhänge

maceis

Aktives Mitglied
Mitglied seit
24.09.2003
Beiträge
16.879
Ich denke Du benötigst die nicht 64_bit Variante von MySQL. Ein wunder, dass die überhaupt läuft (ja, die Terminal Ausgabe bestätigt das)
...
dann bekomme ich diese Fehlermeldung.
...
Er findet den Socket nicht.
Poste mal (bitte Code Tags verwenden; das sind die mit #) die Ausgabe von
Code:
ls -la /tmp/
und von
Code:
ls -la /var/mysql/
 

mactrisha

Mitglied
Thread Starter
Mitglied seit
27.11.2003
Beiträge
740
Code:
ls -la /tmp/
gibt aus:

Code:
Last login: Sun Nov 23 17:54:04 on console
00-000-000-000:~ meinname$ ls -la /tmp/
total 8
drwxrwxrwt  11 root          wheel   374 23 Nov 17:55 .
drwxr-xr-x@  7 root          wheel   238  9 Okt 19:04 ..
-rw-r--r--   1 meinname  wheel  2219 23 Nov 17:54 amt.log
-rw-------   1 _www          wheel     0 23 Nov 17:54 aprTVFUjL
-rw-------   1 _www          wheel     0 23 Nov 17:54 aprsK6LdX
srwxrwxrwx   1 meinname  wheel     0 23 Nov 17:54 com.hp.launchport
drwx------   3 meinname  wheel   102 23 Nov 17:54 launch-JWCzhv
drwx------   3 meinname  wheel   102 23 Nov 17:54 launch-YZ2scu
drwx------   3 meinname  wheel   102 23 Nov 17:54 launch-moqYca
drwx------   3 meinname  wheel   102 23 Nov 17:54 launchd-73.keDvOi
srwxrwxrwx   1 _mysql        wheel     0 23 Nov 17:54 mysql.sock
00-000-000-000:~ meinname$
 

mactrisha

Mitglied
Thread Starter
Mitglied seit
27.11.2003
Beiträge
740
Code:
ls -la /var/mysql/
und das gibt aus:

Code:
Last login: Sun Nov 23 17:56:34 on ttys001
00-000-000-000:~ meinname$ ls -la /var/mysql/
ls: /var/mysql/: No such file or directory
00-000-000-000:~ meinname$
Was bedeutet das weiter? Was ist zu tun, wenn die Socket-Datei nicht gefunden wird?

Danke für deinen Support, maceis,
Salü,
mactrisha.
 

mactrisha

Mitglied
Thread Starter
Mitglied seit
27.11.2003
Beiträge
740
Ich denke Du benötigst die nicht 64_bit Variante ...
Hallo maceis,

also in der Hife meines MacBookPro (nach 64-bit durchsucht) steht:

Wenn Sie mit einem ab Anfang 2008 oder später erhältlichen Mac Pro oder MacBook Pro arbeiten, können Sie eine 64-Bit-Version von Windows Vista verwenden.
Da mein MacBookPro erst Anfang September zu mir kam, schließe ich, dass es in 64-bit Computer, was auch immer das ist, sein muss.

Salü ...
mactrischa.
 

mactrisha

Mitglied
Thread Starter
Mitglied seit
27.11.2003
Beiträge
740
Hi maceis,

und auf der Apple-Website heißt es:

Es ist fortschrittlich.

Voraussetzung dafür, auch anspruchvollste Aufgaben schnell und einfach zu erledigen, ist eine moderne, leistungsfähige Technologie. Mac OS X baut auf einer stabilen Unix Grundlage auf, bietet echte 64-Bit-Leistung und umfasst Unterstützung für branchenführende Grafikanimation. Doch das Beste ist: Sie müssen all dies nicht unbedingt wissen. Es reicht völlig, wenn Sie einfach Ihren Mac starten und verwenden.
Also die 64-bit mySQL Version müsste schon passen.

Salü,
mactrisha.
 

maceis

Aktives Mitglied
Mitglied seit
24.09.2003
Beiträge
16.879
Ja, 64 bit ist dann wohl okay.

Das komische ist, dass in /tmp/ der Socket (mysql.sock) vorhanden ist. Ich vermute daher ein Problem mit den Berechtigungen.

Die Frage ist jetzt, ob Dein MySQL Server bereits einen Benutzer und ein Passwort hat und ob Du Dich im Terminal verbinden kannst. Evtl. sind auch die test Datenbanken schon installiert.

Kannst also jetzt im Terminal folgendes probieren.
1.)
Code:
mysql test
2.)
Code:
mysql -u [I]benutzer[/I] -p[I]geheim[/I]
Wobei benutzer durch den Benutzernamen und geheim durch das Passwort auszutauschen ist. Achtung: nach -p kommt kein Leerzeichen.

Es empfiehlt sich auch, das einschlägige Kapitel in der MySQL Doku zu lesen. Kapitel 2.9 dürfte u.a. von Interesse sein.
 

mactrisha

Mitglied
Thread Starter
Mitglied seit
27.11.2003
Beiträge
740
Code:
mysql test
Hi maceis,

wenn ich das machen, dann kommt:

Code:
Last login: Mon Nov 24 22:59:14 on ttys000
00-000-000-000:~ meinname$ mysql test
-bash: mysql: command not found
00-000-000-000:~ meinname$
Mache ich da was falsch?

Ich hab in der mySQL-Doku über die Berechtigungen das Kapitel gelesen, aber hat mir nicht weitergeholfen. User mit Passwort habe ich noch keinen angelegt, da auch der Befehl

Code:
Last login: Mon Nov 24 23:05:40 on ttys000
00-000-000-000:~ meinname$ mysql -u root -pmeinrootpasswortdescomputers
-bash: mysql: command not found
00-000-000-000:~ meinname$
ergibt.

Ich bin so hilflos! Generell alle Befehle aus der mySQL-Doku die mit > shell beginnen ergeben in meinem Terminal command not found.

Wenn ich zur mysql.sock Datei in private/temp visuell hinnavigiere und diese doppelklicke, dann kommt eine Fehlermeldung (siehe Anhangbild). Mir ist dabei allerdings jetzt aufgefallen, dass meine mysql.sock-Datei in private/temp liegt ist das richtig? Ist das das gleiche wie /tmp/?

Eine andere mysql.sock-Datei ist allerdings nicht auf meinem MacBookPro per Suchfnktion findbar.

Außerdem habe ich auf meinem Vorgänger PowerBookG4 (10.2.1 System mit mySQL4.irgendwas) nachgesehen, welche Rechte die mysql.sock Datei besitzt und ich konnte keinen Unterschied feststellen. Ich habe die Rechteaugabe auch übers Terminal, also nicht nur visuell geprüft, ergibt beidesmal:

Code:
srwxrwxrwx   1 _mysql        wheel     0 23 Nov 17:54 mysql.sock
Ich bin verzweifelt. Alles andere von mySQL 5 funktioniert ja nachweislich und ich verstehe nicht, warum die Socketdatei nicht gefunden wird.



Salü,
mactrisha.
 

Anhänge

mactrisha

Mitglied
Thread Starter
Mitglied seit
27.11.2003
Beiträge
740
Hi maceis,

nochmal ich. Könnte es sein, dass ich erst dem mySQL Server sagen muss, dass meine Socketdatei in /private/tmp/ liegt? Wie siehst du das?

Code:
Last login: Tue Nov 25 15:13:33 on ttys000
00-000-000-000:~ meinname$ mysql_config
-bash: mysql_config: command not found
00-000-000-000:~ meinname$ /usr/local/mysql/bin/mysql_config
Usage: /usr/local/mysql/bin/mysql_config [OPTIONS]
Options:
        --cflags         [-I/usr/local/mysql/include  -g -Os -arch x86_64 -fno-common   -D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DIGNORE_SIGHUP_SIGQUIT]
        --include        [-I/usr/local/mysql/include]
        --libs           [-L/usr/local/mysql/lib -lmysqlclient -lz -lm     -lmygcc]
        --libs_r         [-L/usr/local/mysql/lib -lmysqlclient_r -lz -lm     -lmygcc]
        --socket         [/tmp/mysql.sock]
        --port           [0]
        --version        [5.0.67]
        --libmysqld-libs [-L/usr/local/mysql/lib -lmysqld -lz -lm       -lmygcc]
00-000-000-000:~ meinname$
Salü und Danke,
mactrisha.
 

maceis

Aktives Mitglied
Mitglied seit
24.09.2003
Beiträge
16.879
Nein, "command not found" bedeutet, dass bei Dir das Verzeichnis, in dem das mysql Programm liegt, noch nicht im Suchpfad ist.
Das bedeutet, dass Du den vollständigen Pfad angeben musst.
Meist wird mysql in /usr/local/mysql/bin/ installiert. Den Pfad sieht man oben übrigens in dem "Usage:"-Hinweise.
Das heißt, Du müsstest 'mysql' in den o.g. Kommandos durch '/usr/local/mysql/bin/mysql' ersetzen, also zum Beispiel

/usr/local/mysql/bin/mysql test
 

mactrisha

Mitglied
Thread Starter
Mitglied seit
27.11.2003
Beiträge
740
... Kommandos durch '/usr/local/mysql/bin/mysql' ersetzen ...

Hi maceis,

sorry, ich bin so ein Dummy! Also ich danke dir tausendmal! Jetzt habe ich es geschafft.


1
* * *
Also ich konnte mich mit keinem User anmelden, weder mit localhost noch mit root.
* * *

Terminaleingabe:
Code:
/usr/local/mysql/bin/mysql -u localhost -pmeinwort
Terminalausgabe:
Code:
00-000-000-000:~ meinname$ /usr/local/mysql/bin/mysql -u localhost -pmeinwort
ERROR 1045 (28000): Access denied for user 'localhost'@'localhost' (using password: YES)

2
* * *
Dann habe ich wie es in der mySQL Doku steht für alle User ein Passwort gesetzt Erst für den localhost und auch für den root.
* * *

Terminaleingabe:
Code:
/usr/local/mysql/bin/mysql -u root

und dann

mysql> SET PASSWORD FOR ''@'localhost' = PASSWORD('meinwort');
Terminalausgabe:
Code:
00-000-000-000:~ meinname$ /usr/local/mysql/bin/mysql -u root
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 9
Server version: 5.0.67 MySQL Community Server (GPL)

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> SET PASSWORD FOR ''@'localhost' = PASSWORD('meinwort');
Query OK, 0 rows affected (0.00 sec)

mysql>

3
* * *
Dann konnte ich mich gleich mit User localhost und dem neuen Passwort verbinden.
* * *

Terminaleingabe:
Code:
/usr/local/mysql/bin/mysql -u localhost -pmeinwort
Terminalausgabe:
Code:
00-000-000-000:~ meinname$ /usr/local/mysql/bin/mysql -u localhost -pmeinwort
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 11
Server version: 5.0.67 MySQL Community Server (GPL)

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>

4
* * *
Das Passwort habe ich auch dann für den zweite User root gesetzt.
* * *

Terminaleingabe:
Code:
/usr/local/mysql/bin/mysql -u root

und dann

mysql> SET PASSWORD FOR 'root'@'localhost' = PASSWORD('meinwort');
Terminalausgabe:
Code:
00-000-000-000:~ meinname$ /usr/local/mysql/bin/mysql -u root
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 12
Server version: 5.0.67 MySQL Community Server (GPL)

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> SET PASSWORD FOR 'root'@'localhost' = PASSWORD('meinwort');
Query OK, 0 rows affected (0.00 sec)

mysql>

5
* * *
So, und dann habe ich Sequel Pro installiert und es hat sofort top funktioniert.
* * *

Nur phpmyadmin geht nocht immer nicht, es kommt noch immer der oben genannte Fehler. Aber wenn ich erstmal Sequel Pro laufen habe, das übrigens super ist, dann brauche ich phpmyadmin nicht.

Also, maceis, ein super großes Danke für deinen Support und deine geduldige Hilfe, du bist für mich DER GOTT der Befehlszeilengötter!


Salü,
mactrisha.


P.S.: Falls ich phpmyadmin doch noch zum Laufen bekomme, poste ich hier, wie es dann ging. Ich bin da gerade noch am Frickeln.
 
Oben