1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

PHP Fehlermeldungen aktiviren? 10.3

Dieses Thema im Forum "Web-Programmierung" wurde erstellt von Garrancho, 22.12.2003.

  1. Garrancho

    Garrancho Thread Starter MacUser Mitglied

    Mitglied seit:
    07.05.2003
    Beiträge:
    504
    Zustimmungen:
    25
    Hallo,

    seit 10.3 zeigt mein PHP keine Fehlermeldungen mehr... das hat leider nix damit zu tun, daß ich fehlerfrei programmiere... :rolleyes:

    Was muß ich in der php.ini ändern um wieder die guten alten PHP Fehlermeldungen zu sehen?
     
  2. ment

    ment MacUser Mitglied

    Mitglied seit:
    21.11.2003
    Beiträge:
    48
    Zustimmungen:
    0
  3. Delmar

    Delmar MacUser Mitglied

    Mitglied seit:
    28.09.2002
    Beiträge:
    803
    Zustimmungen:
    1
    Hi Garrancho,

    in der "php.ini" gibt es den Bereich "Error Handling". Dort steht alles genau
    beschrieben, was Du wann auskommentieren musst, um bestimmte Fehler-
    meldungen angezeigt zu bekommen.


    Gruß
    Delmar
     
  4. Garrancho

    Garrancho Thread Starter MacUser Mitglied

    Mitglied seit:
    07.05.2003
    Beiträge:
    504
    Zustimmungen:
    25
    hmmm, irgendwie funzt das bei mir nicht...

    ich habe in der php.ini.default (ich hoffe das ist die richtige...) folgendes geändert:

    error_reporting = E_ALL
    display_errors = On
    display_startup_errors = On

    - leider werden mir immer noch keine Fehler angezeigt...

    HILFE!
     
  5. HAL

    HAL


    Schon mal probiert, selbige Datei als "php.ini" abzuspeichern?

    ;)

    Nachtrag: Haltet mich für nen Klugkacker, aber bitte das Neustarten
    des Servers nach Änderungen in der .ini nicht vergessen.
     
  6. Garrancho

    Garrancho Thread Starter MacUser Mitglied

    Mitglied seit:
    07.05.2003
    Beiträge:
    504
    Zustimmungen:
    25
    Erst mal Danke für die Antworten!

    Wo muß ich die php.ini speichern? Das Verzeichnis in dem die php.ini.default liegt (/private/etc/) lässt mich über save as nix speichern...:confused:
     
  7. HAL

    HAL

    Stimmt... *patsch* Hab ich vergessen zu sagen:

    Zunächst im Finder unter Gehe zu > Gehe zum Ordner
    /private eingeben und öffnen. Dann solltest Du dort
    den Ordner "etc" sehen. Jetzt die Zugiffsrechte für
    selbigen von "nur lesen" auf "lesen & schreiben"
    setzen. Dann kannst Du auch die "php.ini" in dem
    Verzeichnis abspeichern.
     
  8. Garrancho

    Garrancho Thread Starter MacUser Mitglied

    Mitglied seit:
    07.05.2003
    Beiträge:
    504
    Zustimmungen:
    25
    nun klappt es - allerdings musste ich die php.ini ändern die in

    /usr/local/php/lib/

    liegt - warum auch immer...

    Es funktioniert, endlich sehe ich wieder was ich falsch mache carro
     
  9. Garrancho

    Garrancho Thread Starter MacUser Mitglied

    Mitglied seit:
    07.05.2003
    Beiträge:
    504
    Zustimmungen:
    25
    Grompf - jetzt werden "Fehler" angezeigt, die unter Mac OS 10.2 nicht angezeigt wurden...
    kann vielleicht jemand den entsprechenden Teil aus der Mac OS 10.2 php.ini posten damit ich OS 10.3 anpassen kann????


    (da die Skripte funktionieren gehe ich davon aus, daß die neu angezeigten fehler lediglich auf "unschönes" hinweisen...)
     
  10. Garrancho

    Garrancho Thread Starter MacUser Mitglied

    Mitglied seit:
    07.05.2003
    Beiträge:
    504
    Zustimmungen:
    25
    ich habs:

    error_reporting = E_ALL

    sollte

    error_reporting = E_ALL & ~E_NOTICE

    sein.
     
Die Seite wird geladen...

Diese Seite empfehlen