Benutzerdefinierte Suche

PHP Apache Problem

  1. cymeg

    cymeg Thread StarterMacUser Mitglied

    Mitglied seit:
    20.03.2005
    Beiträge:
    25
    Zustimmungen:
    0
    Hi!
    Ich habe auf meinem osx (10.3.8) ja einen Apache standartmässig.
    Den habe ich angeknipst und so konfiguriert, das er auch index.php dateien als index files anerkennt. Nun habe ich ein BBoard in das Hauptverzeichnis reingepackt und die index.php wird auch von ausserhalb geladen wenn ich die Adresse "http://meineip" eintippe. Das Problem ist nur, dass mit jedem Browser der quelltext der PHP Datei angezeigt wir und nicht die Seite, so wie es eigentlich sein sollte.
    Habt ihr eine Idee woran das liegt?

    http://cymeg.myftp.org könnt ihr selber testen.
     
    cymeg, 07.04.2005
  2. mikne64

    mikne64MacUser Mitglied

    Mitglied seit:
    02.04.2004
    Beiträge:
    3.097
    Zustimmungen:
    92
    Hallo CyMeg,

    willkommen im Forum! :)

    Problem ist, daß die Seite nicht interpretiert, sondern der Quelltext dargestellt wird. Schon mal in der Datei "httpd.conf" geschaut, ob die Einträge richtig sind? Was passiert bei http://localhost/.../index.php?

    Nach den Änderungen in der Datei "httpd.conf" hast Du hoffentlich auch den Apache neu gestoppt und neu gestartet?

    Viele Grüße
    Michael
     
    mikne64, 07.04.2005
  3. Adrenalinpur

    AdrenalinpurMacUser Mitglied

    Mitglied seit:
    07.07.2004
    Beiträge:
    666
    Zustimmungen:
    0
    wie jetzt? soll der Source angezeigt werden oder nicht?
     
    Adrenalinpur, 07.04.2005
  4. cymeg

    cymeg Thread StarterMacUser Mitglied

    Mitglied seit:
    20.03.2005
    Beiträge:
    25
    Zustimmungen:
    0
    Danke für deine Antwort!
    Aber klar hab ich ihn resettet.
    Ich glaube ich muss noch was in der Config Datei für die MIME Typen eintragen, damit
    der Apache weiss, das es sich um php handelt und das dementsprechent übersetzt.
    Aber ich weis leider nicht wie.
    hm, mal gucken, morgen ist auch noch ein tag
     
    cymeg, 07.04.2005
  5. cymeg

    cymeg Thread StarterMacUser Mitglied

    Mitglied seit:
    20.03.2005
    Beiträge:
    25
    Zustimmungen:
    0
    @ Adrenalinpur
    Hi! Nein, natürlich nicht, nur die PHP Seite an sich (Das Forum halt).
    aber er zeigt ja nur den source an ;(
     
    cymeg, 07.04.2005
  6. wegus

    wegusMacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    14.982
    Zustimmungen:
    1.545
    wegus, 07.04.2005
  7. maceis

    maceisMacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Mit MIME hat das nichts zu tun.
    Du benötigst einige Einträge in der httpd.conf.
    Mache davon müssten eigentlich schon da sein, die übrigen (i. d. R. 1278, 1279) musst Du ergänzen.
    Die Zeilennummern können Dir als Anhaltspunkt dienen, wo das alles (ungefähr) zu stehen hat

    243 LoadModule php4_module libexec/httpd/libphp4.so
    ...
    288 AddModule mod_php4.c
    ...
    1276 <IfModule mod_php4.c>
    1277 # If php is turned on, we repsect .php and .phps files.
    1278 AddType application/x-httpd-php .php
    1279 AddType application/x-httpd-php-source .phps
    1280
    1281 # Since most users will want index.php to work we
    1282 # also automatically enable index.php
    1283 <IfModule mod_dir.c>
    1284 DirectoryIndex index.html index.htm index.php
    1285 </IfModule>
    1286 </IfModule>


    HTH
     
    maceis, 07.04.2005
  8. cymeg

    cymeg Thread StarterMacUser Mitglied

    Mitglied seit:
    20.03.2005
    Beiträge:
    25
    Zustimmungen:
    0
    Cool, Das war das Problem.
    Ich habe jetzt die PHP Module laden lassen und den Server neu gestartet.
    Funktioniert alles wie es soll.
    Tnahx
     
    cymeg, 07.04.2005
  9. mikne64

    mikne64MacUser Mitglied

    Mitglied seit:
    02.04.2004
    Beiträge:
    3.097
    Zustimmungen:
    92
    Hallo,

    bei OS X 10.3.6 sind die von maceis erwähnten Zeilen 1278 und 1279 schon da, es reicht sie auszukommentieren.

    Viele Grüße
    Michael
     
    mikne64, 07.04.2005
  10. Saski

    SaskiMacUser Mitglied

    Mitglied seit:
    06.02.2005
    Beiträge:
    644
    Zustimmungen:
    0
    Bearbeitet: Zu langsam :rolleyes:
     
    Saski, 07.04.2005
Die Seite wird geladen...
Ähnliche Themen - PHP Apache Problem
  1. stubser
    Antworten:
    20
    Aufrufe:
    1.446
  2. gaby23
    Antworten:
    4
    Aufrufe:
    451
  3. lotter1
    Antworten:
    1
    Aufrufe:
    601
    rpoussin
    24.01.2008
  4. Axtrim
    Antworten:
    3
    Aufrufe:
    666
  5. sasi
    Antworten:
    5
    Aufrufe:
    395