Benutzerdefinierte Suche

Performance 100 MBit Netz für Filmwiedergabe

  1. McHennsy

    McHennsy Thread StarterMacUser Mitglied

    Mitglied seit:
    29.03.2003
    Beiträge:
    525
    Zustimmungen:
    0
    Hallo,

    ich hoffe ich kann bei Euch eine Antwort auf meine Frage bekommen.

    Habe ein eigenartiges Problem welches ich mir nicht erklären kann.

    Zuhause habe ich eine kleines Netzwerk welches über einen 100 MBit Switch verbunden ist. In dieses Netzwerk habe ich eine LAN-Drive (Platte mit Netzwerkanschluss) eingebunden auf welcher ich meine Filme (aufgenommen mit EyeTV) ablegen möchte.

    Wenn ich eine solche Aufnahme (zB. 2 GB) auf die Platte kopiere geht das eigentlich recht zügig (ca. 15 Minuten). Will ich jedoch den Film direkt von der Platte ansehen, dann kommt es immer zu Ton- und Bildaussetzern. Kurz gesagt scheint es so, als würde die Netzwerkgeschwindigkeit nicht ausreichen.
    Die Aufnahme hat aber eine Länge von ca. 2 Stunden.

    Im Aktivitätsmonitor kann ich umter netzwerk sehen, dass die Daten ziemlich stark schwanken. Starke ausschläge nach oben und dann (bei den Aussetzern) wieder auf Null.

    Wie kann das sein? Wie kann das verhindert werden?

    Danke für Eure Hilfe!

    Gruß
    Michi
     
    McHennsy, 03.04.2006
  2. Ghettomaster

    GhettomasterMacUser Mitglied

    Mitglied seit:
    06.03.2005
    Beiträge:
    821
    Zustimmungen:
    5
    Das kann sowohl an der CPU des LAN Drives, als auch am Player liegen. Falls möglich solltest du diesen so einstellen das er immer ein paar MB cached. Am besten ist du versuchst mal VLC und guggst obs damit immernoch ruckelt.

    CU
    Ghettomaster
     
    Ghettomaster, 03.04.2006
  3. McHennsy

    McHennsy Thread StarterMacUser Mitglied

    Mitglied seit:
    29.03.2003
    Beiträge:
    525
    Zustimmungen:
    0
    Hallo Ghettomaster,

    danke für Deine Antwort.

    Ich habe VLC schon probiert. Kann man da die Puffergröße einstellen?
    Bin gerade nicht zuhause, deshalb kann ich das nicht selbst überprüfen.

    Gruß
    Michi
     
    McHennsy, 03.04.2006
  4. Generalsekretär

    GeneralsekretärMacUser Mitglied

    Mitglied seit:
    06.06.2005
    Beiträge:
    829
    Zustimmungen:
    1
    Sind noch andere Geräte im Netz?
    Oder braucht evtl. der Netzkartentreiber so viel Performance für sich selbst?

    Evtl. kannst Du mit Ethereal oder einem anderen Packetsniffer feststellen, ob außer der Platte noch etwas anderes Verkehr verursacht.
     
    Generalsekretär, 03.04.2006
  5. Ghettomaster

    GhettomasterMacUser Mitglied

    Mitglied seit:
    06.03.2005
    Beiträge:
    821
    Zustimmungen:
    5
    Das ist eine gute Frage, ich denke schon (für einen Video LAN Client wärs nur logisch), kann es dir aber nicht mit Bestimmtheit sagen, da ich grad nicht am Mac sitz und das Optionenmenü des VLC 5mal umfangreicher ist als das von OSX. :D

    CU
    Ghettomaster
     
    Ghettomaster, 04.04.2006
  6. hatty

    hattyMacUser Mitglied

    Mitglied seit:
    08.04.2003
    Beiträge:
    285
    Zustimmungen:
    0
    hi McHennsy,
    wie sieht es denn mit den Einstellungen deiner NIC aus? Ist dort 100MBit eingestellt? Und welcher Duplexmode: half oder full? Kannst du unter den Systemeinstellungen/Netzwerk/Ethernet einstellen. Die aktuellen Einstellungen schaue ich mir immer im Terminal mit dem Befehl ifconfig an. Vielleicht gibt es einen einfacheren Weg. :rolleyes:
    Falls du "Automatisch" eingestellt hast, würde ich mit den Einstellungen "100MBit/full" und "100MBit/half" experimentieren. 100MBit/full hört sich erstmal gut an, aber manchmal kommt man mit 100MBit/half schneller ans Ziel. Warum würde hier zu weit führen. ;)
    Das Kopieren von ca. 2GB in ca. 15 Minuten entpricht einer Transferrate von ca. 2,2 MB/s. In einem geswitchten FastEthernet-Netzwerk ohne viel Last würde ich eher eine Transferrate von ca. 5-6MB/s erwarten. :(
    Also schau mal nach, dann schaun mer mal weiter. :D
     
    hatty, 04.04.2006
  7. Incoming1983

    Incoming1983MacUser Mitglied

    Mitglied seit:
    23.07.2005
    Beiträge:
    7.545
    Zustimmungen:
    1
    Das liegt tatsächlich am OS X, eine Lösung dafür habe ich jedoch auch nicht gefunden. Liegt auch nicht an den Playern, es tritt unter vielen Playern auf (VLC, mplayer etc.).

    Die Bandbreite ist ok, jedoch werden zu wenig Daten im voraus gecached, so daß es zu den Aussetzern kommt, da die Zugriffszeit via smb natürlich etwas höher ist, als direkt von der Platte runter.

    Hat also nichts mit deinem Netzwerk oder der NAS-Platte zu tun. Ebensowenig mit dem Fileserver.
     
    Incoming1983, 04.04.2006
  8. jgerlach

    jgerlachMacUser Mitglied

    Mitglied seit:
    18.05.2003
    Beiträge:
    125
    Zustimmungen:
    0
    Hallo,

    Ich nutze EyeTV und VideoStreaming über 100Mbit wie über Wireless Lan (mit EyeHome). Ich habe absolut keine Probleme und Aussetzer. das hilft dir jetzt möglicherweise nicht wirklich weiter, zeigt aber das es gehen sollte.

    Jens
    P.S. selbst Livestream über WL mit Dreambox ist kein Problem genause Problemlos geht ein EyeTV Livestream über CyTV.
     
    jgerlach, 04.04.2006
  9. McHennsy

    McHennsy Thread StarterMacUser Mitglied

    Mitglied seit:
    29.03.2003
    Beiträge:
    525
    Zustimmungen:
    0
    Hmm? Bei dem einen gehts, bei dem anderen nicht! Komische Sache!
    Ich habe mal die VLC Einstellungen angesehen und bin fast vom Stuhl gefallen. So viele Optionen wo ich keine Ahnung habe was die bringen! Da fasse ich lieber nichts an! ;)
     
    McHennsy, 05.04.2006
Die Seite wird geladen...