1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

OS X Zugriff auf Windows 2003 Domain

Dieses Thema im Forum "Internet- und Netzwerk-Hardware" wurde erstellt von detzi, 19.05.2005.

  1. detzi

    detzi Thread Starter MacUser Mitglied

    Mitglied seit:
    19.05.2005
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo!

    Gleich vorweg: ich bin der absolute Mac-Newbie und hab so ziemlich keinen Schimmer von dem Zeug... :)

    Hier ist mein Problem: Ich brauch von einem Mac mit OS 10.3.x (genaue Version weiß ich grad nicht) Zugriff auf einen Fileserver der in einer Windows 2003 Active Directory Domäne hängt. Wenn ich über den Finder und der Option "Mit Server verbinden..." zB eingebe smb://servername/freigabe dann bekomme ich die Aufforderung Domäne, Benutzername und Passwort einzugeben. Nun, das ist gut so und wenn ich alles richtig eingebe bekomme ich auch Zugriff.
    Nun soll aber das ganze so aussehen, dass 1. das Netzlaufwerk beim Systemstart gemountet wird und 2. der Benutzer keine Passwörter eingeben muss.
    Das 1. Problem hab ich mit einem Alias gelöst.
    Das 2. Problem bereitet mir wahrlich Kopfschmerzen...wenn ich zb smb://username@servername/freigabe eingebe, muss ich nur die Domäne und das Passwort eingeben. Nun, man glaub wenn man smb://username:passwort@servername/freigabe eingibt, dass man vielleicht nur die Domäne eingeben muss...dem ist aber nicht so. Es geht einfach nicht. Er bricht mit Fehler -36 ab.
    Diese Schreibweise funktioniert nur dann, wenn der username ein LOKALER Benutzer auf dem Server ist. Er ist aber Domänenuser.
    In Linuxumgebungen gibt es da die Schreibweise smb://Domäne\Username:passwort@servername\Freigabe. Wenn ich das auf dem Mac mache bekomme ich die Fehlermeldung dass Username oder Passwort falsch sind...

    So, ich hoff ich hab nicht allzu kompliziert geschrieben. :(

    Vielen Dank schon mal, ich hoffe es hat irgendjemand eine Idee!!!
     
  2. detzi

    detzi Thread Starter MacUser Mitglied

    Mitglied seit:
    19.05.2005
    Beiträge:
    3
    Zustimmungen:
    0
    hat sich noch nie jemand mit soetwas herumschlagen müssen?
     
  3. Funktioniert die automatische Anmeldung auch nicht wenn Username+Passwort im Schlüsselbund gespeichert sind? Hab das selbst noch nie gemacht, aber schon öfter gelesen, dass man einfach nur einen Alias in die Startobjekte zieht (hast du ja schon) und das Passwort im Schlüsselbund speichern muss.

    Leider kein wirklicher Tipp, da du das vermutlich schon versucht hast, oder?

    MfG, juniorclub.
     
  4. detzi

    detzi Thread Starter MacUser Mitglied

    Mitglied seit:
    19.05.2005
    Beiträge:
    3
    Zustimmungen:
    0
    leider kann man anscheinend im schlüsselbund nicht die domäne mitspeichern. es würde funktionieren wenn der benutzer lokal auf dem server vorhanden ist. aber der benutzer ist eben ein domänenbenutzer und den gibts lokal nicht.
     
  5. Mr. D

    Mr. D MacUser Mitglied

    Mitglied seit:
    24.10.2003
    Beiträge:
    3.384
    Zustimmungen:
    124
    So geht das:
    smb://domain;username:passwort@server/share
     
  6. Mr. D

    Mr. D MacUser Mitglied

    Mitglied seit:
    24.10.2003
    Beiträge:
    3.384
    Zustimmungen:
    124
    Das ganze noch hübsch in ein Applescript verpackt sieht so aus und dann als Programm sichern und in die Startobjekte legen:

    tell application "Finder"
    activate
    mount volume "smb://domain;username:passwort@server/share1"
    mount volume "smb://domain;username:passwort@server/share2"
    mount volume "smb://domain;username:passwort@server/share3"
    end tell