OS X: Angelegten Benutzer löschen?

anda

Neues Mitglied
Thread Starter
Registriert
03.07.2002
Beiträge
8
Hallo zusammen,

wie kann ich unter OS X einen angelegten Benutzer löschen bzw. der Benutzer ist schon gelöscht, allerdings bleiben die Ordner vorhanden mit dem namen xyz Gelöscht. Dieser Ordner lässt sich nicht entfernen.

Hat jemand eine Idee?

Gruß
Andy
 

DJAG

Aktives Mitglied
Registriert
08.04.2002
Beiträge
1.522
Benutzer löschen

Es gibt einen einfachen und einen "korrekten"- und einen UNIX Weg. Korrrekt: Zuerst folgendes, du kannst unter OS X best. Objekte nur als sog. "root" löschen. Dieser Account hat alle rechtee am rechner, der Administrotoe kann nicht alles, so zum Beispiel Benutzer löschen. Wenn du noch keinen Root angelegt hast öffne das Programm im Ordner Aplications/Utilities/ NetInfoManager. Siehr ein wenig wie ein DateiBrowser aus, ist es eigentlich zusaätzlich-doch dazu später. Nun gehe in die Menüzeile Menü "Domain" und dan uaf "Sicherheit". Evt wirst du dann nach deiner legitimation als Admin. gefragt gebe hoerzu dein Admin.Kennwort ein. Ich denke es wird aber der Punkt "root anlegen" sein. Gehe hier auf, du wirst nach einem Kennwort gefragt, denk dir eins und gebe es ein, Ok drücken, das Passwort nochmals eingeben und "verify" drücken. Das Programm nun beenden und nochmals starten. Nun die selben Menüpunkte durch gehen: Menü "Domain" Sicherheit/ … und nun "root aktivieren" (evt. in englisch) du wirst nach den Passwörten gefragt (Admin und Root).
Jetzt kannst im NetInfofenster die Herachie anklicken und den Ordner wählen, den du löschen möchtest, wie in einem "Sichern" Dialog. nach dem Löschen den "root" wieder deaktivieren. NetInfomanager beenden.
Zur Aktivierung des "root" musst du dich evt. nach der Einrichtung als Admin Ab.- und wieder Anmelden.
Der brutalste ist im 9er zustarten und den Ordner einfach in den Papierkorb zu ziehen und zu löschen. Der UNIX Weg geht uber das Terminal, die Befehle kenne ich allerdings nicht.
Viel Spass!
 

DJAG

Aktives Mitglied
Registriert
08.04.2002
Beiträge
1.522
Noch was:

Im NetInfoManager löscht du die Ordner über die tasten oben im Programmfenster, wenn du mit der Maus einige Zeit drauf bleibst, werden dir die Funktionen der Tasten angezeigt
Ich hab mich oben einige Male vertippt, sorry!:D
 

Woulion

Aktives Mitglied
Registriert
06.06.2002
Beiträge
1.317
und so geht der UNIX-Weg (dafür musst Du Administrator sein)


cd /User

Beispiel: UserXYZ

sudo rm -Rf userXYZ

mit password bestätigen, fertig


W
 

anda

Neues Mitglied
Thread Starter
Registriert
03.07.2002
Beiträge
8
Hallo,

Vielen Dank für eure Hilfen, letztendlich hat der Unix Weg geklappt. Danke trotzdem für den Netinfomanager. Hatte ich auch schon mal probiert, allerdings wurden und wird mir die Verzeichnisse nicht angezeigt. Auch als eingeloggter Root User hat das nicht so hingehauen.

Nochmals danke an euch beide.

Gruß
Anda
 

conti

Mitglied
Registriert
04.07.2002
Beiträge
118
Hallo zusammen,
habe noch eine zusätzliche frage zu diesem thema.
wie bringt ihr den gelöschten user vom anmelde bildschirm weg.

bei mir ist der gelöschte immer noch drauf, was den effekt hat das man ihn zum anmelden benutzen kann. wenn man dies tut legt er sich wieder an.

vielen dank.

conti
 

Macuser30

Aktives Mitglied
Registriert
23.07.2002
Beiträge
2.334
Hallo,

kann es sein, das du ein DSL-Modem an deiner Netzwerkkarte hast, oder ähnliches? Einfach alles vom Netzwerk trennen, neu starten und den Benutzer löschen.
Du kannst den "gelöschte Benutzer" auch einfacher löschen. Du gehst auf den Ordner, Information, Benutzerrechte. Du veränderst einfach die Benutzerrechte und kannst problemlos löschen.......

Gruß macuser30
 

conti

Mitglied
Registriert
04.07.2002
Beiträge
118
Hallo macuser30

weiss nicht ob wir uns richtig verstanden haben.

Das Benutzerverzeichniss ist weg.
Nur auf dem Anmeldebildschirm von OS X ist noch das Bild mit dem zugehörigen Namen da.

Das will ich auch weg haben.

Gruss
 

moegeler

Mitglied
Registriert
16.10.2002
Beiträge
496
Kann sein dass du nur die Benutzerverzeichnis gelöscht hast?
Das reicht nicht um die Benutzer zu löschen...
 

conti

Mitglied
Registriert
04.07.2002
Beiträge
118
Nein nein,

ich habe die Systemeigenen Mittel benutzt.
Das heisst ich bin über die Systemeinstellungen/Benutzer gegangen und habe dort gesagt "Benutzer löschen".

Daraufhin legt das System ein save Verzeichnis an lässt aber das Benutzerverzeichnis stehen.

Jetzt erst habe ich das Benutzerverzeichnis gelöscht.
Das Icon des gel. Benutzer bleibt aber trotzdem auf dem Anmeldebildschirm.

Habe übrigens dazu den User "root" benutzt.

gruss
 

Macuser30

Aktives Mitglied
Registriert
23.07.2002
Beiträge
2.334
Hallo,

nein ich habe schon richtig verstanden, du wolltest den Benutzer löschen, hast ihn gelöscht und er hat die Benutzerdaten abgespeichert. Trotzdem erscheint das Anmeldebild.

Geh einfach nochmal auf Systemsteuerung in Benutzer, dort wirst du sehen, dass der gelöschte Benutzer immer noch da ist.

Das selbe Problem hatte ich auch. Wenn du im Dock auf den Finder klickst, dann erscheint neben deinen Volumen auch Netzwerk, das einfach mal anklicken.......
dann erscheinen ebenfalls alle Benutzer wieder.
Zieh deinen Kram aus der Netzwerkkarte, starte neu, dann kannst du den Benutzer entfernen.

Gruß macuser30
 

conti

Mitglied
Registriert
04.07.2002
Beiträge
118
Sorry macuser30,

also Du schreibst "zieh deinen kram........." damit meinst Du wahrscheinlich ich soll meine Airport Netzwerkverbindung deaktivieren, neustarten und dann kann ich wo entfernen ??

vielen dank.
 
A

abgemeldeter Benutzer

Der Befehl heißt "sudo rm -rf /Users/Benutzername\ gelo??scht" wobei Benutzername der kurze Name des Benutzers ist. Da die Shell kein Ö kennt, nimmt man "O??" als maskiertes Ö, das Leerzeichen wird mit "\ " maskiert.
Dafür muss root im Netinfomanager aktiviert sein und der Benutzer muss natürlich vorher im Kontrollfeld Benutzer gelöscht worden sein.

Mac OS X 10.2 legt die Benutzerordner übrigens in ein Diskimage (Benutzername.dmg). Das kann ein Admin ganz einfach in den Papierkorb schmeißen.
 

Macuser30

Aktives Mitglied
Registriert
23.07.2002
Beiträge
2.334
Hallo,

genau, nichts an der Netzwerkkarte lassen, neu starten, dann Systemeinstellungen, Benutzer löschen (wie du es sicherlich schon einige male verzweifelt gemacht hast)......... dann ist er wech....richtig wech.

Gruß
 

conti

Mitglied
Registriert
04.07.2002
Beiträge
118
Tja,
ich gaube ein Pferd beisst meinen Apfel.

Also.
Irgendwie habe ich es das 2. mal doch noch geschafft.

Vielen Dank für den Tip macuser30.

Gruss
Conti
 

Macuser30

Aktives Mitglied
Registriert
23.07.2002
Beiträge
2.334
JO, ich trink gerne ab und zu einen Kasten Hasseröder.................. javascript:smilie(':D')
 

Registrierung oder Anmeldung bei MacUser.de

Du musst bei uns Mitglied sein, um einen Beitrag schreiben zu können.

Benutzerkonto erstellen

Erstelle ein kostenloses Benutzerkonto für Macuser.de

Log in

Besitzt du schon ein Benutzerkonto? Hier anmelden.

Oben