Ordner als Sparsebundle erstellt, wird aber als normaler Ordner angezeigt.

lackiem

Mitglied
Thread Starter
Mitglied seit
07.04.2008
Beiträge
354
Habe unter MacOS Mojave schon länger einen Ordner mit Dateien als Sparsebundle mit Passwort gesichert.

Der Ordner hatte immer den Namen "secretordner@.sparsebundle" (oder so ähnlich).

Wenn ich auf den Ordner geklickt habe, wurde der Ordner gemountet, und ich konnte auf meine Dateien im Finder zugreifen,
bis ich ihn wieder ausgeworfen habe.

Jetzt wollte ich an die Dateien in den Ordner, und musste feststellen dass mir ein normaler blauer Ordner im Finder angezeigt wurde,
in dem die Dateien alle mit .rxf enden, und nicht zu öffnen sind.

Wie komme ich an meine Dateien wieder ran, oder wie wird der Ordner wieder ein gesicherter Sparsebundle Ordner.

Hoffe ihr könnt verstehen was ich meine, vielen Dank im Voraus.
 

Schiffversenker

Aktives Mitglied
Mitglied seit
25.06.2012
Beiträge
11.780
Was ist ein "Sparsebundle-Ordner? Was neues?
Ich kenne Sparsebundles nur als Images.
Und Ordner mountet man auch nicht, die öffnet man einfach.
Kann es sein, daß du da mit den Begriffen etwas durcheinandergekommen bist?
Wie wird dieses Dings denn im Festplattendienstprogramm angezeigt? Bzw. wird es überhaupt, als Image angezeigt, wenn du es "gemountet" hast? Kannst du ja mal mit dem Backup testen.
 

walfreiheit

Aktives Mitglied
Mitglied seit
06.06.2004
Beiträge
30.691
Was ist ein "Sparsebundle-Ordner? Was neues?
Ich kenne Sparsebundles nur als Images.
Und Ordner mountet man auch nicht, die öffnet man einfach.
Kann es sein, daß du da mit den Begriffen etwas durcheinandergekommen bist?
Ja, ich denke es wurde nur Begriffe durcheinander geworfen. Ändert aber nichts an den Lösungsmöglichkeiten.
 

lackiem

Mitglied
Thread Starter
Mitglied seit
07.04.2008
Beiträge
354
Danke, habe ich versucht. Aber leider ist mir meine TM Sicherung FB im Dezember abgeraucht,
und ich mache erst seit Anfang Januar auf meiner Synology DS920+ die Neue Datensicherung mit TM.

Da das Problem wohl schon länger besteht und ich es noch nicht gemerkt habe, da ich nicht an die Dateien musste,
ist auf der Aktuellen Datensicherung auch nur der Normale Ordner des Sparsebundle zu sehen.
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
56.526
Das nennt sich Bundle oder auf deutsch Paket.
Da ist einfach die Zuweisung als Paket hin.
 

lackiem

Mitglied
Thread Starter
Mitglied seit
07.04.2008
Beiträge
354
@Schiffversenker
Ja kann sein das ich die Begriffe etwas durcheinander gebracht habe, da ich nicht so oft an die Dateien musste
weis ich nicht mehr genau wie das alles genannt wurde.

Fakt ist jedenfalls, das ich vorher auf diese Image geklickt habe, und es mir im Finder angezeigt wurde,
mit so einem Pfeil zum auswerfen wie bei einer USB Platte oder NAS.
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
56.526
Normal über die Dateinamenerweiterung.
Was sagt denn die Information auf den Ordner oder das Terminal wie das Ding vollständig heißt.
Endet wohl nicht mehr .sparsebundle.
 

lackiem

Mitglied
Thread Starter
Mitglied seit
07.04.2008
Beiträge
354
Der Ordner heißt jetzt einfach nur "Secret Ordner" ohne .sparsebundle Erweiterung,
aber die Dateien darin heißen je nach Datei am Ende xxxx_xls.rxf, xxxx_doc.rxf oder xxxx_txt.rxf.
 

walfreiheit

Aktives Mitglied
Mitglied seit
06.06.2004
Beiträge
30.691
Dann füge die .sparsebundle-Erweiterung mal manuell wieder hinzu.
 

lackiem

Mitglied
Thread Starter
Mitglied seit
07.04.2008
Beiträge
354
Habe ich gerade probiert, heißt dann "Secret Ordner.sparsebundle".

Wird aber nicht als Image erkannt.
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
56.526
Vielleicht muss man auch noch mit SetFSInfo was setzen.
 

picollo

Mitglied
Mitglied seit
01.05.2020
Beiträge
370
Am besten mit einer Kopie testen, im Terminal
su -s

dann prüfen
hdiutil attach -nomount -noverify -noautofsck /Pfad/zum/Sparsebundle

es erscheint ähnliche Meldung
/dev/disk2 Apple_partition_scheme
/dev/disk2s1 Apple_partition_map
/dev/disk2s2 Apple_HFS

die mit Apple_HFS ist wichtig

dann weiter im Terminal eingeben
fsck_hfs -drfy /dev/disk2s2

Wie gesagt, das Image erst kopieren, nicht mit Original.
 

lackiem

Mitglied
Thread Starter
Mitglied seit
07.04.2008
Beiträge
354
wenn das der /Pfad/zum/Sparsebundle bei mir ist: "/Users/rxxxxxt/Documents/OneDrive/Office Daten/Privat/Secret Ordner",
soll ich dann den hinter "hdiutil attach -nomount -noverify -noautofsck" einsetzen?
 

lackiem

Mitglied
Thread Starter
Mitglied seit
07.04.2008
Beiträge
354
Wenn ich das richtig eingegeben habe, erscheint bei mir im Terminal folgender Eintrag:

MacBookProRetina-3:~ rxxxxxt$ su -s


su: illegal option -- s


usage: su [-] [-flm] [login [args]]


MacBookProRetina-3:~ rxxxxxt$ hdiutil attach -nomount -noverify -noautofsck /Users/rxxxxxt/Documents/OneDrive/Secret Ordner


hdiutil: attach: extra image argument "Ordner" - "/Users/rxxxxxt/Documents/OneDrive/Secret" already specified


Usage: hdiutil attach [options] <image>


hdiutil attach -help
 

picollo

Mitglied
Mitglied seit
01.05.2020
Beiträge
370
Sorry, ohne s .. mein Fehler:

Du benötigst erst mal root-Rechte mit
Code:
sudo -

Noch was, du hast ein Leerzeichen im Namen "Secret Ordner", den muss du mit einem "\" (Backslash) vor dem Leerzeichen maskieren. Im Terminal werden Leerzeichen als Trenner von Parametern interpretiert. Das Zeichen "\" sagt der Shell, dass das folgende Leerzeichen kein Trenner ist, sondern zur Angabe gehört. Also gibst du ein:

Code:
hdiutil attach -nomount -noverify -noautofsck /Users/rxxxxxt/Documents/OneDrive/Secret\ Ordner
Den Backslash \ erhält man mit drei Tasten gleichzeitig drücken: alt+Shift+7

Wie gesagt, mach das nur mit einer Kopie, nicht mit dem Original Ordner !!!
 

picollo

Mitglied
Mitglied seit
01.05.2020
Beiträge
370
Der Befehl fsck_hfs ... stellt den btree wieder her (r =rebuild catalog btree). Deswegen ist es wichtig, das du mit einer Kopie des Sparsebundle Image arbeitest. Denn es könnten Daten gelöscht werden, wenn da Fehler enthalten sind.
 

lackiem

Mitglied
Thread Starter
Mitglied seit
07.04.2008
Beiträge
354
Danke Picollo,

habe es nun so eingegeben, und das stand im Terminal:

MacBookProRetina-3:~ rxxxxxt$ sudo -


Password:


sudo: -: command not found


MacBookProRetina-3:~ rxxxxxt$ hdiutil attach -nomount -noverify -noautofsck /Users/rxxxxxt/Documents/OneDrive/Secret\ Ordner


hdiutil: attach failed - Image nicht erkannt

MacBookProRetina-3:~ rxxxxxt$
 
Oben