Benutzerdefinierte Suche

openvpn: "No buffer space"

  1. atnexxtnexxt

    atnexxtnexxt Thread StarterMacUser Mitglied

    Mitglied seit:
    06.02.2004
    Beiträge:
    1
    Zustimmungen:
    0
    Wir haben hier ein OpenVPN auf einem FreeBSD 5.5-Server. Mit dem Server verbinden sich unsere Clients (iBooks) über das VPN. Wir haben allerdings das Problem, das bei einem Client die Fehlermeldung:
    Code:
    UDPv4: No buffer space available (Code=55)
    erscheint. Die Konfigurationen sind (bis auf die Zertifikate und Schlüssen ;-)) identisch, zwei Clients kommen problemlos ins VPN, einer nicht.
    Bis vor der Installation von Kismac funktionierte das VPN auch beim dritten Client. Während der Installation und auch nachdem die Software wieder entfernt wurde, funktioniert es nicht mehr.

    Wir haben festgestellt, das die Anzahl der mbufs auf dem nicht-funktionierenden Client nur ein Zehntel dessen beträgt, was die funktionierenden Clients haben.
    Code:
    yyybook:~: netstat -m
    78 mbufs in use:
           66 mbufs allocated to data
           3 mbufs allocated to packet headers
           3 mbufs allocated to socket names and addresses
           6 mbufs allocated to Appletalk data blocks
    
    Zum Vergleich:
    Code:
    xxxbook:~: netstat -m
    974 mbufs in use:
           956 mbufs allocated to data
           15 mbufs allocated to socket names and addresses
           3 mbufs allocated to Appletalk data blocks
    
    Alle anderen Werte und Konfigurationen (sysctl) sind gleich. Die Softwareversionen (Tunnelblickk) sind gleich, die Kernelmodule (tap/tun.kext) sind gleich.

    Die Frage ist nun: Was können wir machen? Haben wir noch irgend einen Knopf oder Schalter übersehen?
     
    atnexxtnexxt, 12.05.2006
  2. BigBen4711

    BigBen4711MacUser Mitglied

    Mitglied seit:
    23.05.2006
    Beiträge:
    89
    Zustimmungen:
    0
    Hi,

    ich habe hier das gleiche Problem auf einem Mac Mini Dual Core in Verbindung mit der Tunnelblick 3.0-RC2-Version.

    Habt Ihr schon eine Lösung für das Problem gefunden ?

    cu,
    ben
     
    BigBen4711, 06.06.2006
  3. BigBen4711

    BigBen4711MacUser Mitglied

    Mitglied seit:
    23.05.2006
    Beiträge:
    89
    Zustimmungen:
    0
    Hi,

    ich noch mal:

    Der o.g. Fehler liegt offensichtlich an der 3.0rc2-Version. Die RC1-Version produziert diesen Fehler nicht, allerdings funktioniert der Tunnel nicht, obwohl der Tunnel fehlerfrei initialisiert wird. Schlimmer noch: Die RC1 schiesst die Netzwerkwerkverbindung vom Mac in den Orbit.

    Ergo: Werden wir wohl auf die RC3 bzw. finale Version warten müssen. Ärgerlich...


    cu,
    ben
     
    BigBen4711, 06.06.2006
Die Seite wird geladen...
Ähnliche Themen - openvpn buffer space
  1. Maverick420
    Antworten:
    0
    Aufrufe:
    489
    Maverick420
    15.02.2016
  2. pfannkuchen2001
    Antworten:
    1
    Aufrufe:
    850
    pfannkuchen2001
    08.06.2014
  3. NilZ
    Antworten:
    25
    Aufrufe:
    1.464
  4. sevenofnine
    Antworten:
    12
    Aufrufe:
    752
    sevenofnine
    13.08.2008
  5. the-nana
    Antworten:
    0
    Aufrufe:
    578
    the-nana
    15.11.2007