Open Directory deaktivieren. Wie??

  1. skavenger

    skavenger Thread Starter MacUser Mitglied

    Mitglied seit:
    09.01.2004
    Beiträge:
    60
    Zustimmungen:
    0
    Hallo Leute,

    habe bei der Installation eines Servers unvorsichtigerweise OpenDirectory aktiviert. (Später bereits auf 10.3.4 upgedatet)
    Nun stellt sich heraus, das ich diesen "Dienst" gar nicht benötige.

    Obwohl mein server ein G4 733 mit 1 GB RAM ist, habe ich nun ständig 90-99% CPU-Auslastung.
    Ich habe so den Verdacht, das es entweder an der Apple-Firewall oder eben an OpenDirectory liegt.

    Gibt es irgendeine Möglichkeit OpenDirectory wieder vom System zu verbannen??

    Oder wie kann ich generell überprüfen/ändern, welche Dienste/Erweiterungen beim start mitgestartet werden??

    ein auf hilfreiche Antworten wartender

    SkAvEnGeR
     
  2. Grady

    Grady MacUser Mitglied

    Mitglied seit:
    25.04.2003
    Beiträge:
    2.277
    Zustimmungen:
    0
    In /Library/StartupItems und in den Benutzereinstellungen finden sich die Programme, die beim Start automatisch geladen werden. Um Systemprozesse detailliert zu betrachten, ist die Aktivitätsanzeige bei den Dienstprogrammen gut zu gebrauchen. Dort lässt sich schnell feststellen, welcher Prozess die Leistung frisst.
     
  3. maceis

    maceis MacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Ergänzung:
    Allerdings sind hier nur diejenigen, die nachträglich installiert wurden.
    Die mit dem System gelieferten StartupItems liegen unter /System/Library/StartupItems.
    Ob oder ob nicht ein Dienst gestartet wird, lässt sich u. a. über die Datei /etc/hostconfig steuern.

    Mit Open Directory kenne ich mich leider nicht aus.
    Da es sich um einen Verzeichnisdiesnt handelt, würde ich evtl. mal im Programm Verzeichnisdienste nachsehen.

    Ich glaube aber nicht, das die firewall oder Open Directory Deine CPU so beanspruchen.

    Was sagt denn ein Aufruf von "top" im Terminal
     
  4. skavenger

    skavenger Thread Starter MacUser Mitglied

    Mitglied seit:
    09.01.2004
    Beiträge:
    60
    Zustimmungen:
    0
    Erst mal DANKE für eure Tips.

    Beim Nachsehen in der Aktivitätsanzeige habe ich festgestellt, das der Kernelprozess fast die gesamte CPU-Leistung beansprucht.

    Eine Ursache könnte sein, das der Server, als ich ihn aufgesetzt habe, den Namen "Web-Mail-Server" hatte.
    Nun hat dieser Server hausintern aber eine völlig andere Aufgabe erhalten.
    In folge dessen habe ich ihn umbenannt in "X-Backup-Server".

    Bei einigen Tools steht aber irgendwie immernoch der alte Name drin.

    In welchen config-Dateien steht denn evtl. noch der Hostname drin??

    Könnte ja sein, das es daran liegt.

    Ich freue mich schon auf weitere konstruktive Tips.

    SkAvEnGeR
     
Die Seite wird geladen...