Office 2016: "Zuletzt verwendete Dokumente" werden nicht gemerkt

caja

Mitglied
Thread Starter
Mitglied seit
27.03.2008
Beiträge
48
Hallo,
ich hab Office 2016 installiert und in keinem Programm werden unter "zuletzt verwendet" Dokumente angezeigt. Nur in der aktuellen Excel- oder Wordsession. Schliesse ich dies Programme ist beim nächsten Start wieder alles leer. Auch das Anpinnen hilft nicht. Kennt jemande eine Lösung des Problems?
Danke!
Carsten
 

Fidefux

Mitglied
Mitglied seit
17.08.2010
Beiträge
5.993
Habe das Problem auch.

Scheint wohl ein Bug zu sein.
 

fa66

Mitglied
Mitglied seit
16.04.2009
Beiträge
13.110
Von einem MSO2016-Nichtnutzer sei hingewiesen:
Unabhängig von einem denkbaren Bug kann das sichern einer Chronik benutzer Dokumente auch systemseitig unterbunden werden/worden sein (entweder via Terminal oder bspw. TinkerTool).
Hast du das ausgeschlossen?
 

outdoor262

Mitglied
Mitglied seit
03.07.2015
Beiträge
35
Von einem MSO2016-Nichtnutzer sei hingewiesen:
Unabhängig von einem denkbaren Bug kann das sichern einer Chronik benutzer Dokumente auch systemseitig unterbunden werden/worden sein (entweder via Terminal oder bspw. TinkerTool).
Hast du das ausgeschlossen?
Moinsen.
Gleiches Problem auf meinem mac (allerdings nur in Excel und Word) - und mein mac hat TinkerTool noch gar nie nicht gesehen
 

caja

Mitglied
Thread Starter
Mitglied seit
27.03.2008
Beiträge
48
Ich hatte vor Jahren mal mit Tinkertool Einstellungen vorgenommen. Habe eine aktuelle Version installiert um nachzuschauen, ob es diesbezüglich Einstellungen gibt. Fehlanzeige.
Bei mir geht es weder bei Word noch bei Excel oder Power Point.
Betriebssystem: 10.10.5 Yosemite
Rechner: Macbook Pro 15" early 2008
Gleiche Office-Installation wurde auf einem anderen Macbook ( Bj. 2013, Yosemite) vorgenommen und dort erscheinen die zuletzt geöffneten Dokumente.

Im der älteren zuvor installierten Office funktionierte es.
 

Schiffversenker

Mitglied
Mitglied seit
25.06.2012
Beiträge
10.777
Habt ihr Schreibrechte an den entsprechenden Dateien?
(Ich habe aber keine Ahnung, wo das bei MS-Programmen gespeichert wird.)
 

caja

Mitglied
Thread Starter
Mitglied seit
27.03.2008
Beiträge
48
Ich habe inzwischen alle OS-X und Microsoft Office Updates mitgemacht und bin diesbezüglich auf dem neuesten Stand.
Was immer noch nicht funktioniert sind die "Zuletzt verwendete Dokumente". Das ist echt zum heulen.
Hat jemande zwischenzeitlich hier einen neuen Hinweis?
 

fa66

Mitglied
Mitglied seit
16.04.2009
Beiträge
13.110
Gleiche Office-Installation wurde auf einem anderen Macbook ( Bj. 2013, Yosemite) vorgenommen und dort erscheinen die zuletzt geöffneten Dokumente
Eine letzte Gegenkontrolle:
Da der Rechner mit MSO2016 bei gleicher MacOSX-Version zeigt, dass die Ursache nicht per se bei MSO2016 liegen muss, bleibt auf deinem Rechner zu prüfen, ob das Problem auch in einem anderen/neuen Benutzerkonto auftritt.

Falls nicht, sind die Pref-Dateien (und/oder Cache-Dateien) von MSO2016 im betroffenen Benutzerkonto auf solche zu prüfen, die etwa aufgrund des Namens etwas mit dem Verzeichnis von zuletzt benutzten Dokumenten zu tun haben könnten. Solche Dateien sind dann zu beseitigen. Dann die Anwendungen neu zu starten.

Leider haben sich die Verzeichnisorte im Vergleich zu MSO2011 bisweilen geändert; daher kann ich nur allgemein auf typische Stellen wie ~/Library/{Application Support/Microsoft/ | Caches/ | Preferences/} und sinngemäß für Programmdaten verweisen.

Geht’s hingegen auch in einem anderen Benutzerkonto nicht, kannst du dir Obiges zu prüfen aber auch sparen.
 

caja

Mitglied
Thread Starter
Mitglied seit
27.03.2008
Beiträge
48
Gute Idee fa66. Vielen Dank.
In einem anderen Benutzerkonto werden die Dokumente gemerkt. Jetzt gilt es die Unterschiede herauszufinden. Das werde ich machen wenn ich mehr Musse habe. Ich werde berichten.
Aber:
Stehe alleine mit der Meinung da, dass es irgendwie armseelig ist, dass die Software nicht existierende Verzeichnisse nicht anlegen kann bzw. darauf zumindest hinweisst?
 

fa66

Mitglied
Mitglied seit
16.04.2009
Beiträge
13.110
dass es irgendwie armseelig ist, dass die Software nicht existierende Verzeichnisse nicht anlegen kann bzw. darauf zumindest hinweisst?
In Sachen Yosi und MSO2016 leider alles nur spekulativ:
Unterstellt, es seien systemseitige Beschränkungen dem Benutzerkonto gegenüber, die das Abspeichern zuletzt benutzter Dokumente behindern, käme die Anwendung mglw. gar nicht dazu, sich diesbezüglich zu melden.

Ich für meinen Teil habe das Speichern zuletzt benutzter Dokumente (unter MacOSX-10.6.x) generell unterbunden (durch das nachträgliche Verschieben in diverse Ordner oder Umbenennungen wären die Verweise in Word eh oft verwaist).
Da die Unterbindung auf Systemebene erfolgt (eine via Terminal (oder für kommandozeilenferne Nutzer etwa mittels TinkerTool oder OnyX) eingeschaltete Systemfunktion), also durch den User lizensiert wurde, gibt es für Word keinen Grund, zu meckern. Eigentlich Unix-typisch: Solange alles wie geplant läuft, gibt’s nix zu melden.

Funktioniert bei dir das Merken benutzter Dokumente in anderen Programmen außerhalb MSO2016?
 

caja

Mitglied
Thread Starter
Mitglied seit
27.03.2008
Beiträge
48
ja, in anderen Programmen und auch mit den alten Office-Programmen zuvor habe ich damit kein Problem. Funktioniert alles bestens
 

Suehprom

Registriert
Mitglied seit
08.11.2015
Beiträge
1
Hallo zusammen... ich habe oder besser gesagt hatte das gleich Problem und wollte schon nachfragen, ob es eine Lösung gab/gibt... aber nun funktioniert es plötzlich.

Ich kann das Verhalten jedoch nur bestätigen, ich habe ebenfalls zwei Benutzer auf meinem MAC, Update auf El Capitan und Update auf Office 2016 durchgeführt. Bei einem Account ging es immer, bei zweiten nicht. Dies bezieht sich übrigens nur auf Office.

Ich bin dann auf diesen Artikel gestossen und habe diverse weitere gegoogelt und diverses ausprobiert. Jetzt wollte ich schon schreiben und nun funktioniert es plötzlich. Den genauen Grund kann ich jedoch nicht genau sagen. Was habe ich zuletzt gemacht... Ich habe diverse Einstellungen im Office überprüft, gesucht, ob es hier was gibt, ohne Erfolg. Auf Grund der Erklärung von einem User vorher hier, dachte ich es könnte noch an den OS Einstellungen liegen. Ich habe dann noch den Artikel von sinnvollen Tipps bei El Capitan gelesen http://www.macwelt.de/ratgeber/OS-X-10-11-El-Capitan-richtig-konfigurieren-9820428.html . Die dort beschriebenen Einstellung für "zuletzt verwendet" geprüft und am Wert "Benutzte Objekte" rumgespielt (runter auf 5 und wieder hoch auf 10).

Nun wollte ich schreiben bzw. wegen einer Lösung nachfragen und nun geht es plötzlich... komisch und zwar bei beiden Accounts. Ich weiss jetzt aber leider nicht, was den definitiven Ausschlag gegeben hat. Geändert habe ich nur die Systemeinstellungen, im Office gab es ja nichts zu ändern. Vielleicht war es das, obwohl nix gross verändert wurde. Vielleicht hilft es ja jemandem trotzdem und ich würde mal dies Systemeinstellungen überprüfen und vielleicht auch ändern.

Ein weitere Hinweis wäre, dass ich Office zuerst bei mir installiert und aktiviert habe und danach erst beim zweiten Account. Dies hätte ich als nächste gemacht, bei dem Account der nicht funktioniert Office nochmals aktiviert. Hat sich aber aktuell erledigt und ich hoffe es funktioniert auch noch zukünftig.

Viel Erfolg.
 

Midie

Mitglied
Mitglied seit
18.02.2014
Beiträge
297
Guten Morgen, seit kurzem hab ich ein neue Macbook mit neuem (aktuellem) OS und MS Office 365 (vorher Office 2011 auf dem bis dahin aktuellen OS). Hab mein System aus einem TM-BAckup wieder hergestellt und dann office 365 installiert.

Leider sehen die Office-programme bei jedem Start anders aus, d.h. Einstellungen zu Menüs, Lineal und insbesondere zuletzt geöffneten Dateien gehen offenbar jedesmal verloren. Es wird z.B. unter "zuletzt verwendete Dateien" immer wieder nur eine Datei angezeigt, die ich sehr lange schon nicht bearbeitet habe, die anderen vor kurzem bearbeiteten Dateien nicht.
Das Problem tritt in allen Office-Programmen auf.

Gint es dafür mittlerweile eine Lösung?

Herzliche Grüße
Michael
 

fa66

Mitglied
Mitglied seit
16.04.2009
Beiträge
13.110
Einstellungen zu Menüs (eben auch angepassten) und dem Lineal (also etwa der mittelbar zu erkennenden Skalierung des Dokuments) stehen in der Dokumentdatei bzw. der der Dokumentdatei zugrundeliegenden Dokumentvorlagendatei (gewöhnlich also der Normal.dotm).

Bemaßungen (also etwa Zoll oder Zentimeter) sind Sache der Programmvoreinstellung (com.microsoft.Word.plist).

Ob sich Word wiederum benutzte Dokumente merkt, kann nun einerseits in Word selber eingestellt werden; darüberhinaus kann das Merken systemseitig systenweit beschränkt werden. Systemseitige Einstellungen gehen programminternen vor.
Dass da überhaupt noch eine gemerkte Datei steht, deutet darauf hin, dass Word seine com.microsoft.Word.plist zu ändern gehindert wird – und so nur diese alte Zustand fixiert zu sein scheint.

Damit Word seinen Anteil speichern kann, müssen Schreibrechte auf Dokument, Dokumentvorlage und Programmvoreinstellungsdatei bestehen. Inwieweit dir das Sandboxing unter aktuellen macOS-Versionen in die Quere kommt, kann ich nicht beurteilen. Aktuell sind die genannten Dateien in Unterordnern zu ~/Library/Containers/com.microsoft.programmname/ bzw. ~/Library/Group Containers/com.microsoft.programmname/ zu finden (klassisch war das noch unter ~/Library/Preferences/(Microsoft/) bzw. ~/Library/Application Support/(Microsoft/)).

Standardmäßig ist zumindest für einen Admin-User kein Konflikt der beschriebenen Art zu erwarten.
Daher wie immer: Tritt das Problem auch in einem anderen/neuen Benutzerkonto auf?
 

Midie

Mitglied
Mitglied seit
18.02.2014
Beiträge
297
Danke für deine Rückmeldung. Es geht nicht nur um Word, sondern um auch um Excel und Powerpoint.
Ich arbeite als Admin damit. Müsste dann mal weitere User anlegen und bei Microsoft registrieren, um das zu probieren. Oder?
 

Ergebnis

Mitglied
Mitglied seit
26.07.2009
Beiträge
1.319
Es war wohl ein Bug, denn seit dem letzten Update werden die Dateien gemerkt.