"Öffnen mit:" ist ausgegraut

Capablanca

Capablanca

Neues Mitglied
Thread Starter
Dabei seit
13.04.2013
Beiträge
37
Punkte Reaktionen
0
Hallo!

Ich möchte unter macOS 10.14.6 eine Webloc-Datei standardmäßig mit Firefox, meinem Standard-Browser, öffnen. Das funktioniert bei einem Doppelklick auch, allerdings zeigt mir die Datei das icon von einer Safari-Datei an.

Nun rief ich über "cmd i" die Informationen auf, um das Standard-Programm zu ändern, aber die Funktion ist ausgegraut (siehe Screenshot ... Update: Ich kann den JPG-Screenshot nicht hochladen, weil die Fehlermeldung "Die hochgeladene Datei war nicht wie erwartet ein Bild." erscheint).

Woran kann das liegen?

Wie kann ich das Standard-Programm auf andere Weise (z. B. über das Terminal oder ein Tool wie TinkerTool) ändern?

Ich habe bereits die Rechte repariert und den Finder neugestartet, auch ein Neustart mit "alt cmd P R" brachte keine Besserung.

Hat jemand eine Idee?
 
fa66

fa66

Aktives Mitglied
Dabei seit
16.04.2009
Beiträge
17.943
Punkte Reaktionen
8.094
Mein OS: macOS-10.14.6
Browser: FF-109.0
FF ist als Standard ausgewählt (hier Anzeige in FF-Einstellungen):

FF-Einst-Std.jpg
Gegenkontrollen: Safari ist nicht Standard:

SAF-Einst-KeinStd.jpg

Frische .webloc-Datei (von dieser Seite) erstellt: D&D der Adresszeile auf den Desktop.
Informationen-Dialog: »Öffnen mit:« ist ausgegraut – und steht auf »Safari«:

Infodialog.jpg

FF geöffnet gelassen: Doppelklick auf .webloc öffnet als zusätzlicher Tab in FF.
FF beenden;
BIS GLEICH

.
.
.
EDIT:
Doppelklick auf .webloc startet FF.

Fazit bis hierher:
1. Ausgrauung im Info-Dialog kann bestätigt werden.
2. Eintrag von »Safari« dort kann bestätig werden.
3. Öffnen der .webocs in »Safari« kann, trotz derer Fixierung in den Informationen, nicht bestätigt werden.

EDIT2:
Safari (14.1.2) gestartet.
Doppelklick auf .webloc öffnet weiterhin als zusätzlicher Tab in FF.

EDIT3:
Diese Seite in Safari geöffnet – und darin angemeldet.
Neuen .webloc davon aus Safari heraus erstellt.
Safari und FF beenden;
BIS GLEICH
.
.
.

EDIT:
Der neue (wie auch der zuvorige) .webloc öffnen in Firefox.

Fazit nunmehr: Bisher konnte keine Bedingung hergestellt werden, die die .weblocs per Doppelklick in einem anderen Browser als dem als Standard festgelegten Firefox öffnen zu lassen. Im Ergebnis bleibt das Verhalten das von mir über die Standardbrowser-Auswahl einstellte gewünschte.
Keinen Versuch habe ich gemacht in Richtung auf eine zeitweilige Auswahl von Safari als Standardbrowser.
 
Zuletzt bearbeitet:
Capablanca

Capablanca

Neues Mitglied
Thread Starter
Dabei seit
13.04.2013
Beiträge
37
Punkte Reaktionen
0
Okay, danke!

Das deutet darauf hin, dass das Icon eines Webloc-Dokuments automatisch stets das von Safari ist und man, egal welcher Browser der Standard-Browser ist, dies auch nicht ändern kann.

Ich bin mir gerade nicht mehr sicher, ob das in früheren macOS-Versionen auch schon immer so war bzw. gewesen sein könnte. Ein schneller Test mit Opera ergibt das gleiche Ergebnis; die Webloc-Datei zeigt das Safari-Icon. "Öffnen mit:" ist ausgegraut.
 
Capablanca

Capablanca

Neues Mitglied
Thread Starter
Dabei seit
13.04.2013
Beiträge
37
Punkte Reaktionen
0
MacEnroe

MacEnroe

Aktives Mitglied
Dabei seit
10.02.2004
Beiträge
22.771
Punkte Reaktionen
7.006
Unter HighSierra ist es auch so wie von dir oben beschrieben. :)
 
AgentMax

AgentMax

Super Moderator
Dabei seit
03.08.2005
Beiträge
52.527
Punkte Reaktionen
12.194
Zu den Links: Mein System ist zum Glück nicht Ventura, sondern wie gesagt Mojave. Mein Firefox ist Version 96.0.3. Beides hat Gründe. Aber trotzdem danke.
Und was hindert dich nun daran die Lösung dort zu nutzen? Anscheinend besteht das Problem ja auch schon bei deinem System.
Und da steht ja drin wie man das Standardprogramm ändern kann. Auch danach hattest du gefragt.
 
fa66

fa66

Aktives Mitglied
Dabei seit
16.04.2009
Beiträge
17.943
Punkte Reaktionen
8.094
Anscheinend besteht das Problem ja auch schon bei deinem System.
De facto gibt es kein Problem beim TE.

Denn der Beschreibung nach (#1), sei das einzige Manko das nicht auf FF lautende .webloc-Symbol – und nicht etwa eine nicht in FF erfolgende Öffnung dieser URI-Link-Dateien.
 
AgentMax

AgentMax

Super Moderator
Dabei seit
03.08.2005
Beiträge
52.527
Punkte Reaktionen
12.194
Stimmt. War dein Screenshot in #2 auf dem Safari das Standardprogramm ist.
 
fa66

fa66

Aktives Mitglied
Dabei seit
16.04.2009
Beiträge
17.943
Punkte Reaktionen
8.094
Stimmt. War dein Screenshot in #2 auf dem Safari das Standardprogramm ist.
…demgegenüber aber trotzdem alle .webloc-Dateien (wie gewünscht) in FF (v109.0) öffnen. Und FF eben doch der unter macOS-10.14.6 als Standard festgelegte Browser ist.

(Ich kann allerdings nicht das Verharren des TE bei FF-v96 einordnen – war aber auch nicht die Frage und spielt offenbar auch nicht ins Problem hinein.)
 

Ähnliche Themen

monstermops
Antworten
25
Aufrufe
514
tubo
tubo
SwissBigTwin
Antworten
15
Aufrufe
432
SwissBigTwin
SwissBigTwin
W
Antworten
2
Aufrufe
371
wobbel
W
66smooth66
Antworten
1
Aufrufe
306
Killerkaninchen
Killerkaninchen
Oben