Numbers: Arbeitszeit pro Monat addieren

Diskutiere das Thema Numbers: Arbeitszeit pro Monat addieren im Forum Office Software.

  1. nitram70

    nitram70 Thread Starter Mitglied

    Beiträge:
    60
    Zustimmungen:
    1
    Mitglied seit:
    16.03.2006
    Hallo,
    ich möchte ein einer Tabelle meine Arbeitszeiten fortlaufend eintragen, in einer weiteren die addierten Stunden pro Monat angezeigt haben. Probleme habe ich mit dem Datumsvergleich.
    Alle Spalten sind als "Datum" formatiert, allerdings mit unterschiedlichen Anzeigeformaten.
    Ausgenommen ist die Spalte "Dauer", die habe ich auch als "Dauer" formatiert.
    In Tabelle 2 habe ich als Datum immer den 1. des Monats eingestellt.

    Die Formel in der Spalte "Arbeitszeit" der Tabelle 2 sieht so aus:
    =SUMMEWENN(MONAT(Tabelle 1::A)&JAHR(Tabelle 1::A);MONAT($A2)&JAHR($A2);Dauer)

    Die Formel habe ich durch Eingabe der Funktionen und anklicken von Spalten zusammengebaut.

    In der Theorie will ich alle Datumsangaben in der Spalte Datum der Tabelle 1 auf zB. 042019 für den April normalisieren, damit ich korrekt Vergleichen kann. Genau das scheint aber nicht vernünftig zu klappen.
    Die Fehlermeldung lautet:
    SUMMEWENN erwartet, dass alle Bereichsargumente dieselbe Größe haben.

    in der Zeiterfassung selbst an anderer Stelle funktioniert diese Formel, ich vergleiche dort aber Tageweise und normalisiere nicht auf den jeweiligen Monat.
    Was mache ich falsch?

    Gruß,
    Martin
     

    Anhänge:

  2. tamuli

    tamuli Mitglied

    Beiträge:
    1.293
    Zustimmungen:
    840
    Mitglied seit:
    21.07.2014
    Ich habe gerade mal etwas herum probiert, aber kann dein Problem nur mit Hilfe von Extraspalten lösen, die allerdings ausgeblendet werden können. In den Extraspalten wird der numerische Monatswert des jeweiligen Datums extrahiert.

    Bildschirmfoto 2019-05-25 um 01.08.33.png Bildschirmfoto 2019-05-25 um 01.09.14.png Bildschirmfoto 2019-05-25 um 01.10.46.png Bildschirmfoto 2019-05-25 um 01.33.33.png
     
  3. KOJOTE

    KOJOTE Mitglied

    Beiträge:
    4.976
    Medien:
    1
    Zustimmungen:
    973
    Mitglied seit:
    06.11.2004
    @tamuli Das war dann also deine Einschlaf-Lektüre. :)
    Die ersten beiden Tabellen sind identisch mit den zweiten zwei Tabellen, oder?
    Nur der Übersichtlichkeit halber. ;)
     
  4. tamuli

    tamuli Mitglied

    Beiträge:
    1.293
    Zustimmungen:
    840
    Mitglied seit:
    21.07.2014
    :D
    Alle 4 Bilder sind von denselben 2 Tabellen. Es sind lediglich verschiedene Zellen angeklickt, um die verschiedenen Formeln anzuzeigen, bzw. beim letzten Bild die Möglichkeit des Ausblendens von Spalten.

    Edit: für längere Texterklärungen war es zu spät, reichte nur noch für Screenshots. ;)
     
Die Seite wird geladen...
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite weitersurfst, akzeptierst du unseren Einsatz von Cookies. Akzeptieren Weitere Informationen...