NAS Verbindung auf dem MAC

Red--Baron

Neues Mitglied
Thread Starter
Registriert
30.04.2021
Beiträge
19
Moin alle zusammen
Erstmal vorab, ich bin ganz neu auf dem Mac. Besitze seit 3 Monaten einen MacBook Air M1 und möchte diesen mit meinem Synology NAS DS215j verbinden.
Alles gut, Verbindung kann leicht hergestellt werden aber die Qualität der Verbindung ist ziemlich schlecht. Im Durchschnitt habe ich eine 20MB/s Schreib- und 15MB/s Lesegeschwindigkeit. Das stöbern auf den Ordnern klappt eigentlich Problemlos aber wenn ich versuche 20-30 Dateien (10-20MB's) in einen Ordner zu kopieren muss ich erst 2-3 Minuten warten und erst danach fängt der Mac an sehr lahm zu kopieren.
Stöbern auf einem Ordner mit ungefähr 10.000 Fotos ist eine Qual. Habe auch andere Software ausprobiert. Keine einzige Software konnte das stöbern in einem NAS Ordner mit über 10,000 Fotos erleichtern. Würde jetzt nicht sagen das die Software nichts taugen aber sicherlich läuft irgendetwas falsch.
Habe auch einen PC, da gibts es Null Probleme! Stöbern, kopieren.. einfach alles.
Letztens musste ich 300 weitere Fotos und Video's zu den 10,000 Fotos Ordner kopieren. Hatta nach einer halben Stunde die Schnauze voll. Habe mich über Teamviewer auf meinen PC geschaltet, und in unter 5 Minuten 5,5GB's in den Ordner kopiert! Die Geschwindigkeit auf meinem PC liegt so um die 100MB/s.
Kann jemand meine Qual nachvollziehen oder mir einen Rat geben wo und was ich falsch mache?
Ich kann mir nicht vorstellen das der MAC im Bereich Network dem PC gegenüber so unterlegen ist.
 

Anhänge

  • DiskSpeedTest.png
    DiskSpeedTest.png
    195,5 KB · Aufrufe: 28

AgentMax

Super Moderator
Registriert
03.08.2005
Beiträge
49.191
Ist das MacBook denn auch per LAN verbunden wie der PC?
Vermutlich nicht?
 

Red--Baron

Neues Mitglied
Thread Starter
Registriert
30.04.2021
Beiträge
19
Ist das MacBook denn auch per LAN verbunden wie der PC?
Vermutlich nicht?
Naja, recht hast du. Und es war auch ein Versuch Wert das zu prüfen. Die Ergebnisse teile ich hier im Anhang.
Der Internet Speedcheck ist identisch LAN vs WIFI.

WIFI:
WIFI Speed Test.png


LAN:
LAN Speed Test.png



Für die Disk Lese- und Schreibgeschwindigkeit war das tatsächlich ein Volltreffer.

WIFI:

WIFI DISC SPEED.png


LAN:
LAN DISC SPEED.png


Also habe ich gleich den großen Ordner Ordner aufgemacht und drin rumgestöbert. Leider ist es in der Realität ziemlich anders als hier beim Test. In der Realität habe ich kein Unterscheid bemerkt. Es war wie vorher. Die Qual beim öffnen von Fotos und Videos oder navigieren durch den Ordner steht wie zuvor.

Vielleicht hat jemand weitere Vorschläge?
 

cpx

Aktives Mitglied
Registriert
14.01.2005
Beiträge
1.766
Vielleicht hat jemand weitere Vorschläge?
Ich würde ein Thunderbolt 3 Dock mit 10Gbit/s USB Anschlüssen besorgen und dann einen 10Gbit/s USB Hub mit genügend Ports um dort einige M.2 SSD's rein zu stecken. Das dürfte die Qualen auf das Portmonaie verlagern. :hehehe:
 

pk2061

Aktives Mitglied
Registriert
21.01.2005
Beiträge
1.316
Ähm....
Ich glaube du verwechselt hier gerade Äpfel und Birnen.

Mit dem Speedtest testet du nicht dein Verbindung zum NAS oder deine WLAN oder deine LAN Geschwindigkeit sondern deine Verbindung zum Internet.
Du hast also scheinbar eine 100/50 Mbit Verbindung.
Deine Internetgeschwindigkeit wird am PC und Macbook nicht durch das LAN oder WLAN ausgebremst. Herzlichen Glückwunsch! ;)

Aber was willst du mit dem DISK Speed Test Anzeigen?
Die Lesegeschwindigkeit von deinem Rechner während du Daten kopierst?

Ich würde dafür eher die Anzeige vom DSM ablesen mit wieviel MB pro Sekunde das NAS Daten empfängt, während du da was drauf kopierst.
 

Johanna K

Mitglied
Registriert
28.10.2009
Beiträge
620
Der erste Speedtest (der mit dem großen "GO"-Button) zeigt die Geschwindigkeit in MBit/s an, der zweite von Blackmagic hingegen in MByte/s. Die 67MB/s in der vierten Bildschirmkopie sind also etwa sechsmal so schnell wie die 110Mbps in der ersten Bildschirmkopie. Da muss man immer aufpassen. Also vergiss die beiden ersten Tests. Die sagen nur, was dein Internetprovider liefert, und das ist weniger als das, was dein WLAN kann.

Die über LAN angezeigten 77MByte/s schreibend und 67MByte/s lesend sind immer noch unterhalb dessen, was Gigabit-LAN kann. Etwa 110MByte/s sind möglich.
Du kannst ausprobieren, ob du durch ein anderes Netzprotokoll (das zum Verbinden der Netzlaufwerke ist gemeint) eine bessere Geschwindigkeit kriegst. Also SMB, AFP und NFS ausprobieren. Bei mir war SMB am schnellsten.
Jumbo-Frames kann man ausprobieren, dürften aber bei Gigabit-LAN mehr Ärger als Nutzen bringen.
Ein Engpass ist aber auch der Prozessor auf dem NAS. Das ist mittlerweile sechs Jahre alt, und die j-Serie war schon immer die Billigserie von Synology. Falls Verschlüsselung eingeschaltet ist, ist Ausschalten der Verschlüsselung einen Versuch wert.

Wenn du deutlich schneller werden willst: 10-Gigabit-Ethernet (10GbE), aber nicht so, wie cpx schreibt. Wenn er das ernst meint, dann hat er keine Ahnung davon.
Was du dazu brauchst:
10GbE-Thunderbolt-Adapter, z. B. von Qnap, für 200,- Euro.
10GbE-Switch, am günstigsten bei Mikrotik ab 120,- Euro
10GbE-Karte für das NAS, gebraucht ab 35,- Euro, neu ab 200,- Euro, und wo du dabei bist auch noch eine für den PC
DAC-Kabel oder Glasfaser mit Transceivern, zwischen 20,- und 100,- Euro pro Verbindung bei günstigem Einkauf
Und vor allem brauchst du dann ein neues NAS, mind. drei Festplattem im Raid oder besser SSDs, mit ordentlichem Prozessor, und da wird es dann vierstellig in der Anschaffung.

Bei mir komme ich mit 10GbE am MacBook (Bj. 2017) lesend auf 920MByte/s, und das 2012er MB schafft immerhin noch 650MByte/s (was schneller ist als die eingebaute SSD, allerdings nur bei großen Dateien).
 

pk2061

Aktives Mitglied
Registriert
21.01.2005
Beiträge
1.316
Als Ergänzung zu meinem Post: Gucke mal im Diskstation Manager nach was dein NAS anzeigt, wenn du Daten auf das NAS kopierst / von dem NAS kopierst.
 

Anhänge

  • DSM.jpg
    DSM.jpg
    96,5 KB · Aufrufe: 22

Red--Baron

Neues Mitglied
Thread Starter
Registriert
30.04.2021
Beiträge
19
Ähm....
Ich glaube du verwechselt hier gerade Äpfel und Birnen.

Mit dem Speedtest testet du nicht dein Verbindung zum NAS oder deine WLAN oder deine LAN Geschwindigkeit sondern deine Verbindung zum Internet.
Du hast also scheinbar eine 100/50 Mbit Verbindung.
Deine Internetgeschwindigkeit wird am PC und Macbook nicht durch das LAN oder WLAN ausgebremst. Herzlichen Glückwunsch! ;)

Aber was willst du mit dem DISK Speed Test Anzeigen?
Die Lesegeschwindigkeit von deinem Rechner während du Daten kopierst?

Ich würde dafür eher die Anzeige vom DSM ablesen mit wieviel MB pro Sekunde das NAS Daten empfängt, während du da was drauf kopierst.
Nein, natürlich hat der Speedtest mit der LAN Geschwindigkeit nichts zu tun. Ich wollte damit nur zeigen das die Verbindung vom Macbook zum Router schneller kann als die vom Macbook zum NAS. Naja, egal, jedenfalls hast du (und Johanna K) einen guten Punkt! Das eine ist MBit/s, das andere MByte/s. Das hatte ich übersehen.
Aber ok, habe über WLAN jetzt eine 1GB Datei hochgeladen und hatte im Durchschnitt nur 20-25 MB's. Als ich den MacBook dann mit dem Kabel angeschlossen habe bekam ich dann im Durchschnitt 40MB's.

Ekran Resmi 2021-05-03 21.12.30.png


Immer noch ziemlich niedrig im Vergleich zum PC aber ich könnte ja damit noch leben wäre es nicht so schwierig eine Datei hochzuladen.
Ich füge mal hier ein Video ein, damit ihr mein Problem besser verstehen könnt.

 

mausfang

Aktives Mitglied
Registriert
04.08.2016
Beiträge
2.023
Ich wollte damit nur zeigen das die Verbindung vom Macbook zum Router schneller kann als die vom Macbook zum NAS.
NA JA. Ist ja nicht so - bzw. zeigst Du damit nicht auf.

108Mbit = 9MByte/s über den Router ins Internet ... wohingegen zum NAS 20MByte/s.

Ist zwar nicht zielführend für Dein Problem ... aber Du solltest Dir das mal ordentlich angewöhnen, wenn Du mit anderen "PC-fachkundigen" über Netzwerk-Geschwindigkeiten reden willst.

Sonst wirst am Ende nur ausgelacht.
 

diver68

Mitglied
Registriert
24.07.2011
Beiträge
470
Das stöbern auf den Ordnern klappt eigentlich Problemlos aber wenn ich versuche 20-30 Dateien (10-20MB's) in einen Ordner zu kopieren muss ich erst 2-3 Minuten warten und erst danach fängt der Mac an sehr lahm zu kopieren.
Stöbern auf einem Ordner mit ungefähr 10.000 Fotos ist eine Qual
Könnte auch an Universal Search liegen, das fordert die -J Modelle doch arg. Schau mal hier
https://www.synology-forum.de/threads/performance-probleme-mit-ds213j-durch-universal-search.114430/#post-939308
 

tinatrompete

Neues Mitglied
Registriert
17.03.2021
Beiträge
49
Für die Übertragung per WIFI sind 20-25 MB/s völlig ok. Da gibt es nix zu meckern.

40 MB/s über GBit LAN ist etwas mau, insofern du eine große Datei kopierst.
Das sollte, wie beim PC, so um die 100 MB/s sein.

Was für einen USB zu Ethernet Adapter verwendest du denn am MBA?
 

Johanna K

Mitglied
Registriert
28.10.2009
Beiträge
620
Immer noch ziemlich niedrig im Vergleich zum PC aber ich könnte ja damit noch leben wäre es nicht so schwierig eine Datei hochzuladen.
Ich füge mal hier ein Video ein, damit ihr mein Problem besser verstehen könnt.
Da ist noch was anderes faul. Das sollte wesentlich schneller gehen. Ich tippe eher auf ein Netzwerkproblem als auf ein Problem im NAS.

IP-Adresse doppelt vergeben? Kein anderes Gerät darf deine IP haben, und wenn du mit WLAN und LAN gleichzeitig verbunden bist, brauchst du dafür zwei verschiedene Adressen.

Port im Switch defekt? (Anderen Port testweise nehmen.)

Kabel defekt oder Kabelbruch?

USB-Port am Mac oder USB-Ethernet-Adapter defekt? (Eher selten, das hatte ich noch nie.)
 

Red--Baron

Neues Mitglied
Thread Starter
Registriert
30.04.2021
Beiträge
19
Leg doch mal bitte einen neuen Ordner auf dem Ziel Laufwerk an und Kopiere dann die gleichen Daten. Dauert es dann immer noch so lange ?
Nein.. Das geht in null komma nix... Das liegt eben daran das dieser Ordner über 12.000 Fotos hat. Alle anderen Ordner sind OK. Aber mit diesem Foto Ordner hat der PC eben keine Probleme. Der Macbook aber.
Bitte sag mir nicht die 12.000 Dateien in verschiedene Ordner unterteilen. Das kann ich nicht da dieser Ordner mit Onedrive synchronisiert wird.
(iPhone schieẞt Fotos, eine App, synchronisiert die Fotos vom iPhone auf den NAS. Das Nas synchronisiert die Fotos auf den Onedrive. Darum sind das so viele Fotos die ich jetzt nicht wieder verteilen will)
 

Red--Baron

Neues Mitglied
Thread Starter
Registriert
30.04.2021
Beiträge
19
NA JA. Ist ja nicht so - bzw. zeigst Du damit nicht auf.

108Mbit = 9MByte/s über den Router ins Internet ... wohingegen zum NAS 20MByte/s.

Ist zwar nicht zielführend für Dein Problem ... aber Du solltest Dir das mal ordentlich angewöhnen, wenn Du mit anderen "PC-fachkundigen" über Netzwerk-Geschwindigkeiten reden willst.

Sonst wirst am Ende nur ausgelacht.
Na für mich klang das logisch 😊 Aber ja, ihr seid ja die Experten. Wie gesagt ich bin der Frischling mit nur minimal Ahnung. Aber ja, ich merke mir das fürs nächste Mal, versprochen 😇
 

Red--Baron

Neues Mitglied
Thread Starter
Registriert
30.04.2021
Beiträge
19
Für die Übertragung per WIFI sind 20-25 MB/s völlig ok. Da gibt es nix zu meckern.

40 MB/s über GBit LAN ist etwas mau, insofern du eine große Datei kopierst.
Das sollte, wie beim PC, so um die 100 MB/s sein.

Was für einen USB zu Ethernet Adapter verwendest du denn am MBA?
Ist so ein billig Teil von Amazon. Marke Flyland. Bestimmt aus China. Aber ja, mit der Geschwindigkeit wäre ich ja noch einverstanden wenn er doch nicht bei diesem Ordner so hängen bleiben würde
 

Red--Baron

Neues Mitglied
Thread Starter
Registriert
30.04.2021
Beiträge
19
Da ist noch was anderes faul. Das sollte wesentlich schneller gehen. Ich tippe eher auf ein Netzwerkproblem als auf ein Problem im NAS.

IP-Adresse doppelt vergeben? Kein anderes Gerät darf deine IP haben, und wenn du mit WLAN und LAN gleichzeitig verbunden bist, brauchst du dafür zwei verschiedene Adressen.

Port im Switch defekt? (Anderen Port testweise nehmen.)

Kabel defekt oder Kabelbruch?

USB-Port am Mac oder USB-Ethernet-Adapter defekt? (Eher selten, das hatte ich noch nie.)
IP Addresse doppelt? Nein. Da weiss ich wo ich nachschauen muss. Aber nein. Alle haben eine eigene Addresse
Port im switch defekt? Denke nicht. Sonst wäre ja die PC-NAS Verbindung auch lahm. Die Macbook-NAS Verbindung habe ich über das Apple TV Kabel ausprobiert. Da habe ich auch keine Probleme.
Kabel defekt? Wie oben...
USB-Port am Mac oder USB-Ethernet Adapter defekt? Stimme dir zu das das ein seltener Fall wäre aber wie gesagt, meine Priorität wäre in diesem Fotos Ordner arbeiten zu können wie ich das auch auf dem PC mache.
 
Oben