1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Nach "Ordner verschieben" Ausführen nicht mehr möglich

Dieses Thema im Forum "Mac OS Entwickler, Programmierer" wurde erstellt von lucia, 13.05.2005.

  1. lucia

    lucia Thread Starter MacUser Mitglied

    Mitglied seit:
    04.01.2005
    Beiträge:
    166
    Zustimmungen:
    1
    Ich bin Cocoa-Neuling.

    Ich habe ein kleines Programm geschrieben, das in der Statusleiste ein Symbol einblendet mit einem Popup-Menü, über das ich die Prozessorleistung auf Min/Max/Auto stellen kann. Alles gut und schön. Funktioniert unter Panther und Tiger prima, solange ich meinen Ordner nicht verschiebe, aber genauer:

    Applikation ist in meinem Stammordner mit xcode kompiliert. Im Ordner build habe ich meine .apps-Datei. Klappt. Jetzt verschiebe ich den ganzen Stammordner (wo alle meine .h und .m und .xcode Dateien enthalten sind) auf den Desktop. Funktioniert nicht mehr.

    Das Programm greift auf drei .icns Dateien zu, die ich im Resourcen-Ordner eingebunden haben. Im Terminal kann ich diese Dateien auch tatsächlich im entsprechenden Unterordner des .apps-Ordners sehen. Sind also da.

    Was mache ich falsch? Wieso kann ich mein Programm nur ausführen, solange ich den ganzen Stammordner nach dem Kompilieren lasse, wo er vorher war. Übrigens kann ich die .apps-Datei hinlegen, wo ich will. Es kommt auf den Stammordner an. Beim Einfügen der .icns-Dateien habe ich darauf geachtet, daß das Feld "Ggf. Datei kopieren" angekreuzt war.

    Vielen Dank.
     
  2. lucia

    lucia Thread Starter MacUser Mitglied

    Mitglied seit:
    04.01.2005
    Beiträge:
    166
    Zustimmungen:
    1
    ok, jetzt habe auch ich den unterschied zwischen "development" und "deployment" verstanden. mein "hillegass" ist gerade per post gekommen. dann geht's einfach leichter...