MySQL klappt nicht mehr

  1. martinibook

    martinibook Thread Starter MacUser Mitglied

    Mitglied seit:
    20.08.2005
    Beiträge:
    8.632
    Zustimmungen:
    350
    Hallo,
    Ich habe auf meinem Rechner MySQL 4.x gehabt. Klappte wunderbar, auf einmal klappte es nicht mehr, es lässt sich nicht über das Systemsteuerungs-Teil starten. Auch nach OSX neuinstallation und jetzt MySQL 5.x klappt es auch nicht. Gab es da ein Update, mit dem es jetzt nicht mehr klappt?

    Martin
     
  2. martinibook

    martinibook Thread Starter MacUser Mitglied

    Mitglied seit:
    20.08.2005
    Beiträge:
    8.632
    Zustimmungen:
    350
    Klappt wieder :)
     
  3. martinibook

    martinibook Thread Starter MacUser Mitglied

    Mitglied seit:
    20.08.2005
    Beiträge:
    8.632
    Zustimmungen:
    350
    Wenn ich 127.0.0.1 eingebe (PHP-Skripte, Binär-MySQL-Administrator) dann klappt es. Mit localhost nicht. Woran lieght das?

    Martin
     
  4. wegus

    wegus MacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    14.982
    Zustimmungen:
    1.545
    am klappen ;)

    im ernst: Klappt/Klappt nicht ist keine Fehlerbeschreibung! Da kann Dir nur wenig geholfen werden (Mein Auto fährt nicht, warum?)! Es macht schon Sinn Programmversionen, Art des Zugriffs und aufgetretenen Fehler möglichst genau zu benennen!

    Ich verschieb das jetzt mal in's DB Forum!


    gruß wegus
     
  5. martinibook

    martinibook Thread Starter MacUser Mitglied

    Mitglied seit:
    20.08.2005
    Beiträge:
    8.632
    Zustimmungen:
    350
    Ich habe jetzt folgende Version: MySQL 5.0.18-standard.

    Wenn ich über diese logindaten reingehe, dann klappt es nicht:
    PHP:
    $server 'localhost';
    Dann kommt diese Meldung:
    Code:
    Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/mysql/mysql.sock' (2) in /Users/martin/Sites/Verschiedenes/BuchDB/login.inc.php on line 7
    
    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /Users/martin/Sites/Verschiedenes/BuchDB/login.inc.php on line 9
    
    Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /Users/martin/Sites/Verschiedenes/BuchDB/buch_autorensicht.php on line 37
    
    Warning: mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in /Users/martin/Sites/Verschiedenes/BuchDB/buch_autorensicht.php on line 40
    Mit denen schon:
    PHP:
    $server '127.0.0.1';
    Was kann das sein, ist das ein DNS Problem?
     
  6. wegus

    wegus MacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    14.982
    Zustimmungen:
    1.545
    da liegt der Fehler und wie Du siehst, ohne DNS da lokale Filesystemsuche. Die mysql.sock Datei wird schlicht an der falschen Stelle gesucht. Finde heraus, wo Dein mysql diese ablegt und trag den Pfad in Deine php.ini ein ( oder anders herum: ändere für mysql den socket-Pfad so, wie PHP ihn erwartet).
    Ich nehme mal an, daß der 2te Weg über das loopback-device vielleicht letztendlich doch nicht via TCP/IP-Zugriff erfolgt!? Sonst könnt ich mir nicht erklären warum der klappt, denn die socket-Datei dürfte auch dann nicht auffindbar sein.
     
  7. maceis

    maceis MacUser Mitglied

    Mitglied seit:
    24.09.2003
    Beiträge:
    16.696
    Zustimmungen:
    602
    Vermutlich /var/tmp/mysql.sock
    Kann man in der php.ini einstellen, wo gesucht wird, dann "klappt's" :)D) wieder.
     
  8. dackel

    dackel MacUser Mitglied

    Mitglied seit:
    22.10.2003
    Beiträge:
    818
    Zustimmungen:
    4
    Hab das gleiche Problem.
    Unter ... /var/ ... finde ich keine "mysql.sock".
    Lösungen?
     
  9. Incoming1983

    Incoming1983 MacUser Mitglied

    Mitglied seit:
    23.07.2005
    Beiträge:
    7.545
    Zustimmungen:
    1
    mysql.sock suchen
     
  10. catvarlog

    catvarlog MacUser Mitglied

    Mitglied seit:
    30.01.2005
    Beiträge:
    1.468
    Zustimmungen:
    1
Die Seite wird geladen...