MS Outlook für Mac ersetzt Backslash durch Slash

Azarod

Mitglied
Thread Starter
Mitglied seit
11.12.2009
Beiträge
6
Hallo MacUser-Community.

Ich habe folgendes Problem:
Ich würde gerne Links mit Windowsnutzern teilen. Die Convertierung des Links funktioniert sicher, hier kann ich den Fehler ausschließen, da Firmensoftware.
Aber was bei mir passiert wenn ich den Link in eine Email in MS Outlook setze ist, dass das Programm aus
file:\\...
file:///
macht.
Der Text des Links sieht optisch ok aus, aber der dahinter liegende Link wird eben automatisch so gesetzt. Selbst wenn ich in Link bearbeiten gehe und nochmal den richtigen Link als Text einfüge mit "file:\\.." und OK klicke ist dennoch wieder "file:///.." hinterlegt.

Woran kann das liegen? Ich hab schon Autokorrektur ausgeschaltet.

Danke euch schon Mal.
Viele Grüße
Azador
 

fa66

Mitglied
Mitglied seit
16.04.2009
Beiträge
13.022
Ich kann das geschilderte Verhalten zumindest für das betagte Outlook2011-14.7.7 weder in formatierten (HTML), noch in Nur-Text-Emails nachvollziehen. Auch mit eingeschalteten Autokorrektur- und Autoformat-Optionen (»Internet- und Netzwerk-Pfade durch Links«) bleiben mit Backslash in den Emailtext getippte Pfade mit Backslash. Auch nach Speichern und Wiederöffnen zur Weiterbearbeitung hat sich nichts getan.

OL2011.jpg

Zu welchem Zeitpunkt der Emailbearbeitung oder des Emailversands bemerkst du die Änderung des dahinterliegenden Link-Codes?

EDIT:
Ich kann mit OL2011 (und für den parallelen Empfang mit Mail-12.4) weder in der im Posteingang (beider Programme) befindlichen Email noch in der unter Gesendete Elemente in OL2011 abgelegte Email beobachten, dass besagte getippte Links sich nunmehr geändert hätten.
 

Azarod

Mitglied
Thread Starter
Mitglied seit
11.12.2009
Beiträge
6
Hi fa66,

ich dachte mir schon, dass es an meinem Rechner liegt :)
Wenn ich den Link als reinen Text nehme "file:\\europe.ext.corp\..." dann steht der Link als Text da und diesen kann man zwar kopieren und im Explorer auf Windows eingeben. (Probleme gibts nur wenn Leerzeichen dazwischen, weil es nicht richtig übernommen wird)

Wenn ich per Button "Link einfügen" klicke und den gleichen URL-Text eingebe, OK klicke, dann macht Outlook automatisch aus file:\\ zu file:///...

Ich glaube auch, dass irgendwo noch ein Automator? Skript läuft aber ich finde dazu nichts. Wenn ich Automator öffne, dann habe ich noch nicht raus gefunden wie man bestehende Workflows sieht und löscht.

Echt verwirrend.
Danke schon mal.
 

fa66

Mitglied
Mitglied seit
16.04.2009
Beiträge
13.022
Wenn ich per Button "Link einfügen" klicke und den gleichen URL-Text eingebe, OK klicke, dann macht Outlook automatisch aus file:\\ zu file:///...
Als URI ist das auch richtig so. Es geht ja, vereinfacht formuliert, um »Links«, wie sie in HTML gebräuchlich sind. Was das jeweilige Ziel-Betriebssystem dann beim Klick draus macht, obliegt diesem.

Nebenbei verweist ein vollständiger Pfad, der mit file: eingeleitet wird, auf ein lokales Ziel. Ist denn gewährleistet, dass der Pfad beim Empfänger der Email noch gültig ist?

Auch gefragt: Gibt es denn bekannte Probleme wenn der Empfänger deiner Email den Link anklickt?
 

mj

Mitglied
Mitglied seit
19.11.2002
Beiträge
8.578
Macht mein Outlook genauso, aber ist doch korrekt. Der Backslash wird nur in Windows URIs verwendet wenn man direkt Netzlaufwerke referenziert, also z.B. \\server\freigabe. Gibt man dagegen das Protokoll vorneweg an, also http, smb oder file ist die korrekte Syntax ein Doppel- oder Trippelslash.
 
Oben