Mountain Lion will, dass ich Java installiere. Warum?

uselessuser

Mitglied
Thread Starter
Mitglied seit
11.09.2005
Beiträge
447
Hallo Internet,

Nach der Mountain Lion Installation ist mein (unter Lion installiertes) Java scheinbar wieder weg. Allerdings werde ich regelmäßig darauf hingewiesen, dass "jar" Java benötigt. Die Meldung kommt ungerelmäßig und ohne dass ich etwas gestartet hätte oder derlei.
Der "braucht Java"-Dialog sagt mir leider nicht, wo diese Datei namens "jar" liegt, die da gestartet werden soll. Natürlich habe ich diverse .jar-Dateien auf meiner Platte liegen, aber keine die "jar.jar" heißt. Ist also die Dialogbox buggy? Wie kann ich herausfinden was da gestartet werden soll?
 

Mac-Bene

Aktives Mitglied
Mitglied seit
18.03.2006
Beiträge
5.568
Ist es evtl. einfach nur irgendwo auf einer Internetseite ein kleines Applet?
Um zu Testen, ob Java installiert ist, einfach mal im Terminal "java -version" eintippen und Enter druecken. Alternativ gucken, ob unter Dienstprogramme->Java Einstellungen ein JRE/JDK gelistet ist.
 

uselessuser

Mitglied
Thread Starter
Mitglied seit
11.09.2005
Beiträge
447
Tatsache, beim Upgrade wurden Safaris Einstellungen zurückgesetzt und Java wieder erlaubt. Mal sehen ob die Meldung nochmal auftaucht. Danke!
 

InkognitoX

Mitglied
Mitglied seit
06.04.2011
Beiträge
51
Der "braucht Java"-Dialog sagt mir leider nicht, wo diese Datei namens "jar" liegt, die da gestartet werden soll.
Wie schon drauf hingewiesen handelt es sich um ein Java-Archiv das man ausführen kann wie ein normales Programm, z. B. den Anonymisierer JAP - jap.jar. Unter Linux mußte man den auch von der Kommandozeile aus starten: java -jar jap.jar

Die auftretenden Aufforderungen das Java benötigt wird könnten vom System stammen, daß bei bestimmten Aktionen ein Javaprogramm starten will, aber mangels Java nicht kann. -- Vielleicht ist es aber auch der Flashback-Trojaner, eine .jar-Datei, der endlich aus der Flasche will. :crack:

Aber im Ernst, offenbar will das System ein Programm ausführen. Nachdem Java installiert wurde mit dem angegebenen Befehl java -version prüfen ob es funktioniert, gefunden wird. (Mit Perl ist es dasselbe - weiß nicht, ob man das unter OSX braucht, unter Linux war es unverzichtbar.)

Javaversion.jpg
 
Zuletzt bearbeitet: