Mit FM Rechnen

NorbertH

Mitglied
Thread Starter
Mitglied seit
24.02.2006
Beiträge
571
Hallo

Heute schein ich etwas Vernebelt zu seihen.

Bekomme die Berechnung nicht hin.

Gegeben sind die Werte eines Betriebsstundenzähler
Abgabe – Wert : 2280,05 Std.
Rückgabe – Wert: 2282,06 Std.
Laufzeit: (Rückgabe-Wert – Abgabe-Wert) = 2,01 Std.

Für eine Stunde wird 23,50 € Berechnet(Netto).

Somit währe das richtige Ergebnis: 47,39 €

Wer hat die richtige Formel um den Betrag zu Errechnen.

2,01 * 23,50 = 47,24 € somit Falsch.
 

Lor-Olli

Aktives Mitglied
Mitglied seit
24.04.2004
Beiträge
9.243
Mal testen ob hier noch alle wach sind???
Dreisatz vom Ansatz her richtig:) aber wie du auf DEIN Ergebnis kommst ist mir schleierhaft :confused:
Tip: ein Blatt Papier und eine Stift und mal auf die altmodische Art versuchen…
 

NorbertH

Mitglied
Thread Starter
Mitglied seit
24.02.2006
Beiträge
571
2 Std. = 23,50 *2 = 47,00 €
1 min. = 23,50/60 = 0,39 €
Betrag = 47,00 + 0,39 = 47,39 €
 

Satome

Mitglied
Mitglied seit
20.11.2006
Beiträge
230
Hallo NorbertH,

[Laufzeit: (Rückgabe-Wert – Abgabe-Wert) = 2,01 Std.

Für eine Stunde wird 23,50 € Berechnet(Netto).

Somit währe das richtige Ergebnis: 47,39 €

Wer hat die richtige Formel um den Betrag zu Errechnen.

2,01 * 23,50 = 47,24 € somit Falsch.[/QUOTE]

Das Ergebnis 47,39€ kann nur richtig sein, wenn Du mit 2,01 Std. eigentlich 2 Std. und 1 min. meinst, das sind dann aber dezimal keine 2,01 Std., sondern 2,02 (genauso, wie 2 Std. 15 min nicht 2,15 Stunden, sondern 2,25h sind).

Grüße,
Satome
 

NorbertH

Mitglied
Thread Starter
Mitglied seit
24.02.2006
Beiträge
571
Satom genau so ist es 2 Std und 1 min.

Nur als Ergebnis liegt 2,01 im Feld Laufzeit und somit für mich als Grundlage der Berechnung.
 

Satome

Mitglied
Mitglied seit
20.11.2006
Beiträge
230
Hallo NorbertH,

da liegt auch das Problem. 2,01 sind nicht korrekt.

Grüße,
Satome
 

Satome

Mitglied
Mitglied seit
20.11.2006
Beiträge
230
Schau Dir mal unsere Zeiterfassung an, da siehst Du, daß auf digital umgerechnet wird. Vielleicht kannst du das ja in Deine Tabelle einbauen...

Grüße,
Satome
 
Zuletzt bearbeitet:

NorbertH

Mitglied
Thread Starter
Mitglied seit
24.02.2006
Beiträge
571
Letztendlich ist es schon Richtig da es ja 2 Std. und 01 Minuten sind die dei Maschiene gelaufen ist.

Der Betriebsstundenzähler zählt auch dementsprechend.
2280,05 sind 2280 Std. und 05 Minuten.

Das sind die Werte die gegeben sind.
 

NorbertH

Mitglied
Thread Starter
Mitglied seit
24.02.2006
Beiträge
571
Satome hast du einen Link zur Zeiterfassung??


Ich hätte länger Warten sollen....... Danke Satome
 
Zuletzt bearbeitet:

Lor-Olli

Aktives Mitglied
Mitglied seit
24.04.2004
Beiträge
9.243
@Norbert H,
nicht böse gemeint, in einer Tabellenkalkulation, oder anderen Computerberechnungen gibt es das Problem mit der "Nullzeit" (am Apple 1.1.1904, wenn man 0 Stunden zur Berechnung verwendet).
du musst die Minuten separat durch 60 teilen und erhälst den Dezimalwert in Stunden, den zu den vollen Stunden addierst und mit dem Betrag multiplizierst)
= (stunden+(minuten/60)) * Betrag
= (2+(1/60))*23,50 = 47,39
abhängig vom Programm musst du die Schritte der Stunden /Minutentrennung anpassen (bei Exel gibt es Funktionen zum Auslesen)
 

Satome

Mitglied
Mitglied seit
20.11.2006
Beiträge
230
Letztendlich ist es schon Richtig da es ja 2 Std. und 01 Minuten sind die dei Maschiene gelaufen ist.

Der Betriebsstundenzähler zählt auch dementsprechend.
2280,05 sind 2280 Std. und 05 Minuten.

Das sind die Werte die gegeben sind.
das mag ja sein, aber 2280 Std. und 5 Minuten sind keine 2280,05 Stunden, sondern 2280,08 Stunden, d.h. Deine Umrechnung stimmt nicht.

Wenn Du den Wert aber nur so zur Verfügung gestellt bekommst, mußt Du wie folgt umrechnen:

Voraussetzung: Wert steht in Zelle A1
=WENN(A1="";"";RUNDEN((A1-GANZZAHL(A1))*5/3;2)+GANZZAHL(A1))

Dieser Wert ist dann dezimal, den kannst Du dann mit dem Stundensatz multiplizieren.

Grüße,
Satome
 

NorbertH

Mitglied
Thread Starter
Mitglied seit
24.02.2006
Beiträge
571
@Lor-Olli,

bin dir nicht Böse, warum auch.

Das das Ergebnis 2,01 einerseits Richtig und andererseits Falsch ist war mir schon Bewusst.

Ich hatte nur gehofft das einer eine „Formel“ hätte um das Fleddern der Laufzeit zu verhindern.
 

Satome

Mitglied
Mitglied seit
20.11.2006
Beiträge
230
wirf mal nen Blick auf die Jahresangabe: 2003 :p

Keine Sorge, wir arbeiten inzwischen auch länger... :D

@NorbertH: siehe posting #14

Grüße,
Satome
 

Lor-Olli

Aktives Mitglied
Mitglied seit
24.04.2004
Beiträge
9.243
Was zu klären gilt: liefert der Betriebsstundenzähler bereits eine ins Dezimale umgerechnete Zahl (2800,05), oder steht der Betrag für 2800 Stunden 5 Minuten. In ersterem Fall sind 2,01 Stunden korrekt und auch der Betrag von 47,24 ist richtig. (In der Industrie sind die Zählwerke öfter mal auf 100 Minuten je Stunde eingestellt)
Handelt es sich aber um 2800 Stunden und 5 Minuten (2 Stunden und 1 Minute als Differenz) musst du die Minuten erst noch in einen Dezimalbetrag umrechnen (also durch 60 teilen)
 

NorbertH

Mitglied
Thread Starter
Mitglied seit
24.02.2006
Beiträge
571
Jo habe nr. 14 gesehen und Bedanke mich bei dir dafür.

So dann hätten wir den Betriebsstundenzähler Nummer 1 Std. und Minuten.

Der nächste gibt nur Minuten an
35369 Minuten

und ein weiterer 3536 Std. 5 1/10 min.

Ich liebe diese Betriebsstundenzähler, jeder Hersteller macht es anders.
 

MACboerse.de

Mitglied
Mitglied seit
05.03.2007
Beiträge
197
Ich hatte nur gehofft das einer eine „Formel“ hätte um das Fleddern der Laufzeit zu verhindern.
=WENN(A1="";"";RUNDEN((A1-GANZZAHL(A1))*5/3;2)+GANZZAHL(A1))


Hallo Norbert,

entweder habe ich etwas nicht verstanden, oder es geht viel einfacher und OHNE komplizierte Formel:

1) Du verrechnest die Betriebsstunden. Das Ergebnisfeld muss eine Uhrzeit (Apfel+1 -> Uhrzeit) sein.
2) In einem (neuen) Feld dann diesen Wert mit 24 (Stunden) multiplizieren.
3) Als Ergebnis = einen dezimalen Wert, den Du dann mit dem Stundenlohn multiplizieren kannst.

Gruß, Michael
 
Zuletzt bearbeitet:
Oben