Benutzerdefinierte Suche

Mamp

  1. carat

    carat Thread StarterMacUser Mitglied

    Mitglied seit:
    06.09.2005
    Beiträge:
    15
    Zustimmungen:
    0
    hallo. mein erstes post :)

    ich habe ein problem mit mamp. ich habe es installiert, den server gestartet und er läuft auch.

    meine files in den ordner »htdocs« kopiert und hier schon viel gesucht, gelesen und ausprobiert.

    trotzdem zeigt safari mir nur den sourcecode an.

    ws mache ich falsch?
    was habe ich vergessen?

    ich benutze OS X 10.4.2 + MAMP 1.0.1

    danke und gruss
     
    carat, 06.09.2005
  2. mikne64

    mikne64MacUser Mitglied

    Mitglied seit:
    02.04.2004
    Beiträge:
    3.097
    Zustimmungen:
    92
    Hallo,

    willkommen im Forum! :)

    Hast Du auch kontrolliert ob z.B. für PHP die entsprechenden Einträge in der Datei httpd.conf auskommentiert sind? Dazu gibt es auch ein paar Threads hier im Forum.

    Viele Grüße
    Michael
     
    mikne64, 06.09.2005
  3. Kruemel_ddorf

    Kruemel_ddorfMacUser Mitglied

    Mitglied seit:
    17.02.2004
    Beiträge:
    787
    Zustimmungen:
    2
    Den Spurce code von html dateinen ? Den Source code von php files ? den sourcecode deiner DB ??

    Mein Tipp ins Blaue fuer heute :

    AddType oder AddHandler

    gruss
    Kruemel
     
    Kruemel_ddorf, 06.09.2005
  4. carat

    carat Thread StarterMacUser Mitglied

    Mitglied seit:
    06.09.2005
    Beiträge:
    15
    Zustimmungen:
    0
    oh. vielen dank für die schnellen antworten.

    gemeint ist der sourcecode der php-files.
    den htdocs-tip aus diesem thread hab ich schon probiert. hat auch nichts gebracht.
    es sei denn man muss den rechner oder safari dann neustarten - das habe ich nicht getan.
    sollte ich?

    bevor ich aber die dateien selbst bearbeite würde ich gerne andere fehlerquellen ausschliessen.
    vielleicht ist es ja ein ganz blöder fehler - man weiss ja wie das immer so ist … :rolleyes:

    was ist »AddType« oder »AddHandler«?

    gruss
     
    carat, 06.09.2005
  5. Kruemel_ddorf

    Kruemel_ddorfMacUser Mitglied

    Mitglied seit:
    17.02.2004
    Beiträge:
    787
    Zustimmungen:
    2
    es sollte reichen, wenn du den apache neu startest und du solltest sicher sein, das der lokal installierte nicht antwortet und dein neu insstallierter Apache sich gar nicht ruehrt....

    AddType und AddHandler sind apache anweisungen wie er mit entsprechenden Dateien umgehen soll. Die sollten in der httpd.conf entsprechend aufgelistet sein


    gruss
    Kruemel
     
    Kruemel_ddorf, 06.09.2005
  6. carat

    carat Thread StarterMacUser Mitglied

    Mitglied seit:
    06.09.2005
    Beiträge:
    15
    Zustimmungen:
    0
    also hab den apache ausgeschaltet, die änderungen (httpd.conf) vorgenommen und will jetzt apache neu starten.
    er versucht es auch aber schafft es nicht (rainbow of death) …
     
    carat, 06.09.2005
  7. hossa

    hossaMacUser Mitglied

    Mitglied seit:
    03.04.2005
    Beiträge:
    309
    Zustimmungen:
    0
    1. Bist du sicher das mamp gestartet ist?
    2. Liegen die php files im "programme->mamp->htdocs" Ordner?
    3. Rufst du die files unter der Url "http://localhost:8888/deinphpfile.php" auf?
    (der Port 8888 ist bei Mamp standard, kannst du unter Einstellungen in Mamp ändern)

    wenn du alle 3 Punkte mit ja beantworten kannst kann ich dir leider auch nicht weiterhelfen ;-)
     
    hossa, 06.09.2005
  8. carat

    carat Thread StarterMacUser Mitglied

    Mitglied seit:
    06.09.2005
    Beiträge:
    15
    Zustimmungen:
    0
    daran lag es!!!!

    [​IMG]

    warum sagt einem das keiner? [​IMG]

    danke hossa!

    [​IMG]
     
    carat, 06.09.2005
  9. hossa

    hossaMacUser Mitglied

    Mitglied seit:
    03.04.2005
    Beiträge:
    309
    Zustimmungen:
    0
    büdde *GG*
     
    hossa, 06.09.2005
  10. carat

    carat Thread StarterMacUser Mitglied

    Mitglied seit:
    06.09.2005
    Beiträge:
    15
    Zustimmungen:
    0
    jetzt bekomme ich kine verbindung zur db :o

    PHP:
    <?php
    // ** MySQL settings ** //
    define('DB_NAME''test');
    define('DB_USER''root');
    define('DB_PASSWORD''root');
    define('DB_HOST''localhost:8889');
    was mach ich nun falsch?
     
    carat, 06.09.2005
Die Seite wird geladen...
Ähnliche Themen - Mamp
  1. malah
    Antworten:
    3
    Aufrufe:
    1.165
    beatles
    10.02.2017
  2. Bantam
    Antworten:
    3
    Aufrufe:
    1.398
    nonpareille8
    03.03.2016
  3. rodriguez
    Antworten:
    0
    Aufrufe:
    760
    rodriguez
    02.01.2015
  4. Akeno
    Antworten:
    5
    Aufrufe:
    1.312
  5. Ichliebedich
    Antworten:
    1
    Aufrufe:
    1.033
    falkgottschalk
    10.09.2014