El Capitan Mail stürtzt beim Starten ab

maxxio

Mitglied
Thread Starter
Mitglied seit
11.03.2004
Beiträge
449
Liebe Gemeinde,
mein Mail startet nicht mehr.

Habe auch schon das hier gemacht:
Entferne die Dateien "Envelope Index", "Envelope Index-wal" und "Envelope Index-shm" aus dem Verzeichnis ~/Library/Mail/V5/MailData
Am Besten in den Papierkorb verschieben, aber nicht löschen für den Fall, dass Du sie doch wieder brauchst.

Leider keine Besserung erreicht.

Hatte einer schon mal das Problem und kann mir bei der Lösung behilflich sein?

Danke vorab.

Leider ist der Fehlerbericht so lang, dass ich ihn nicht hier posten kann. Wie kann ich den den hier einstellen?
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
55.192
In Crashlogs steht so viel unnützes drin, das lohnt nicht alles rein zu kopieren.
Thread crashed wäre interessant.
 

maxxio

Mitglied
Thread Starter
Mitglied seit
11.03.2004
Beiträge
449
Process: Mail [685]
Path: /Applications/Mail.app/Contents/MacOS/Mail
Identifier: com.apple.mail
Version: 9.3 (3124)
Build Info: Mail-3124000000000000~2
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Mail [685]
User ID: 501

Date/Time: 2020-11-22 13:12:47.919 +0100
OS Version: Mac OS X 10.11.6 (15G22010)
Report Version: 11
Anonymous UUID: DB684D3A-F1D4-842A-3424-08087BC593F3

Sleep/Wake UUID: 9AD3D412-0DDD-4D9B-B5B7-1752E9CDC3EF

Time Awake Since Boot: 3000 seconds
Time Since Wake: 64 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000018
Exception Note: EXC_CORPSE_NOTIFY

VM Regions Near 0x18:
-->
__TEXT 0000000105efa000-00000001062b5000 [ 3820K] r-x/rwx SM=COW /Applications/Mail.app/Contents/MacOS/Mail

Application Specific Information:
objc_msgSend() selector name: release


Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libobjc.A.dylib 0x00007fff8416b4dd objc_msgSend + 29
1 com.apple.CoreText 0x00007fff8b3c4458 TTruncator::TruncateEndChars(long, double, TLine&, bool*) + 1010
2 com.apple.CoreText 0x00007fff8b3c3f08 TTruncator::EndTruncate(double, __CTRun const* (__CTLine const*, CFRange*, __CFDictionary const*) block_pointer) + 94
3 com.apple.CoreText 0x00007fff8b3c3bef CTLineCreateTruncatedLineWithTokenHandler + 182
4 com.apple.UIFoundation 0x00007fff956c4f1e __NSStringDrawingEngine + 24489
5 com.apple.UIFoundation 0x00007fff956bd302 _NSStringDrawingCore + 159
6 com.apple.AppKit 0x00007fff8317aab2 _NSDrawTextCell2 + 7035
7 com.apple.AppKit 0x00007fff83183a53 -[NSTextFieldCell drawInteriorWithFrame:inView:] + 997
8 com.apple.AppKit 0x00007fff83172ceb __40-[NSTextFieldCell drawWithFrame:inView:]_block_invoke + 451
9 com.apple.AppKit 0x00007fff830fb108 +[NSAppearance _performWithCurrentAppearance:usingBlock:] + 79
10 com.apple.AppKit 0x00007fff83172a3f -[NSTextFieldCell drawWithFrame:inView:] + 238
11 com.apple.AppKit 0x00007fff8316c388 -[NSControl drawRect:] + 342
12 com.apple.AppKit 0x00007fff8316a7be -[NSView(NSInternal) _recursive:displayRectIgnoringOpacity:inGraphicsContext:CGContext:topView:shouldChangeFontReferenceColor:] + 1331
13 com.apple.AppKit 0x00007fff8316ab8c -[NSView(NSInternal) _recursive:displayRectIgnoringOpacity:inGraphicsContext:CGContext:topView:shouldChangeFontReferenceColor:] + 2305
14 com.apple.AppKit 0x00007fff8316ab8c -[NSView(NSInternal) _recursive:displayRectIgnoringOpacity:inGraphicsContext:CGContext:topView:shouldChangeFontReferenceColor:] + 2305
15 com.apple.AppKit 0x00007fff8316a156 __46-[NSView(NSLayerKitGlue) drawLayer:inContext:]_block_invoke + 242
16 com.apple.AppKit 0x00007fff83169caf -[NSView(NSLayerKitGlue) _drawViewBackingLayer:inContext:drawingHandler:] + 2403
17 com.apple.AppKit 0x00007fff83169341 -[NSView(NSLayerKitGlue) drawLayer:inContext:] + 108
18 com.apple.QuartzCore 0x00007fff86860a05 CABackingStoreUpdate_ + 3494
19 com.apple.QuartzCore 0x00007fff8685fc59 ___ZN2CA5Layer8display_Ev_block_invoke + 59
20 com.apple.QuartzCore 0x00007fff8685f645 CA::Layer::display_() + 1565
21 com.apple.AppKit 0x00007fff83168318 _NSBackingLayerDisplay + 641
22 com.apple.AppKit 0x00007fff8315a878 -[_NSViewBackingLayer display] + 818
23 com.apple.QuartzCore 0x00007fff8685138d CA::Layer::display_if_needed(CA::Transaction*) + 603
24 com.apple.QuartzCore 0x00007fff86850eb5 CA::Layer::layout_and_display_if_needed(CA::Transaction*) + 35
25 com.apple.QuartzCore 0x00007fff86850389 CA::Context::commit_transaction(CA::Transaction*) + 277
26 com.apple.QuartzCore 0x00007fff8684ffd4 CA::Transaction::commit() + 508
27 com.apple.QuartzCore 0x00007fff8685b863 CA::Transaction::observer_callback(__CFRunLoopObserver*, unsigned long, void*) + 71
28 com.apple.CoreFoundation 0x00007fff85c0dfc7 __CFRUNLOOP_IS_CALLING_OUT_TO_AN_OBSERVER_CALLBACK_FUNCTION__ + 23
29 com.apple.CoreFoundation 0x00007fff85c0df37 __CFRunLoopDoObservers + 391
30 com.apple.CoreFoundation 0x00007fff85bed52a __CFRunLoopRun + 1178
31 com.apple.CoreFoundation 0x00007fff85bece28 CFRunLoopRunSpecific + 296
32 com.apple.HIToolbox 0x00007fff89546935 RunCurrentEventLoopInMode + 235
33 com.apple.HIToolbox 0x00007fff8954676f ReceiveNextEventCommon + 432
34 com.apple.HIToolbox 0x00007fff895465af _BlockUntilNextEventMatchingListInModeWithFilter + 71
35 com.apple.AppKit 0x00007fff83001df6 _DPSNextEvent + 1067
36 com.apple.AppKit 0x00007fff83001226 -[NSApplication _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 454
37 com.apple.AppKit 0x00007fff82ff5d80 -[NSApplication run] + 682
38 com.apple.AppKit 0x00007fff82fbf368 NSApplicationMain + 1176
39 libdyld.dylib 0x00007fff846465ad start + 1
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
55.192
Kann halt irgendeinen Text nicht darstellen.
Mail hatte doch auch einen Safe Start mit shift.
Halt mal Shift gedrückt, nach dem doppel klicken auf das App Icon.
 

maxxio

Mitglied
Thread Starter
Mitglied seit
11.03.2004
Beiträge
449
Also das mir dem Safe start bekomme ich nicht hin.
Ich bin aber einen kleinen schritt weiter.
Ich habe 3 Mail Accounts. Wenn ich jetzt starte, dann ist in dern linken Spalte kein Ordner ausgewählt. Ich kann alle Ordner auswählen und er zeigt mir auch die Mail darin an. Nur wenn ich auf den Posteingang des wichtigsten Accounts gehe, dann stürtzt er ab.
 

KOJOTE

Aktives Mitglied
Mitglied seit
06.11.2004
Beiträge
6.857
Backup hast du?
Mails über POP oder IMAP?
Du kannst auch über Mail > Menü > Postfach > Wiederherstellen, wählen.

Unabhängig davon:
Teste mal auf einem anderen Benutzer ob es sich da mit diesem Account auch so verhält.
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
55.192
Da musst du mal die Mails in dem Crash Account durchgehen, eine davon macht den Crash.
 

maxxio

Mitglied
Thread Starter
Mitglied seit
11.03.2004
Beiträge
449
Backup hast du?
Mails über POP oder IMAP?
Du kannst auch über Mail > Menü > Postfach > Wiederherstellen, wählen.

Unabhängig davon:
Teste mal auf einem anderen Benutzer ob es sich da mit diesem Account auch so verhält.

Backup habe ich. Ich habe das Backup als externe Platte an einem anderen Rechner gestartet um Hardwarefehler auszuschliessen. Da habe ich einen neuen User angelegt und in Mail den betreffenden Account hinzugefügt. Und es läuft! Danke @KOJOTE für den Tip.
Ich hätte grundsätzlich kein Proiblem damit mit einem neuen Benutzer zu arbeiten, brauche aber natürlich die ganzen einstellunegn etc. des alten. Was wäre denn da eine adäquate Lösung?
 

KOJOTE

Aktives Mitglied
Mitglied seit
06.11.2004
Beiträge
6.857
Es scheint du verwendest IMAP für deine Mails. Bevor du nun vom neuen Benutzer die Einstellungen für Mail auf den alten Benutzer holst, würde ich mal versuchen, den betroffenen Account im alten Benutzer in Apple-Mail zu löschen und dann neu hinzuzufügen.
Vielleicht löst sich dabei der Knoten.
Ergänzend könntest du im neuen Benutzer mal alle E-Mails des betroffenen Accounts löschen die du nicht mehr brauchst, ggf. rückblickend zu der Zeit als die Probleme begannen.
 
  • Gefällt mir
Reaktionen: dg2rbf

maxxio

Mitglied
Thread Starter
Mitglied seit
11.03.2004
Beiträge
449
Jetzt habe ich mal ein komplette neues System aufgesetzt. Den betreffenden Account in Mail integiriert und Mails abgerufen. Zack, gleiches Thema. Mail stürzt wieder ab.
Es ist für mich auch nicht ersichtlich ob es an einer bestimmten korupten Mail liegt.
 

KOJOTE

Aktives Mitglied
Mitglied seit
06.11.2004
Beiträge
6.857
Jetzt habe ich mal ein komplette neues System aufgesetzt.
Wie bist du dabei vorgegangen? Wenn du per Recovery das System drüber gebügelt hast, bleiben die Benutzerdaten ja weiter bestehen und da bei deinem Test mit einem anderen Benutzer ja alles geklappt hatte, bringt dir das eigentlich nichts. Es ging doch am anderen Nutzer, oder?
 

maxxio

Mitglied
Thread Starter
Mitglied seit
11.03.2004
Beiträge
449
Erwischt.
Ich habe auf einer Externen Platte ein nues System Aufgesetzt und den Benutzer importiert. Voll dumm von mir, wenn ich das gerade selber lese. Ich mach mal nen neuen Benutzer und muss dann die wichtigen Daten händisch rüberziehen...
 

maxxio

Mitglied
Thread Starter
Mitglied seit
11.03.2004
Beiträge
449
So, jetzt habe ich ein neu aufgesetztes System einen neuen Benutzer und alle Daten händisch übertragen. Und es läuft.
Danke noch mal an alle für die Hilfe.
 
  • Gefällt mir
Reaktionen: dg2rbf und KOJOTE
Oben