Mail spinnt total

macstephan

Mitglied
Thread Starter
Mitglied seit
24.11.2007
Beiträge
86
Hallo.
Mail lässt E-Mails einfach verschwinden, legt sie wild durcheinander ab und zeigt Mails an, die angeblich nicht vom Server geladen werden. Das sind immer Mails mit genau der Uhrzeit, wo ich Mail starte. Alle Mails an mich kommen an. Aber nach verlassen von Mail und wieder starten sind die voher eingegangenen Mails futsch. Weg, nirgends mehr...?
Dann werden Mails angezeigt, die angeblich im Mülleimer oder Eingangsordner liegen, aber keine drinnen sind. Ich vermute, mir hat es bei Mail irgend eine Datei zerbröselt und jetzt spinnt das Programm völlig. Rechte habe ich auch schon repariert, aber erfolglos. Würde es helfen, wenn ich Mail nochmal von der Sytem DVD installiere? Also "drüberbügle"? sind dann meine ganzen Zugangsdaten auch weg, oder bleiben die erhalten wenn ich das tue?
Danke und Grüße
 

eMac_man

Aktives Mitglied
Mitglied seit
08.10.2003
Beiträge
30.116
Ohne auf Deine fehlenden Informationen einzugehen: Nein, es bringt gar keine Besserung, wenn Du Mail.app von der Install-Disc neu installierst. Die Einstellungen von Mail liegen nämlich in Deinem Home-Verzeichnis und bleiben bei einer Neuinstallation von Mail völlig unberücksichtigt.
Gruss
der eMac_man
 

macstephan

Mitglied
Thread Starter
Mitglied seit
24.11.2007
Beiträge
86
Danke für Deinen Tipp. Was für Informationen fehlen?
 

eMac_man

Aktives Mitglied
Mitglied seit
08.10.2003
Beiträge
30.116
Danke für Deinen Tipp. Was für Informationen fehlen?
Nun, z.B. verwendetes BS (und damit Version von Mail) und POP- oder IMAP-Account?
Ich würde den Mail-Ordner im Home-Verzeichnis sichern (an andere Stelle kopieren), dann die plist-Datei von Mail löschen und den Account in Mail neu anlegen. Beim Löschen der plist-Datei sollte Mail geschlossen sein.
Gruss
der eMac_man
 

lundehundt

abgemeldet
Mitglied seit
22.02.2003
Beiträge
19.147
ich wuerde die Datei ~/Library/Preferences/com.apple.mail.plist loeschen und mir ein neues Benutzerkonto mit deinen Zugangsdaten anlegen. Und dann die Option Mailboxes Importieren aus dem Ablage Menu von mail waehlen. Dann waehlst du ~/Library/Mail/Alter_Mailaccount (die ~steht fuer dein Home Verzeichnis) von dem importiert werden soll. Wenn das zu deiner Zufriedenheit passiert ist, kannst du die mails des Alten_Mailaccount under ~/Library/Mail/Alter_Mailaccount loeschen
 

Chris.b

Aktives Mitglied
Mitglied seit
21.06.2005
Beiträge
1.394
Ähnliches Problem, das keinen eigenen Thread braucht: Mail holt manche Nachrichten nicht vom Server, woran kann das liegen? Wenn ich im Browser in mein Postfach gehe sind sie da, aber nie in Mail.app gelandet. (alles Mails von einem Absender, über ein paar Tage verteilt verschickt, im Postfach komischerweise schon als gelesen markiert.)

Dienst: GMX, POP
BS: Leo, also Mail 3.2

Hat jemand mein Postfach gehackt? (mäßig ernst gemeint)
 

tgam

Aktives Mitglied
Mitglied seit
15.02.2008
Beiträge
1.300
Bevor Du Dir all die Mühe des Neuinstallierens machst versuche erst einmal folgendes: Wähle in Deinem Benutzer Ordner den von Mail aus, finde darin die Datei "Envelope Index" - hier sind die Indizes und Aktivitäten des Programms verzeichnet - und lösche diese. Am besten, Du schiebst sie erst einmal auf den Schreibtisch. Wenn Du dann das Mailprogramm startest werden die Maildaten neu eingeladen und indiziert. Wenn alles geklappt hat kannst Du die alte "Envelope Index" Datei endgültig löschen.

Viel Erfolg!
 
T

toto

Bei Problemen mit Mail hilft auch oft, die Indexdatei neu anzulegen, die schon mal korrupt werden kann.

Dazu Mail beenden. Im Ordner ~/Library/Mail liegt die Datei "Envelope Index". Diese da rausnehmen und sicherheitshalber irgendwohin sichern. Beim nächsten Start vom Mail werden die Mails neu importiert und der Index neu angelegt.

EDIT: zu langsam geschrieben. :)
 

macstephan

Mitglied
Thread Starter
Mitglied seit
24.11.2007
Beiträge
86
ich wuerde die Datei ~/Library/Preferences/com.apple.mail.plist loeschen und mir ein neues Benutzerkonto mit deinen Zugangsdaten anlegen. Und dann die Option Mailboxes Importieren aus dem Ablage Menu von mail waehlen. Dann waehlst du ~/Library/Mail/Alter_Mailaccount (die ~steht fuer dein Home Verzeichnis) von dem importiert werden soll. Wenn das zu deiner Zufriedenheit passiert ist, kannst du die mails des Alten_Mailaccount under ~/Library/Mail/Alter_Mailaccount loeschen
danke für deinen guten rat. es klappt jetzt wieder wie vorher. das wars auch schon. habe alles so gemacht, wie du es mir gesagt hast. vielen herzlichen dank dir.
 

smaui

Registriert
Mitglied seit
09.07.2008
Beiträge
1
alles nochmals trottelsicher für mich?

hallo ihr alle, also ich steh mir anscheinend selber auf der leitung...ich habe dasselbe problem wie macstephan, nur das bei mir der server "nur" gar keine mails mehr lädt. ich finde leider absolut kein "envelope index" bei mir auf der hd und auch wo ich genau das ~/Library/Preferences/com.apple.mail.plist finden soll habe ich nicht rausgefunden. eben, leitung hat einen rechten knick im moment.
mein mail ist das mac mail 1.3.11 und ich arbeite immer noch mit dem alten 10.3.9. kann mir jemand meinen knick in der leitung reparieren und eine idiotensichere anleitung geben um mein mail wieder zu normalisieren? danke vielmals!
 
Oben