"Mail" killt Umlaute und Sonderzeichen

Diskutiere das Thema "Mail" killt Umlaute und Sonderzeichen im Forum Mac OS Apps. So, jetzt habe ich "Entourage" endlich den Laufpass gegeben und arbeite mit "Mail". Seitdem ich das tue, gibt's...

Frankieboy

Mitglied
Thread Starter
Mitglied seit
15.11.2002
Beiträge
489
So, jetzt habe ich "Entourage" endlich den Laufpass gegeben und arbeite mit "Mail". Seitdem ich das tue, gibt's allerdings immer mal wieder Probleme mit der Darstellung von Umlauten und Sonderzeichen, auch mit "ß" (siehe Anlage). Das ist wie gesagt nicht immer so, aber doch recht häufig. Woran kann das liegen und wie kann ich es verhindern? Bei "Entourage" hatte ich diese Probleme nicht. Für hilfreiche Hinweise schon jetzt besten Dank.
 

Anhänge

v-netz

Mitglied
Mitglied seit
28.10.2004
Beiträge
43
Vielleicht hilft es, die Textcodierung im Menü 'E-Mail' zu ändern. Könnte sein, dass es bei bestimmten Mails Probleme gibt, wenn unter Textcodierung 'Automatisch' eingestellt ist.
 

Frankieboy

Mitglied
Thread Starter
Mitglied seit
15.11.2002
Beiträge
489
klangundklang schrieb:
hi,

das selbe problem habe ich auch. hat der tipp geholfen?

grüße
Leider nur bedingt, denn eine Umstellung von "Automatisch" auf z. B. "Westeuropäisch (Mac Mail)" bringt die Umlaute zwar wieder zum Vorschein ... aber die Umstellung kann man – soweit ich das sehe – immer nur fallweise vornehmen. Oder gibt's da eine Möglichkeit, dass als Standardeinstellung zu wählen? In den "Einstellungen" sehe ich das jedenfalls nicht. Es ist aber wohl definitiv so, dass es dieses Problem mit "Entourage" nicht gibt. Das gibt mir schon zu denken ... Jedenfalls wäre ich froh, wenn sich die Community hier nochmal ernsthaft mit diesem Thema beschäftigen würde, denn offenbar bin ich ja nicht der einzige, der sich damit herumschlägt. Schon jetzt besten Dank für jedwede Unterstützung.
 
A

abgemeldeter Benutzer

Also ich habe dieses Problem auf meinen Rechnern nicht und wüsste auch nicht, dass ich irgendetwas eingestellt habe. Und wo kann man die Textcodierung umstellen (vielleicht kann ich das dann nachvollziehen …)?
 

Frankieboy

Mitglied
Thread Starter
Mitglied seit
15.11.2002
Beiträge
489
bömpfmactobi schrieb:
Also ich habe dieses Problem auf meinen Rechnern nicht und wüsste auch nicht, dass ich irgendetwas eingestellt habe. Und wo kann man die Textcodierung umstellen (vielleicht kann ich das dann nachvollziehen …)?
Unter dem Menüpunkt "E-Mail", letzter Punkt. Es ist auch so, dass das nicht bei allen Adressaten Probleme bereitet, aber eben doch bei manchen. Und es wird noch lustiger: Denn bei manchen zeigen sich dann komische Zeichen statt der Umlaute auf dem Bildschirm, aber wenn die dann die Nachricht ausdrucken, sieht die völlig normal aus. Höchst merkwürdig, oder?
 
A

abgemeldeter Benutzer

Der steht bei mir (Panther, bin in Firma) auf "US-Standard" – gerade dann müsste das Problem ja eigentlich auftauchen? :kopfkratz:
 

paul303

Mitglied
Mitglied seit
18.05.2005
Beiträge
7
hi fheckert,
stell mal die text-codierung auf unicode (utf-8) um, dann sollte das problem verschwunden sein.

greetz
paul
 

davidoff

Mitglied
Mitglied seit
08.02.2005
Beiträge
41
Mail und die Umlaute

Hi Leute,

genau das gleiche Problem habe ich auch: DIe Umlaute sind hinüber, wenn man vor dem Abschicken nicht auf Westeuropäisch (Windows Latin 1) stellt. Leider lässt sich das nicht generell einstellen (habe auch schon länger gesucht).

Wer kennt da eine Patch oder einen anderen Trick?

Davidoff
 

Frankieboy

Mitglied
Thread Starter
Mitglied seit
15.11.2002
Beiträge
489
davidoff schrieb:
Hi Leute,

genau das gleiche Problem habe ich auch: DIe Umlaute sind hinüber, wenn man vor dem Abschicken nicht auf Westeuropäisch (Windows Latin 1) stellt. Leider lässt sich das nicht generell einstellen (habe auch schon länger gesucht).

Wer kennt da eine Patch oder einen anderen Trick?

Davidoff
Mir geht das mittlerweile dermaßen auf den Wecker ... und es ist auch einfach peinlich, wenn Mails so ankommen. Da muss doch was zu machen sein, sonst geht kein Weg (zurück) an Microsoft vorbei.
 

der Michl

Mitglied
Mitglied seit
05.08.2005
Beiträge
12
Nur eine Idee: passiert das vielleicht, wenn Ihr Antworten/Reply To macht?

Es gibt in den Einstellungen unter Verfassen eine Checkbox mit "Das selbe Format verwenden wie in der Original-E-Mail". Zunächst denkt man hier nur an reiner Text vs. formatierter Text - aber vielleicht nimmt er ja auch die Kodierung der Original-E-Mail?
 

Frankieboy

Mitglied
Thread Starter
Mitglied seit
15.11.2002
Beiträge
489
der Michl schrieb:
Nur eine Idee: passiert das vielleicht, wenn Ihr Antworten/Reply To macht?

Es gibt in den Einstellungen unter Verfassen eine Checkbox mit "Das selbe Format verwenden wie in der Original-E-Mail". Zunächst denkt man hier nur an reiner Text vs. formatierter Text - aber vielleicht nimmt er ja auch die Kodierung der Original-E-Mail?
Ja, das ist ein guter Gedanke. Leider aber ist das auch so, wenn man eine neue Mail schreibt. Das Bescheuerte ist, dass es sogar bei ein und demselben Adressaten so ist, dass es manchmal klappt und manchmal nicht. Und noch verrückter: Wenn man den zitierten Text anschaut, dann kann es nach mehrfachem Hin- und Hersenden von Nachrichten sein, dass plötzlich auch der Text, den man ursprünglich mal von jemand anderem erhalten hat, mit seltsamen Zeichen versehen ist. Das nervt extrem (siehe Anlage), weil man ja dann irgendwann für einen Analphabeten gehalten wird!
 

Anhänge

K

Knoppaz

Das klingt so, als ob der Mailpartner ein Mailprogramm benutzt, dass nicht mit allen Textcodierungen klar kommt. Mail benutzt automatisch die Textkodierung, die zum Anzeigen des Textes nötig ist, was auch erklärt, warum es manchaml funktioniert und manchmal nicht.
 
Zuletzt bearbeitet von einem Moderator:

Frankieboy

Mitglied
Thread Starter
Mitglied seit
15.11.2002
Beiträge
489
Knoppaz schrieb:
Das klingt so, als ob der Mailpartner ein Mailprogramm benutzt, dass nicht mit allen Textcodierungen klar kommt. Mail benutzt automatisch die Textkodierung, die zum Anzeigen des Textes nötig ist, was auch erklärt, warum es manchaml funktioniert und manchmal nicht.
Leider ist auch das keine zutreffende Erklärung, denn auch neue Mails kommen oft bei Adressaten mit seltsamen Sonderzeichen (statt der Umlaute) an. Und mit "Entourage" gab es nie Probleme dieser Art. Außerdem: Outlook als Mailprogramm des Mailpartners müsste eigentlich mit allem zurechtkommen. Ich will nicht missverstanden werden: "Mail" ist klasse, aber für dieses Problem muss es eine Lösung geben, sonst kann man damit nicht professionell arbeiten.
 

davidoff

Mitglied
Mitglied seit
08.02.2005
Beiträge
41
Test mit OS X 10.4.3

Hi Leute,

habt Ihr schon mal auf die neuste Version geupdated? Habe ich gerade
gemacht und mir selbst an Web.de eine Nachricht mit reichlich Umlauten
geschickt. Sieht völlig ok aus.

An Mail hat Apple offensichtlich gearbeitet, denn ein alter 10.4.-Bug ist auch raus: Ich konnte bis vor kurzem nach Klick auf "Diashow" immer nur Pixelmüll sehen (nur bei einer Auflösung von 1600x1200). Das ist behoben.

Macht mal ein Update und schreibt ein paar Testmails. Vielleicht hat sich das Problem von allein gelöst ...

Davidoff
 

Frankieboy

Mitglied
Thread Starter
Mitglied seit
15.11.2002
Beiträge
489
davidoff schrieb:
Hi Leute,

habt Ihr schon mal auf die neuste Version geupdated? Habe ich gerade
gemacht und mir selbst an Web.de eine Nachricht mit reichlich Umlauten
geschickt. Sieht völlig ok aus.

An Mail hat Apple offensichtlich gearbeitet, denn ein alter 10.4.-Bug ist auch raus: Ich konnte bis vor kurzem nach Klick auf "Diashow" immer nur Pixelmüll sehen (nur bei einer Auflösung von 1600x1200). Das ist behoben.

Macht mal ein Update und schreibt ein paar Testmails. Vielleicht hat sich das Problem von allein gelöst ...

Davidoff
Auch ich habe heute morgen gleich das Update gefahren ... und heute nachmittag wieder Sonderzeichen zum Dessert bekommen. Die Hoffnung stirbt zuletzt. Vielleicht liegst ja auch am Server meines Providers Arcor, aber bei denen klappt eigentlich alles ganz gut ...
 

davidoff

Mitglied
Mitglied seit
08.02.2005
Beiträge
41
Versuchen wir den Fehler einzugrenzen

Hi,

wenn der Fehler noch da ist, versuchen wir ihn doch mal einzugrenzen. Was hast Du genau gemacht: An wen geschickt, über welchen Provider, welche E-Mail-Adresse, welche Einstellungen bei Mail und wie die Mail gelesen.

Bei meiner Probemail habe ich die Mail mit dem Mac abgeschickt, Textformatierung "Automatisch" an meinen Account bei Web.de. Über das Webinterface bei Web.de gelesen. Damit gab es keine Probleme.

Wie löuft das bei Dir?

Davidoff
 
K

Knoppaz

fheckert schrieb:
Leider ist auch das keine zutreffende Erklärung, denn auch neue Mails kommen oft bei Adressaten mit seltsamen Sonderzeichen (statt der Umlaute) an. Und mit "Entourage" gab es nie Probleme dieser Art. Außerdem: Outlook als Mailprogramm des Mailpartners müsste eigentlich mit allem zurechtkommen. Ich will nicht missverstanden werden: "Mail" ist klasse, aber für dieses Problem muss es eine Lösung geben, sonst kann man damit nicht professionell arbeiten.
Vielleicht kann die Outlook Version nicht mit Unicode umgehen, ist es eine aktuelle Version?

Klick doch mal in deinem Gesendet Ordner eine der Mails an und gib den befehl "wahltaste + apfel+ u" ein und guck, was da bei "charset" in der reinen maildatei steht. Guck mal ob es da einen zusammenhang gibt.
 

Frankieboy

Mitglied
Thread Starter
Mitglied seit
15.11.2002
Beiträge
489
Knoppaz schrieb:
Vielleicht kann die Outlook Version nicht mit Unicode umgehen, ist es eine aktuelle Version?

Klick doch mal in deinem Gesendet Ordner eine der Mails an und gib den befehl "wahltaste + apfel+ u" ein und guck, was da bei "charset" in der reinen maildatei steht. Guck mal ob es da einen zusammenhang gibt.
Danke für diesen Hinweis, der mich auf eine neue Spur bringt. Es ist tatsächlich so, dass es unterschiedliche Angaben bei "charset" gibt. Und es scheint so, dass alle Mails, die Probleme mit den Umlauten machen, auf charset=UTF-8 stehen, während andere auf charset=ISO-8859-1 gestellt sind (eine Einstellung, die sich freilich in der Mail-Auswahl unter "Textcodierung" gar nicht findet). Es ist für mich freilich kein Zusammenhang erkennbar, welches charset "Mail" automatisch wählt und warum. Und außerdem ist ja außer "Automatisch" wohl keine feste Voreinstellung machbar.

Trotzdem: Bei mir wächst die Hoffnung, dass es vielleicht doch eine Lösung für dieses Problem gibt.
 
Oben