MacPro 3.1 GTX680 wenig GPU-Leistung?

fams

Neues Mitglied
Thread Starter
Mitglied seit
23.01.2005
Beiträge
32
Hallo,
ich habe einen MacPro 3.1 (2xQuadcore) mit einer EVGA GTX680 (in Slot1, PCIe 2.0 16x) und einen PC mit einem Gigabyte Z77-Board (PCIe 3.0) und einer Radeon RX460 (i5-3570k).
Überraschenderweise ist die GPU-Leistung des PCs nach Geekbench Compute ca. 3x so hoch.
Nach den Benchmarks im Netz sollte die GTX680 aber die schnellere Karte (ca. 30-70%) sein.
Gut, der Mac hat nur PCI 2.0, der PC PCI 3.0, aber dass sollte doch höchstens Faktor 2 ausmachen.
Von der CPU-Leistung ist der Mac auf allen 8 Kernen etwa so schnell wie der PC mit 4 Kernen (Singlecore entsprechend halb so schnell).
Geht im Mac wirklich so viel Grafikleistung flöten, oder habe ich da einen Denk- oder Konfigurationsfehler?
Grüße
 

Anhänge

Udo Martens

Mitglied
Mitglied seit
14.02.2015
Beiträge
780
Wundert mich nicht: Die RX460 ist einige Jahre jünger als die nVidia, und bei OpenCL ist AMD stärker (dafür können sie die proprietäre CUDA-API natürlich nicht verwenden).
Du kannst die AMD aber in den Mac stecken und testen, die müsste dort problemlos nutzbar sein.

Den CPU-Takt und Kernanzahl kannst Du nicht so einfach gegenrechnen. Die meisten Anwendungen sind noch immer massiv auf Singlecore-Leistung angewiesen und profitieren teilweise NULL von mehr Kernen (die dann nur vor sich hin idlen), neuere CPUs bringen außerdem neue Instruktionen mit, die manche Prozesse ganz erheblich beschleunigen können.
Denk' nur an Videocodecs, die direkt und ohne Umwege auf der GPU abgespult werden können statt umständlich in Software auf der CPU zu encodieren; so kann z.B. ein moderner Laptop manches viel schneller und effizienter abarbeiten, als eine alte Workstation, die beim Blick auf die üblichen Spezifikationen eigentlich viel leistungsstärker sein müsste.
 

Macschrauber

Aktives Mitglied
Mitglied seit
08.02.2014
Beiträge
7.097
Wobei es für die Rx4 erst ab High Sierra Treiber gibt, die zum Teil auch SSE4.1 Befehle verwenden.

Wird also nix ohne Patches und SSE Emulator auf dem 3.1

Machbar, aber Aufwändig für so mal Eben.
 

Roman78

Aktives Mitglied
Mitglied seit
02.10.2006
Beiträge
4.470
Das ist mir auch aufgefallen. Ich hatte auch die GTX680 drin, aber auch mit der 660 getestet. Beide sind im 3.1 fast gleich schnell. Erst als ich die GTX680 in einem 4.1 eingebaut habe, wurde die deutlich schneller. Ich tippe da auf den PCIe 2.0 Bus.

Sowas hatte ich aber auch mit meinem GamePC von damals. Ein Core2Quad, was ja die gleiche CPU-Generation ist wie der XEON in 3.1. Dort hatte ich meine HD4790 durch eine R9 270x ersetz und mit Schrecken gemerkt, dass die Karte nicht schneller ist, obwohl die R9 doppelt so schnell sein sollte. Erst als ich das Mainboard ersetzt hatte mit einer neueren Generation PCIe Standard, lieft die Karte deutlich schneller.
 
  • Gefällt mir
Reaktionen: dg2rbf
Oben