macOS öffnet Programme nach Neustart erneut, obwohl Option deaktiviert ist

Diskutiere das Thema macOS öffnet Programme nach Neustart erneut, obwohl Option deaktiviert ist im Forum Mac OS X & macOS.

  1. Brokoli1

    Brokoli1 Thread Starter Mitglied

    Beiträge:
    129
    Zustimmungen:
    8
    Mitglied seit:
    25.12.2015
    Hallo zusammen,

    ich habe beobachtet, dass mein Mac mini 2018 mit Catalina 10.15.3 oftmals alle Programme wieder öffnet, die ich vorher auf hatte. Allerdings habe ich in dem "Ausschalten"-Dialog nicht "Beim nächsten Anmelden alle Fenster wieder öffnen" aktiviert. Hat jemand ähnliches erlebt oder gar eine Lösung?

    Danke im Voraus und bleibt gesund!
     
  2. klickman

    klickman Mitglied

    Beiträge:
    1.104
    Zustimmungen:
    178
    Mitglied seit:
    31.05.2010
    Warte vor dem Neustart mal 5 Sekunden, nachdem du das letzte Programm geschlossen hast.
     
  3. icritter

    icritter Mitglied

    Beiträge:
    206
    Zustimmungen:
    47
    Mitglied seit:
    29.11.2019
    Wird der mac auch komplett heruntergefahren und ausgeschalten? Sieht für mich so aus, als ob er nicht ordnungsgemäß heruntergefahren ist und dann öffnet er die Apps wieder
     
  4. Brokoli1

    Brokoli1 Thread Starter Mitglied

    Beiträge:
    129
    Zustimmungen:
    8
    Mitglied seit:
    25.12.2015
    Ich glaube, dass war das Problem. Ich habe nicht lange genug gewartet bis die Programme beendet worden sind. Danke!
     
  5. Schiffversenker

    Schiffversenker Mitglied

    Beiträge:
    10.260
    Zustimmungen:
    3.276
    Mitglied seit:
    25.06.2012
    Wie meinst du das mit dem Warten?
    Wenn du auf Ausschalten klickst, kommt doch die Frage, ob du das wirklich willst, da klickst du auf JA und dann macht der Mac alles weitere von selbst.
     
  6. klickman

    klickman Mitglied

    Beiträge:
    1.104
    Zustimmungen:
    178
    Mitglied seit:
    31.05.2010
     
  7. klickman

    klickman Mitglied

    Beiträge:
    1.104
    Zustimmungen:
    178
    Mitglied seit:
    31.05.2010
    Erfreulicherweise habe ich das Problem unter Catalina nicht mehr. Vielleicht weil ich es neu installiert hatte. Wenn du über Mojave drüberinstalliert hast, könnte es gut sein, dass du das mitgeschleppt hast.

    Damit ich nicht immer 5 Sekunden warten muss, habe ich mir unter Mojave damit beholfen, dass ich die Datei com.apple.loginwindow.XXXXXX.plist ("XXXXXX" steht für eine Reihe von Zeichen) im Pfad ~/Library/Preferences/ByHost auf schreibgeschützt gesetzt habe (Datei markieren, Rechtsklick -> Informationen und das Kästchen Gesperrt aktivieren). Wenn du das testen möchtest, dann alle Programme schließen, den Rechner neu starten und sofort durchführen (ohne irgendein Programm vorher zu starten).
    Das hat natürlich den Nachteil, dass nie wieder Programme nach einem Neustart automatisch gestartet werden. Ich persönlich mag das aber ohnehin nicht.
    Hintergrund: Wenn du dir die nicht schreibgeschützte Datei (com.apple.loginwindow.XXXXXX.plist) während des ganz normalen Arbeitens mittels Quicklook ansiehst (im Finder markieren und Leertaste drücken), siehst du, dass da sämtliche geöffneten Programme eingetragen sind. Wenn du die Apps schließt, verschwinden sie wieder aus dieser Datei. Offensichtlich schafft das das Betriebssystem nicht schnell genug, wenn du nach Beenden eines Programms zu flott ausschaltest und nicht die erwähnten 4, 5 oder 6 Sekunden wartest.

    Alles aber ohne Gewähr. ;)
     
  8. HäckMäc_2

    HäckMäc_2 Mitglied

    Beiträge:
    4.352
    Zustimmungen:
    321
    Mitglied seit:
    26.04.2005
    Ich habe das selbe Problem.
    Der Haken ist bei "Beim nächsten Anmelden alle Fenster wieder öffnen" nicht gesetzt und der iMac (27" Ende 2015 mit 10.15.3) startet beim nächsten Einschalten fröhlich mit allen Programmen, die zum Zeitpunkt des Herunterfahrens noch geöffnet waren.
    Programme beenden und warten ist für mich keine Lösung, denn es ändert ja nichts an der Fehlfunktion.
     
  9. klickman

    klickman Mitglied

    Beiträge:
    1.104
    Zustimmungen:
    178
    Mitglied seit:
    31.05.2010
    Das ist ein Bug, der Apple offensichtlich kalt lässt. Wenn dir die Pause mit 5 Sekunden lästig ist, dann versuche es doch mit dem Schreibschutz, wie ich oben erwähnt habe.
     
  10. Schiffversenker

    Schiffversenker Mitglied

    Beiträge:
    10.260
    Zustimmungen:
    3.276
    Mitglied seit:
    25.06.2012
    Warum soll ich Programme manuell schließen, wenn ich den Rechner abschalten will?
    Oder ist das bei Catalina jetzt notwendig?
     
Die Seite wird geladen...
  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite weitersurfst, akzeptierst du unseren Einsatz von Cookies. Akzeptieren Weitere Informationen...