MacOS 11 Firefox

Coffins

Mitglied
Thread Starter
Registriert
02.06.2010
Beiträge
114
Hallo
Wenn ich in einer App (in meinem Fall KeepassXC) eine URL als zu öffnen anwähle, dann öffnet Firefox immer zwei Browserfenster.
Zuerst eine leere Seite (so, wie es in Firefox als Startoption eingetragen ist) und darüber als zweites Fenster dasjenige der gewählten URL.
Bug oder Einstellungsfrage
Ciao
 

fa66

Aktives Mitglied
Registriert
16.04.2009
Beiträge
14.531
Ob’s ein Bug ist, darüber scheinen die Strategen zu streiten.
Dass FF sich so beim Programmstart aus einer anderen Anwendung heraus so verhält, ist bereits seit einigen FF-Versionen so.
(Ist FF hingegen bereits gestartet, öffnen keine zwei Fenster. Soll etwas mit dem API unter macOS zu tun haben – aber bewerten kann ich das nicht.)

PS: Das Verhalten hat – deinem Theadtitel zuwider – nichts per se mit macOS 11 zu tun, in 10.14 ist’s auch so.
 

oneOeight

Aktives Mitglied
Registriert
23.11.2004
Beiträge
57.643
Da müsstest du wahrscheinlich ausstellen, dass der beim Start automatisch ein neues Fenster öffnet.
Der startet halt, öffnet das übliche Start Fenster und erst danach das Fenster für den Link.
 

Coffins

Mitglied
Thread Starter
Registriert
02.06.2010
Beiträge
114
Wo stellt man denn das ein?
Unter "Allgemein -> Start" kann ich nur einstellen, ob die vorherige Sitzung wiederhergestellt werden soll, ob er der Standardbrowser ist, diverses zu Tabs.
Unter "Startseite -> Startseite & neue Fenster sowie Neue Tabs" steht alles auf "leere Seite".
Das Problem tritt auf einem MacMini (Ende2014) unter MacOS 11.2.3 mit Firefox 87.0 auf.
Auf einem iMac (Mitte 2010) unter MacOS 10.13.6 mit Firefox 87.0 hingegen nicht.
 

fa66

Aktives Mitglied
Registriert
16.04.2009
Beiträge
14.531
Auf einem iMac (Mitte 2010) unter MacOS 10.13.6 mit Firefox 87.0 hingegen nicht.
Mit macOS-10.14 hingegen schon. Was bei gleicher FF-Version auf einen Konflikt oder eine Änderung in der Kommunikation zwischen FF und macOS (etwa wegen geänderter Bedingungen unter macOS) hindeutet.

Unter "Allgemein -> Start" kann ich nur einstellen, ob…
Spekulativ: Vielleicht findet sich in FF anstelle unter about:preferences noch etwas unter about:config. Hatte aber keine Muße das durchzugehen – schon weil ich als Nichtentwickler nicht weiß, wonach ich suchen sollte.
 

Coffins

Mitglied
Thread Starter
Registriert
02.06.2010
Beiträge
114
....ahhh, ja, da wüsste ich auch nicht, wo nach zu suchen wäre....
 

Coffins

Mitglied
Thread Starter
Registriert
02.06.2010
Beiträge
114
Hallo
Danke für den Hinweis unter about:config.
Aber er funktioniert nicht mehr.
Jedenfalls nicht unter meiner macOS & Firefox-Konfiguration.
Ich arbeite ja gegenwärtig mit einem MacMini unter macOS 11.2.3 und einem iMac unter macOS 10.13.6 als Monitor
Die Firefoxeinstellungen (beide mit FF 87.0) unter dem gen Pkt. sind auf beiden Systemen gleich - das geschilderte Problem tritt aber nur unter macOS 11.2.3 auf.
 
Zuletzt bearbeitet:
Oben