MacFUSE: FUSE-Portierung für MacOSX. NTFS schreiben.

s_herzog

Mitglied
Thread Starter
Mitglied seit
11.04.2006
Beiträge
3.339

Darii

Mitglied
Mitglied seit
24.02.2004
Beiträge
2.085
Wunderbar, dann muss ich nicht mehr FAT32 benutzen. :)
 

s_herzog

Mitglied
Thread Starter
Mitglied seit
11.04.2006
Beiträge
3.339
Also für kritische Daten würd ichs aber noch nicht verwenden ;)
 

MilchKaffee

Mitglied
Mitglied seit
19.01.2006
Beiträge
798
s_herzog schrieb:
Laut heise

http://www.heise.de/newsticker/meldung/83639

existiert nun eine Portierung von FUSE auf MacOSX. Damit lassen sich Filesystemtreiber durch Userspace-Programme implementieren.

Beispielsweise existieren Treiber für SSH, FTP, EXT3 und mit NTFS-3G auch ein recht guter NTFS-Treiber mit Schreibunterstützung.

NTFS-3G-Anleitung hab ich mal aus dem heise-Forum ausgebuddelt:

http://forums.applenova.com/showpost.php?p=432791&postcount=11

Die Anleitung funktioniert so nicht ..

Folgende Fehlermeldung beim Kompilieren von NTFS-3G:

configure: error: ntfs-3g requires FUSE >= 2.6.0. Please see http://fuse.sf.net/ or install __all__ FUSE packages (e.g. fuse, fuse-utils, libfuse, libfuse2, libfuse-dev) or remove already installed __older__ FUSE.
 

maceis

Mitglied
Mitglied seit
24.09.2003
Beiträge
16.858
MilchKaffee schrieb:
Stimmt, Du hast recht. Ich hatte an zwei Stellen etwas dazu geschrieben und etwas durcheinandergebracht. Sorry.
Kein Problem.
Ich schlage vor, diesen Teil der Diskussion blende ich aus, damit das Topic klarer rauskommt ;).
 

farukp

Mitglied
Mitglied seit
05.12.2006
Beiträge
171
Ich kann nicht mal die ntfs3g treiber installieren. Der sagt: mac_fuse nicht installiert auf der platte die ich hab. Obwohl ich es zuvor installiert habe.
 

winkelmr

Mitglied
Mitglied seit
08.02.2007
Beiträge
65
Macfuse bzw. ntfs-3g ist für mich schlicht unbrauchbar, da selbst mit dem Befehl
Code:
sudo ntfs-3g /dev/diskxxx /mnt/extern -o locale=de_DE.UTF-8
Dateien mit Umlauten im Namen zwar angezeigt, aber weder
a.) geöffnet werden können noch
b.) im Finder kopiert werden können.
Seltsamerweise werden auch in den Ordnern auf einmal komische Geisterdateien (für die Dateien mit Umlauten) mit .irgendwas im Dateinamen angezeigt.
Nur mucommander schafft es, wenigstens die Dateien zu kopieren, allerdings schnarchlangsam.

Schade, OSX - hoffentlich wird das schnell was werden.
 

AssetBurned

Mitglied
Mitglied seit
25.10.2005
Beiträge
2.183
wenn du nur daten von der platte kopieren willst brauchst du fuse nicht.
 

winkelmr

Mitglied
Mitglied seit
08.02.2007
Beiträge
65
AssetBurned schrieb:
wenn du nur daten von der platte kopieren willst brauchst du fuse nicht.
Argh. Ja, das weiß ich doch - ich möchte eben auch mal Dateien auf die Platte kopieren können. :O
 

flapappi

Mitglied
Mitglied seit
03.02.2007
Beiträge
619
Ich bleibe schon direkt bei der Eingabe des Passwortes am Anfang hängen, wenn es ums Entpacken geht. Ich kann einfach keine Zeichen eingeben, sobald nach dem Passwort gefragt wird. Ziemlich blöde Sache. Kann mir jemand sagen, woran das liegt?
 

AssetBurned

Mitglied
Mitglied seit
25.10.2005
Beiträge
2.183
@winkelmr
Ah nun verstehe ich was du meinst. hab mal ne platte mit NTFS formatiert.
wenn ich was mit umlauten auf die platte schiebe kann ich es unter dem entsprechenden system sauber lesen aber sobald das jeweils andere system genutzt wird kommen komische zeichen.

MacFuse benutze ich ja eigentlich für SSHFS.
allerdings habe ich dort das problem mit den umlauten nicht. ich vermute mal das es eher am NTFS-G3 paket liegt. sprich die progger dafür verantwortlich wären.

abgesehen davon läuft das aber recht rund hab ich das gefühl.

@flapappi
was den für nen passwort?!
 

flapappi

Mitglied
Mitglied seit
03.02.2007
Beiträge
619
Na in der Anleitung steht doch:
Code:
3) Extract the tarball onto your system, effectively installing it:
Code:

[CODE]sudo tar -C / -jxvpf fuse-binaries-0.1.0b006.tar.bz2
This will prompt for your password. Enter it, then wait as things get extracted and copied.[/CODE]

Zudem:

Code:
Second, you need NTFS-3G.

1) Download the current tarball from here. Unlike the above, this one's a source tarball: we need to compile it. Again, you need to have Xcode Tools installed!
Geht auch nicht, weil ich den NTFS-3G nicht downloaden kann!
 

Conroe

Mitglied
Mitglied seit
29.08.2006
Beiträge
781
Ich habe es damals geschafft MacFuse und NTFS3G runterzuladen und zu installieren. Hatte jedoch nur Probleme damit. Dateien verschieben ging nicht immer, geschweigeden umbennen, kopieren und löschen. Jedesmal kam eine Fehlermeldung. Komischerweise wurde mir die Partition auch noch als Externe Festplatte angezeigt und ich konnte sie somit auswerfen?!
Ich würde es lassen zumindest mit NTFS3G. Ist aus meiner Sicht noch nicht stabil.
 

AssetBurned

Mitglied
Mitglied seit
25.10.2005
Beiträge
2.183
äh mal so zur info ob wir alle die gleichen vorraussetzungen haben, danach scheint es nämlich nicht auszusehen:

ich hab die MacFUSE-Core-0.2.1.dmg (supper seit ner halbenstunde ist MacFUSE-Core-0.2.2.dmg draußen). zufinden ist MacFUSE unter http://code.google.com/p/macfuse/

in den paket ist auch SSHFS drinne

und ich nutze NTFS-3G 20070207.dmg aus dem AppleNova forum.
dazu benötigt man allerdings noch die MacFUSE Tools 0.1.7.dmg auch aus dem AppleNova forum.

alles hat kein passwort und benötigt kein kompilieren oder sonst welchen humbug, es sind normale installer, teilweise aber laut berichten auch wohl nur für intel. die NTFS-G3 geschichte bindet sich sogar soweit ein das es automatisch die platten mountet statt dem apple treiber. das kann aber abgestellt werden.
 
Zuletzt bearbeitet von einem Moderator:

winkelmr

Mitglied
Mitglied seit
08.02.2007
Beiträge
65
@winkelmr
Ah nun verstehe ich was du meinst. hab mal ne platte mit NTFS formatiert.
wenn ich was mit umlauten auf die platte schiebe kann ich es unter dem entsprechenden system sauber lesen aber sobald das jeweils andere system genutzt wird kommen komische zeichen.

MacFuse benutze ich ja eigentlich für SSHFS.
allerdings habe ich dort das problem mit den umlauten nicht. ich vermute mal das es eher am NTFS-G3 paket liegt. sprich die progger dafür verantwortlich wären.

abgesehen davon läuft das aber recht rund hab ich das gefühl.
Nun ja, versuch doch bitte mal ein paar (leere, ist egal) Textdateien oder sowas unter Windows zu erstellen, wo zum Beispiel Umlaute im Dateinamen vorkommen. Gut, binde ich die Partition dann mittels ntfs-3g unter Ubuntu-Linux ein (natürlich mit dem Parameter -o locale="de_DE.UTF8") werden die Dateien sauber erkannt, und man kann sie problemlos lesen (so lange es keine leeren Textdateien sind, eh klar *gg*).

ntfs-3g auf dem Mac scheint sich nicht mit UTF8 zu vertragen, derzeit. Selbst die aktuellste CVS-Version zum selber kompilieren will bei mir einfach nicht mit Umlauten. Wenn du das hinbekommst, bzw. mir sagen kannst warums bei mir nicht klappen will, bist du eindeutig mein Held! *gg*
Und ja, ich habe die UTF8-Unterstützung für OSX (im Terminal) nachgerüstet, mir eine neue bash kompiliert, die mit UTF8 umgehen kann. Daran wirds also wohl nicht liegen.

Der OSX beiliegende NTFS(nur lesen)-Treiber arbeitet jedenfalls bei meinen Experimenten problemlos mit Sonderzeichen in Dateinamen.
 

AssetBurned

Mitglied
Mitglied seit
25.10.2005
Beiträge
2.183
hm eventuell solltest du mal bei applenova vorbei schauen.

edit:
das ist la lustig.... ich hab gerade mal die platte mit deinem befehlt gemountet und wenn ich mich im terminal in das mount verzeichniss hangel passiert was komisches.
beim auflisten des inhaltes mit "ls" bekomme ich "?????" angezeigt für den ordner den ich under XP mit "äöü" benannt habe.
wenn ich aber "cd" gefolgt von mehrfachen tab drücken eingebe bekomm ich den richtig angezeigt.

im finder verschwindet das verzeichniss schlicht in das ich die platte gemountet habe, beim draufklicken auf den mount point.

edit2:
ah bei AppleNova im Forum hat noch nen anderer lokalisierung probleme allerdings mit russisch.

edit3:
*grummel* es steht sogar in der readme aus dem aktuellen ntfs-g3 disk image. angepasst heißt es:
platte ohne lokalisierungsparameter mounten und dann folgendes in nem terminal eingeben.
echo 'de_DE' > /Volumes/MyNTFSDrive/.ntfs-locale
Platte unmounten und nochmal neu anschließen.
und nun lüppts!
danke nochmal auf diesen wege an "ShadowOfGed" aus dem AppleNova forum :)

edit4:
korrektur.... wenn du nen verzeichniss hast namens "äöü" kannst du die dateien dadrinne zwar nutzen aber weder das verzeichniss noch die dateien kopieren.
 
Zuletzt bearbeitet: