MacBookPro 2012 15 " || Bildschirm geht, dann wieder nicht

Diogen

Neues Mitglied
Thread Starter
Mitglied seit
18.02.2021
Beiträge
10
Guten Tag,

ich bin neu hier im Forum und hoffe hier Hilfe finden zu können. Habe nun einige Seiten durch, um einen ähnlichen Fall zu finde, jedoch konnte ich noch nichts finden.

Folgende Problematik:

Wenn ich mein MacBook starte, dann ist es wie eine Art Lotterie, ob sich der Bildschirm einschaltet oder nicht.

Im Fehlerfall, bleibt es einfach komplett schwarz, also auch ohne Hintergrundbeleuchtung.
Der Start-Sound kommt und der Mac fährt hoch (denke ich zumindest). Tastatur leuchtet kurze Zeit später und ich kann sie auch in der Helligkeit regeln.

Mit Glück startet die Maschine auch ganz normal. Ich kann eine Stunde daran arbeiten und nichts passiert. Wenn ich das Gerät dann jedoch neu starte, dann ist die Wahrscheinlichkeit extrem hoch, dass der Schirm wieder komplett aus bleibt. Keine Beleuchtung....

Einmal ist mir das sogar passiert während ich am Arbeiten im war.

In das Reset Menü zu kommen um das OS zurückzusetzen ist ebenfalls fast unmöglich. Dann schaltet sich der Schirm in 99% der Zeit ab. Es ist wahrscheinlicher, dass der Schirm an bleibt wenn ich den Mac normal hochfahren lasse.
Ich konnte bisher leider kein Muster erkennen. Die üblichen NVRAM-Resets etc. habe ich bereits ohne Erfolg ausgeführt.
Es ist auch kein Unterschied zu erkennen, wenn das Gerät an der Steckdose ist oder auf Akkubetrieb läuft.

Jedes mal wenn der Bildschirm aus geht, dann schaltet sich auch das Apple-Logo auf der Rückseite aus und leuchtet nicht mehr, falls diese Info relevant ist.
Die Steckverbindungen auf dem Logicboard habe ich bereits überprüft und alle neu gesteckt. Jedoch ohne Verbesserung.

Ohje, das liest sich alles sehr verwirrend, aber genau so empfinde ich es auch.

Vielleicht hat jemand eine passende Idee oder eben eine Hiobsbotschaft für mich. Ich bin über jede Hilfe glücklich und bedanke mich bereits Vorab für eure Hilfe.
 

walfreiheit

Aktives Mitglied
Mitglied seit
06.06.2004
Beiträge
30.680
Es wird ein Hardwareproblem sein. Wenn es passiert, leuchte mal mit einer Taschenlampe auf den Bildschirm bzw. von hinten durch den Apfel, und schau ob nur die Beleuchtung ausgefallen ist.
 

Diogen

Neues Mitglied
Thread Starter
Mitglied seit
18.02.2021
Beiträge
10
Hallo walfreiheit. Danke für deine Antwort.
Den Taschenlampentrick habe ich bereits von vorne ausprobiert, nur nicht von hinten durch den Apfel.

Da war nichts zu sehen leider.
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
56.501
Flachbandkabel zum Display?
Kannst einen externen Monitor anschließen?
 

Diogen

Neues Mitglied
Thread Starter
Mitglied seit
18.02.2021
Beiträge
10
Ja kann ich. Der das lief eben auch stabil. Aber nach dem nächsten Neustart ( der funktioniert auch nicht richtig sondern bleibt hängen) war bei beiden wieder alles schwarz.

kann da was repariert werden, es Anschreiben dort überhaupt die Probleme ?
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
56.501
Dann hast du die Firmware Updates von Mojave, wo Apple den Hardware Test kaputt gemacht hat.
Leider kann man den dann auch nicht mehr lokal starten.
 

Diogen

Neues Mitglied
Thread Starter
Mitglied seit
18.02.2021
Beiträge
10
Kann jemand eingrenzen was es sein könnte? Im Festplattentool sagt er mir man müssen die mal demnächst tauschen weil die Kapazität nicht mehr so dolle ist.
Ein Hitzeproblem dürfte es nicht sein, denke ich.
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
56.501
Naja, schwierig.
Kommt denn der Gong wenn die Bildschirme schwarz bleiben?
Wenn die Platte hin ist, sollte ja zumindest der Bildschirm weiß werden.
 

Diogen

Neues Mitglied
Thread Starter
Mitglied seit
18.02.2021
Beiträge
10
Der Gong kommt. Die Tatsatur fängt auch immer an zu leuchten. Ich gehe also stark davon aus, dass der Mac immer hoch fährt.
Danke für deine Hilfe jedenfalls :).
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
56.501
Dann könnte die HDD so hin sein, dass die den ganzen Boot aufhält.
Hast bestimmt keine Andere zur Hand.
Die 2012 sind ja meist nur wegen des SATA Kabel auffällig.
 

Diogen

Neues Mitglied
Thread Starter
Mitglied seit
18.02.2021
Beiträge
10
Ich habe die MacOS Installation auf einer externe Platte angestoßen. Der Rechner startet neu und fängt mit der Installation auf der externen an. Apfellogo wird angezeigt und der Balken bewegt sich.
Und dann plötzlich schwarzes Bild ( Display aus). Die Festplatte scheint weiterzuarbeiten und blinkt.
 

oneOeight

Aktives Mitglied
Mitglied seit
23.11.2004
Beiträge
56.501
Standby des Displays?
Hast mal Leertaste probiert oder ctrl, ob es wieder angeht?
 

Diogen

Neues Mitglied
Thread Starter
Mitglied seit
18.02.2021
Beiträge
10
Soooo...kleines Update meinerseits.

Es wird wohl die dedizierte NVIDIA GPU sein die die Probleme macht. Sie funktioniert zwar, aber sobald das MBP warm wird steigt sie aus.
Das Schwarze Bild kommt wohl immer dann zustanden, sobald das MBP versucht auf die NVIDIA GPU umzuschalten.

Ich habe diese nun mit folgendem Befehl "deaktiviert":

sudo nvram 4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00

Dazu noch den verbose Mode aktiviert. Ich glaube aber dieser hat keinen weiteren Einfluss auf die NVRAM Einstellungen, sondern ist nur zur Protokollierung gut.

Nun läuft das MBP problemlos seit Stunden.

Konnte das Problem sogar nachstellen mit einem NVRAM-Reset und erneutem Abschießen des o.g. Befehls.

Ich teste es noch ein paar Tage weiter, jedoch hält es jetzt schon viel länger durch als sonst.

Nun habe ich jedoch das Problem, dass die Helligkeit nicht mehr über die Funktionstasten regelbar ist. :/
 
Oben