Macbook Pro: Übertragung auf externe HDDs (USB-C) nur auf USB 2.0-Niveau

klausiB

Neues Mitglied
Thread Starter
Dabei seit
02.07.2008
Beiträge
45
Punkte Reaktionen
0
Liebe Leute,

folgendes Problem:

Ich kopiere gerade 600 GB von einer externen HDD auf die andere. Beide sind laut Spezifikation mit USB 3.0 ausgestattet (eine Seagate Expansion 4 TB und eine WD Elements 4 TB) und hängen mit USB 3.1-auf-USB-C-Adaptern von AmazonBasics an meinem Macbook Pro (15-inch 2017). Beide Festplatten sind APFS (verschlüsselt).

Nun dauert das ganze gut 5 Stunden, was ja einer USB 2.0-übertragung entspricht. USB 3 dürfte maximal 40 Minuten dauern.

Woran kann das liegen? Verschlüsselung? Adapter? Weiß gar nicht, wo ich mit der Fehlersuche anfangen soll.

Danke für sachdienliche Hinweise!

Klaus
 

oneOeight

Aktives Mitglied
Dabei seit
23.11.2004
Beiträge
63.936
Punkte Reaktionen
13.086
viele kleine dateien?

guck mal in der systeminformation an welchem USB bus die hängen.
falls die am gleichen hängen, nimm mal für beide einen anderen.
 

sailingHobbit

Aktives Mitglied
Dabei seit
18.03.2006
Beiträge
6.404
Punkte Reaktionen
1.600
Die theoretisch maximal mögliche Transferrate des Ports ist hier ja nur ein kleiner Aspekt des Gesamten.
Folgende Sachen muss man ebenfalls beachten:
- Lese- und vor allem Schreibgeschwindigkeit der mechanischen HDDs. Hier würde ich bei der Schreibgeschwindigkeit keine Wunder erwarten, erst recht nichts was die theoretischen 5 GBit/s (also 640 MB/s) von USB 3 auch nur ansatzweise erreicht. Ich würde so mit maximal 100 MB/s bei einer guten Platte und zusammenhängenden Daten rechnen.
- USB hat immer auch etwas Protokoll Overhead, sprich die vollen 5 GBit/s schafft man auch mit einer entsprechend schnellen SSD nicht.
- Je nach USB-Config im MBP (weiß gerade nicht wie die Ports des 2017er MBP angebunden sind) kann es auch sein, dass beide Ports sich Bandbreite teilen, weil sie quasi intern an einem Hub hängen und nicht unbedingt beide eine direkte Anbindung an CPU/Chipsatz haben
- Wenn es viele kleine Dateien sind statt wenige große (am Block befindliche) Dateien, dann ist das bei HDDs ohnehin langsam und vermutlich deutlich unter 100 MB/s
 

klausiB

Neues Mitglied
Thread Starter
Dabei seit
02.07.2008
Beiträge
45
Punkte Reaktionen
0
Danke euch. Das klingt alles plausibel. Kein Bug also, sondern normal. Das mit den Ports werde ich mal checken. Ansonsten ist es im Alltag ja auch kein Problem, nur wenn man mal seine Backups und so umorganisiert, dann kann es halt dauern ...
 
Oben Unten