Mac OS X und SAMBA (Debian Linux)

  1. big..apple

    big..apple Thread StarterMacUser Mitglied

    Mitglied seit:
    17.11.2004
    Beiträge:
    4
    Zustimmungen:
    0
    Hi,

    weiß jemand, wie man von Mac OS X (v10.4.2) mittels SAMBA auf einen Linux Server (Debian Linux) zugreifen kann? Der SAMBA Server ist ein einer Active Directory Domäne und kann im Finder gefunden werden. Nach Zugriff hängt sich der Finder auf. Der Rechner kann angepingt werden, allerdings nur über die IP-Adresse. Der im Finder angezeigte Name kann jedoch nicht aufgelöst werden. Windows-Rechner innerhalb der Domäne haben keinerlei Probleme beim Zugriff, der Mac hat ebenfalls keine Probleme, auf andere Windows-Server zuzugreifen.

    Kenn jemand das Problem, oder besser noch, hat jemand einen Lösungsvorschlag.

    Besten Dank!
    Big..Apple
     
    big..apple, 29.07.2005
  2. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.171
    Zustimmungen:
    3.888
    probier doch mal den smbclient im terminal...
    (dass der name nicht ausgelöst werden per DNS ist normal, die samba namen laufen nicht über DNS)
    welche samba version läuft denn auf dem debian?
     
    oneOeight, 29.07.2005
  3. Evil Azrael

    Evil AzraelMacUser Mitglied

    Mitglied seit:
    29.07.2005
    Beiträge:
    3
    Zustimmungen:
    0
    Hi!

    Ich bin der Typ, der den Samba-Server aufgesetzt hat.

    stimmt, sollte eigentlich über den WINS server laufen, wenn ich das richtig verstanden habe. sehe ich das richtig, das Mac OS X unter die Verzeichnisdienste nur Authentication versteht und nicht namensauflösung und andere dienste?

    Die aktuelle von Debian, sollte also 3.0.14a-3 sein. Also als fertiges Paket installiert.

    Ist halt merkwürdig, das nur der Mac nicht auf den Samba Server kommt. Alle Windowskisten haben keine Probleme mit dem Server. Wenn man über Verbinden versucht eine Freigabe zu mounten, dann fragt der immer nach dem Benutzer und Passwort und akzeptiert die Daten, mit denen die Anmeldung an anderen Servern in der ADS domäne klappt, nicht.

    Die kommandozeilentools hab ich nicht ausprobiert, da wir eben leider nicht so viel zeit hatten, und leider haben die programme auch alle irgendwie andere parameter(-formate) als die linux-äquivalente (wenn ich da schon an mount denke....)
     
    Evil Azrael, 29.07.2005
  4. bashir

    bashirMacUser Mitglied

    Mitglied seit:
    02.01.2005
    Beiträge:
    49
    Zustimmungen:
    1
    bashir, 29.07.2005
  5. Evil Azrael

    Evil AzraelMacUser Mitglied

    Mitglied seit:
    29.07.2005
    Beiträge:
    3
    Zustimmungen:
    0
    danke, haben wir bei der suche wohl übersehen.
    das mit der password encryption ist wohl ein versuch wert, aber die freigabeart zu ändern, kommt wegen der Domäne nicht in Frage.
     
    Evil Azrael, 29.07.2005
  6. bashir

    bashirMacUser Mitglied

    Mitglied seit:
    02.01.2005
    Beiträge:
    49
    Zustimmungen:
    1
    wie ich in dem anderen thread schon schrieb, hat reichtes es bei mir, nochmal ein passwort zu vergeben?!

    Allerdings musste ich lange hin und her probieren, bis ich eine einigermassen funktionierende smb.conf hatte (extreme geschwindigkeitseinbussen)

    viel glueck

    bashir
     
    bashir, 29.07.2005
  7. gewoldi

    gewoldiMacUser Mitglied

    Mitglied seit:
    13.07.2005
    Beiträge:
    125
    Zustimmungen:
    0
    Is vielleicht nicht das, was du suchst, aber schau dir mal netatalk an... Läuft super stabil bei mir und mehreren Kunden. Von OS 8.6 bis 10.4.2
     
    gewoldi, 29.07.2005
  8. mdtrinker

    mdtrinkerMacUser Mitglied

    Mitglied seit:
    02.02.2005
    Beiträge:
    193
    Zustimmungen:
    9
    Kommt vielleicht zu spät die Hilfe, aber ich hatte das Problem auch. Gleiche Samba Version von Debian stable. Lies sich aber relativ einfach lösen.

    nano /etc/apt/sources.list -> von stable auf unstable umstellen

    apt-get update (kein upgrade!!)

    apt-get install samba (installiert die aktuellste Samba Version)

    nano /etc/apt/sources.list -> von unstable auf stable umstellen

    apt-get update

    Fertig. Nachdem bei mir die 3.0.20b-2 drauf war hat der Finder wieder ohne Probleme die Shares anzeigen und mounten können.

    solence
     
    mdtrinker, 15.11.2005
  9. Evil Azrael

    Evil AzraelMacUser Mitglied

    Mitglied seit:
    29.07.2005
    Beiträge:
    3
    Zustimmungen:
    0
    ja, in der samba 3.0.14 war ein bug drin und debian hat ewigkeiten zum fixen gebraucht (und ich bin leider zu unfähig/faul selber das paket zu basteln).
    leider kommen die Macs immer noch nicht drauf, jetzt kommt ein anderer Fehler. hatte aber leider keine gelegenheit da noch mehr zu testen.

    ausserdem hat einer der macs den geist aufgegeben :D
     
    Evil Azrael, 15.11.2005
  10. oneOeight

    oneOeightMacUser Mitglied

    Mitglied seit:
    23.11.2004
    Beiträge:
    48.171
    Zustimmungen:
    3.888
    wäre ein "apt-get install -t unstable samba" nicht einfacher gewesen ;)
     
    oneOeight, 15.11.2005
Die Seite wird geladen...