macOS Mojave Mac OS vs. Google - Login Probleme

MacMarc1994

Neues Mitglied
Thread Starter
Dabei seit
08.08.2014
Beiträge
19
Punkte Reaktionen
2
Nachdem ich einige Jahre Frieden hatte und alle Schnittstellen, wo mein Google Account und mein Mac miteinander "auskommen" mussten, gut liefen, ist nun wieder der Wurm drinnen. Das Problem ist, dass man bei bestimmtem Verhalten schwer dahinter kommt, ob das Problem beim Mac oder bei Google liegt. Ich hoffe, hier liest jemand mit, der das Problem kennt und im Idealfall auch die Lösung.

Kurz zum bestehenden: MacBook Pro (A1502) mit MacOS 10.14.6 aka Mojave. Google Account ist lediglich für Mail eingerichtet, ursprünglich auch für Kalender. Gmail war als POP eingerichtet, was Jahre gut tat, jetzt aber als IMAP

Irgendwann fing (ohne, dass an der Konfiguration etwas verändert wurde) Mail an zu melden, dass der Login bei Google scheitert. Trotz Eingabe des eindeutig richtigen Passworts ging nichts mehr. Ich habe dann
  • Sicherheitshalber mal das ganze Google Account in den Systemeinstellungen entfernt und auch gleich
  • alle im Schlüsselbund gespeicherten Passwörter, die irgendetwas mit Google zu tun haben, gelöscht.
  • Beim wieder Einrichten ließ sich ein POP Account gar nicht mehr erstellen; scheiterte immer am Login.
  • Da ich ohnehin auf IMAP gehen wollte, versuchte ich es damit, was ganz entspannt (mit deutlich weniger Einstellungen als POP) funktionierte.
  • Die nervige, zeitraubende "Bestätigung in 2 Schritten" (2 Faktor Identifikation) habe ich im Google Konto deaktiviert.

Nun bleibt aber ein sehr nerviges Verhalten, was ich ums Verrecken nicht in den Griff bekomme: Nachdem der Mac aus oder im Ruhezustand war, erfolgt der Login bei Google nicht automatisch, sondern es muss sehr kompliziert eine Anmeldung über einen Browser geschehen. Dies erfolgt auch unter allerlei Eigentümlichkeiten:
  • Erst wird man aufgefordert in die Systemeinstellungen zu den Internetaccounts zu gehen - die Passwort-Eingabe kann nicht in Mail erfolgen.
  • Dann muss ausgerechnet Safari geöffnet werden! Keine Ahnung, aufgrund welcher Einstellung auf diesen Browser zugegriffen wird; ich nutze Safari nie. Als Standardbrowser ist Chrome eingestellt.
  • Es kommt nach jedem Login eine Sicherheitswarnung von Google per E-Mail.
  • Gehe ich in den Sicherheitscheck von Google, ist dort unter den "weniger sicheren Drittanbieter Apps" u.a. Mac OS aufgelistet. (Es wird empfohlen den Zugriff zu entziehen)
Das führt zu den folgenden Fragen:
  • Kann ich mittels irgendwelcher (welcher?) Einstellungen an meinem Mac dieses nervige Verhalten beenden und für eine nahtlose Anmeldung bei Google sorgen? So wie es Jahre lang funktioniert hat?
  • Kann ich irgendwo einstellen, dass nicht Safari sondern der eingestellte Standard Browser geöffnet wird?
  • Und schließlich - vermutlich eher eine Google-, als eine Mac-Frage - warum wird meinem Mac und seinem Betriebssystem plötzlich so "misstraut"? Liegt das am Mac, der sich gegenüber Google verdächtig verhält? Oder ist das eine neue Marotte der Kleinkriegs zwischen Apple und Google?
Ich wäre richtig begeistert, wenn es eine Lösung hierfür gäbe. Klar, habe ich die SuFu bemüht, bin aber - auch aufgrund der etwas unscharfen Suchbegriffe - auf nichts brauchbares gestoßen. Sollte es dennoch bereits einen Fred geben, der das behandelt, freue ich mich auch über einen entsprechenden Verweis.
Danke für die Geduld beim Lesen!


Bildschirmfoto 2021-11-28 um 14.38.26.png Bildschirmfoto 2021-11-27 um 20.06.54.png Bildschirmfoto 2021-11-27 um 20.07.01.png
 
Zuletzt bearbeitet:

raubsauger

Mitglied
Dabei seit
09.04.2004
Beiträge
502
Punkte Reaktionen
348
Kann man beim Anlegen des Mailkontos in Apple Mail auch Anbieter "andere/sonstige" angeben und alles manuell konfigurieren?
 

MacMarc1994

Neues Mitglied
Thread Starter
Dabei seit
08.08.2014
Beiträge
19
Punkte Reaktionen
2
vermutlich…
Sollte ich das mal probieren? Also das Google Account nochmals komplett löschen? Was kann ich mir davon versprechen? Reines Try-and-Error, oder denkst Du an eine bestimmte Einstellung, die ich dann vornehmen kann?

Das wäre halt leider mit einer mittleren, zeitraubenden Lästigkeit verbunden: Da es ein IMAP Konto ist, werden alle auf dem Server befindlichen Mails bei Anlegen eines neuen Kontos erneut geladen. Das war mir übrigens auch klar, als ich damit anfing. Daher habe ich auch die ca. 10.000 Mails bei Google voher mal etwa geviertelt. Das Sortieren und Löschen war das zeitaufwändigste an der ganzen Aktion. Aber auch irgendwie fällig. Zu manchem muss man halt gezwungen werden. Das erste Laden der Mails hat dennoch eine gefühlte Ewigkeit gedauert.
 

MacKaz

Aktives Mitglied
Dabei seit
12.01.2020
Beiträge
2.478
Punkte Reaktionen
1.526
Ich würde die E-Mail-Adresse (und ggf. den Namen) in den Screenshots unkenntlich machen.

Edit: Auf den ersten Blick würde ich vermuten, dass die Authentifizierungsmethode nicht passt. Neben dem klassischen Kennwort gibt es ja auch die Authentifizierung über den Anbieter, so kenne ich das zumindest von Office 365.
In Postbox zum Beispiel kann man das auswählen, wie es bei Apple Mail aussieht weiß ich nicht.
 

MacMarc1994

Neues Mitglied
Thread Starter
Dabei seit
08.08.2014
Beiträge
19
Punkte Reaktionen
2
Das dachte ich auch schon, dann aber was soll's. Danke für den Hinweis; vllt doch besser…
 

raubsauger

Mitglied
Dabei seit
09.04.2004
Beiträge
502
Punkte Reaktionen
348
Ich mag diese Konfigurations-Skripte nicht bei denen man nicht weiß was da passiert. Deshalb würde ich es einfach mal versuchen.
 

MacMarc1994

Neues Mitglied
Thread Starter
Dabei seit
08.08.2014
Beiträge
19
Punkte Reaktionen
2
Bei den "Internetaccounts" der Systemeinstellungen gibt es keine weiteren Möglichkeiten. In Mail kann man ein anderes, als die vorgewählten Accounts einrichten. Wenn ich den Weg wähle, gelange ich erstaunlicherweise umgehend zu der Meldung "Accountname/Passwort konnte nicht überprüft werden"



Bildschirmfoto 2021-11-29 um 13.39.50.png Bildschirmfoto 2021-11-29 um 13.46.00.png
 

MacMarc1994

Neues Mitglied
Thread Starter
Dabei seit
08.08.2014
Beiträge
19
Punkte Reaktionen
2
Damit dieser Thread nicht einer der unzähligen wird, die nur ein Problem, nicht aber eine Lösung enthalten, hier meine Lösung, die aber auch irgendwie unbefriedigend ist, weil sie der Ursache keinen Schritt näher kommt:

Ich habe festgestellt, dass man die Meldungen, die dass System liefert, getrost ignorieren kann (einfach "schließen" klicken). Wenn man dann Mail öffnet wird das Gmail Account als offline angezeigt und oben rechts erscheint eine Meldung "⚠️Anmeldung fehlgeschlagen".
Wenn ich nun diese anklicke, erfolgt die Anmeldung!
Vollkommen unlogisch und rätselhaft. Eine Erklärung mag sein, dass beim ersten Anmelden es zu irgendwelchen zeitlichen Problemen kommt. Also die Routine, die das (sehr wohl korrekt abgespeicherte!) Passwort zur Verfügung stellen soll, hinterher hinkt und das PW wird beim ersten Anmeldeversuch nicht gefunden wird. Whatever - wir werden es nie erfahren. Ich kann jedenfalls damit leben, die nervige Meldung zunächst weg zu klicken und kurz darauf in Mail die Anmeldung wie beschrieben erneut zu starten.

Was übrigens nicht funktioniert, obwohl es wesentlich naheliegender wäre, ist, beim Account, was wegen gescheiterter Anmeldung als offline angezeigt wird, einfach per Kontextmenupunkt "Accont online" zu wählen. Da passiert dann gar nüscht. Ach, Apple Mail ist halt einfach die mieseste Krücke im ganzen MacOS und ich wünschte, ich könnte mir mal die Zeit nehmen auf einen vernünftigen E-Mail Client zu migrieren. Ist halt eine gewisse Hürde…
 
Oben Unten