Mac Mini M1: Monitor geht nach Ruhezustand oft nicht mehr an

mailtopp

Mitglied
Thread Starter
Registriert
17.09.2003
Beiträge
756
Hey zusammen,

seit ein paar Tagen hab ich den Mac Mini M1 zu Hause, der über Thunderbolt an einem LG Display hängt. Energieeinstellung ist, dass nach 10 Minuten der Display Ausgang abgeschaltet werden soll, was auch funktioniert, ca. 10 Sekunden danach merkt auch das Display, dass jetzt kein Signal mehr anliegt und legt sich selbst auch schlafen. In mindestens 50% aller Fälle bekomme ich den Mac Mini aber danach nicht mehr aufgeweckt. Das LG Display merkt zwar, dass da jemand aufgewacht ist, schaltet sich selbst wieder in den aktiven Modus, aber es kommt dann kein Videosignal an und folglich legt sich das Display nach 10 Sekunden wieder schlafen.

Einzige Abhilfe schafft man damit, indem man das Thunderbolt Kabel am Mac Mini absteckt und wieder ansteckt. Auch da ist es dann wieder ca. ne 50/50 Chance, dass der Mac sogar komplett neu startet. Auf den ersten Blick sieht man das gar nicht (man sieht keinen Bootvorgang), aber die Netzlaufwerke sind danach alle disconnected und die uptime im Terminal zeigt eben erst ein paar Sekunden an. Ebenfalls merke ich an Fenstern die vorher maximiert waren, dass sie auf einmal alle mit einer geringeren Auflösung geöffnet sind, ich muss sie dann erst wieder maximieren.

Ich hab auch schon zwei englischsprachige Threads dazu entdeckt:
https://forums.macrumors.com/threads/m1-mac-mini-not-waking-display-after-sleep.2270758/
https://www.reddit.com/r/macmini/comments/k36a9x
Hat jemand ähnliche Probleme? Und vielleicht sogar eine Lösung dazu?

Dankeschön!
 

EasyChris

Mitglied
Registriert
01.09.2014
Beiträge
139
Ja das Problem hatte ich auch mit einem Dell 27" Monitor an HDMI. Bei mir war die Lösung ein HDMI auf Thunderbolt Adapter von Anker. Seitdem wacht der Monitor immer auf. Das ist definitiv ein Bug im OS, als Workaround könntest du in den Energieeinstellungen den haken setzen bei "Automatisches Aktivieren des Computerruhezustands bei ausgeschalteten Display außer kraft setzen"

Dann geht der Mini nicht mehr richtig im Ruhezustand, aber das aufwecken des Monitors sollte wieder funktionieren.
Du könntest auch mal versuchen den Monitor über HDMI am Mini anzuschließen ob es dann besser wird.

Ich hatte zu diesem Thema übrigen auch mal einen Thread gestartet: Lösungsansätze
 

mailtopp

Mitglied
Thread Starter
Registriert
17.09.2003
Beiträge
756
Hi nochmal,
also erstens: "automatisches aktibieren des Computerruhezustands" ausschalten hat bei mir nichts geholfen. Ob der Mac selbst schläft oder nicht, war bei mir egal, es hat gereicht, dass der Monitor schwarz wurde, um in das Problem zu laufen.

Zweitens: Ich hab das Problem gelöst, weiß aber nicht genau, welche dieser beiden Maßnahmen jetzt relevant war:

1. Am Monitor hab ich die Displayport Version von 1.4 auf 1.2 reduziert (habe ich in irgendeinem Thread gelesen)
2. Ich hab folgende drei Dateien gelöscht:
  • /Library/Preferences/com.apple.windowserver.displays.plist
  • ~/Library/Preferences/ByHost/com.apple.windowserver.XXXXXXXX.plist
  • ~/Library/Preferences/ByHost/com.apple.windowserver.displays.XXXXXXXXXX.plist
Quelle: https://forums.macrumors.com/threads/m1-external-display-glitch.2271509/post-29591818

Seit diesen beiden Maßnahmen wacht der Mac scheinbar zuverlässig UND deutlich schneller auf. Ich lass das jetzt mal ein paar Tage so um sicher zu gehen und werde dann die DisplayPort Version wieder auf 1.4 zurück stellen
 
Oben