[LaText und Biblatex] \usepackage[style=geschichtsfrkl]{biblatex}

Diskutiere das Thema [LaText und Biblatex] \usepackage[style=geschichtsfrkl]{biblatex}. Hallo Leute, ich bereite mich darauf vor, in der kommenden Zeit mehrere größere Arbeiten mit...

thetransformer

Mitglied
Thread Starter
Mitglied seit
13.07.2008
Beiträge
523
Hallo Leute,

ich bereite mich darauf vor, in der kommenden Zeit mehrere größere Arbeiten mit LaTex zu schreiben. Zu diesem Zweck habe ich mich grundlegend schon in das Programm eingearbeitet. Zwar habe ich bisher lediglich mit Word und Pages gearbeitet, aber so das wichtigste habe ich mittlerweile drauf, wenngleich ich viele Details immer wieder googeln muss.

Eine Sache ist mir aber vollkommen Schleierhaft - vielleicht kann mir da mal ein kundiger User helfen.

Ich bin nämlich auf eine Paket namens "geschichtsfrkl" gestoßen und würde dieses gerne einbinden, da die Zitierweise damit haargenau so durchgeführt wird, wie ich das benötige. Zu diesem Paket gibt es auch eine kleine Anleitung. Die Basics (Seite 1-15 des Dokuments) sind klar, aber die Installation (ab Seite 16) raff ich so gar nicht. Ich hab null Ahnung, was ich mit den beiden Dateien (.bbx und .cbc) machen soll, wohin die müssen (den dort angegebenen Pfad gibt es bei mir nicht) und was eine ins-Datei ist und wofür ich das nun wieder brauche. Auch der Punkt "Umsetzung" (S. 17) ist mir ein Rätsel - was soll wie da umgesetzt werden?

Ich hoffe, ich als Laie bekomme das ganze durch ein paar Tipps hin, aber ich steh da echt wie der Ochs' vor'm Berg. Ich habe die Grundsachen soweit autodidaktisch und mit Google hinbekommen und kann schon ganz passable Arbeiten anfertigen, aber das hier peil ich nicht - und das ist schlecht, weil die Zitation je gerade eines der Dinge ist, die LaTex mir annehmen soll. Geplant war eigentlich, eine Bib mit BibLaTex anzufertigen.

VG
thetransformer
 

Emma der Hund

MacUser Mitglied
Mitglied seit
08.10.2005
Beiträge
415
Hallo,

Du sagst nicht, welche Distribution Du verwendest. Evtl lässt sich das mithilfe des Installationsmanagers erledigen (Hinweis website: "If possible, get this package from your distribution using its installation manager.")
Zur manuellen Installation:
Hab es jetzt nur mal überflogen, sollte aber recht einfach sein:
Lade hier mal die Dateien geschichtsfrkl.dtx sowie geschichtsfrkl.ins herunter und lege sie in einen Ordner, in dem Latex sie findet (~/Library/texmf/tex/latex/) => ~ = Dein Benutzername (am Rechner, nicht im Forum ;) )

Dann öffnest Du die ins-Datei mit Deinem Editor und kompilierst sie. Dabei sollten dann eigentlich die benötigten bbx und cbx Dateien entstehen. Die legst Du dann wie beschrieben in die notwendigen Ordner. Das sollte es eigentlich schon sein.

Angaben ohne Gewähr :)
 

thetransformer

Mitglied
Thread Starter
Mitglied seit
13.07.2008
Beiträge
523
Hey!

Kurz vorweg: Meine Arbeitszeiten lassen eine schnellere Antwort im Moment nicht zu. Ich tanze gerade auf vielen Hochzeiten.

Ich nutze die The MacTeX-2011 Distribution. Da habe ich aber noch keinen Installationsmanager gefunden, wenngleich ich mir noch nicht bei allen mitgelieferten Programmen sicher bin, was diese tun :)

Den Link, den du gepostet hast, habe ich auch schon gefunden. Genau da habe ich die beiden Dateien (.bbx und .cbc) auch her. Den Pfad ~/Library/texmf/tex/latex/ gibt es bei mir wie gesagt gar nicht. Mit alt+KLick auf Gehe zu > Library findet er nix, was irgendwie nach /texmf/ aussieht. Und eine .ins-Datei gibts auch nicht :)

Alles sehr merkwürdig. Bei der Installationsanleitung versteh ich ab S. 16 nur chinesisch.
 

iTob

Mitglied
Mitglied seit
23.02.2005
Beiträge
493
Also dieser texmf-Ordner kann bei der Installation angelegt worden sein muss aber nicht. Gib mal kpsewhich -var-value=TEXMFHOME in dein Terminal ein. Dabei sollte der Pfad rauskommen, den Emma schon genannt hat. Dort kannst du dann den texmf-Ordner und die Unterordner anlegen und TeX sollte die Daten finden können.
 

iTob

Mitglied
Mitglied seit
23.02.2005
Beiträge
493
Nachtrag: Allerdings ist dieser Stil teil von TeXLive und damit auch von MacTeX. Auf meinem Rechner ist der schon drauf. Öffne mal das TeX Live Utility dort kannst du dir unter Packages anzeigen lassen, was schon installiert ist und unter Updats fehlendes ggf. nachinstallieren. Dann musst du gar nicht mit dem texmf-Ordner und den ins-Dateien arbeiten.
 

iTob

Mitglied
Mitglied seit
23.02.2005
Beiträge
493
Noch ein Nachtrag: Ich sehe gerade das das Paket aus TeX Live gelöscht wurde, ich antworte nachher ausführlich – muss jetzt weg …
 

Emma der Hund

MacUser Mitglied
Mitglied seit
08.10.2005
Beiträge
415
Ich nutze die The MacTeX-2011 Distribution. Da habe ich aber noch keinen Installationsmanager gefunden, wenngleich ich mir noch nicht bei allen mitgelieferten Programmen sicher bin, was diese tun :)
Findest Du den Pfad, wenn Du einfach über den Finder gehst? Also ein neues Fenster öffnest, ganz links auf das Häuschen (Dein Account) klickst, dann
auf die Library etc?
 

thetransformer

Mitglied
Thread Starter
Mitglied seit
13.07.2008
Beiträge
523
Danke für die vielen Hinweise. Es wird langsam!

Mit kpsewhich -var-value=TEXMFHOME spuckt mir das Terminal den Pfad /Users/Benutzer/Library/texmf aus. Suche ich den, gibt es ihn nicht. Eine umgekehrte Suche im Terminal sagt mir dann No such file or directory. Merkwürdig. Auch über Häuschen > Library findet er nichts.

ABER:

Ich habe jetzt erst das TeX Live Utility entdeckt und dort tatsächlich das Paket gefunden! Ich konnte es installieren - jedenfalls glaube ich das. Es steht im Utility als "installed"

Zwar klappt im Moment die Einbindung der .bib-Datei nicht - es erscheint der Fehler "paragraph ended before fileswith@ptions was complete" - aber das wird ja jetzt wohl nicht mehr grundsätzlich mit der Einbindung des Pakets zu tun haben (hoffe ich)
 

Emma der Hund

MacUser Mitglied
Mitglied seit
08.10.2005
Beiträge
415
PHP geht, oder einfach Code => das Raute-Symbol bei der Eingabe.

Dein Beispiel läuft so nicht bei mir - es ist, streng genommen, auch nicht minimal ;)

Zunächst: In Zeile 29 fehlt eine eine ], das beseitigt den eigentlichen Fehler. => \usepackage[style=geschichtsfrkl{biblatex}

Dann aber: Du lädst zweimal das biblatex-Paket (einmal Zeile 5, einmal Zeile 29) => führt bei mir zu einem option-clash

Irgendwo ist aber immer noch ein Fehler. Den suche ich noch :)
 

thetransformer

Mitglied
Thread Starter
Mitglied seit
13.07.2008
Beiträge
523
Die eckige Klammer fehlte tatsächlich. Danke dafür!
Das doppelte Packet war ein Copy+Paste Fehler meinerseits. Sorry!

Ich glaube der Fehler lag woanders. Meine Titelseite sieht so aus:

Code:
Inhalt nur für registrierte User sichtbar  Logge dich ein oder registriere dich jetzt.
Meine Mail Adresse hatte ich mit \href gekennzeichnet. Das hab ich jetzt rausgenommen und jetzt geht's! Natürlich hab ich mit dem Paket jetzt noch zu kämpfen, aber ich hab's grade mal mit einem Beispieltext (Lorem ipsum ...) probiert und sieht soweit ganz gut aus. Am Wochenende werde ich meine Bibliographie mal ausarbeiten und sehen, ob es tatsächlich so klappt, wie ich es mir vorstelle!

Danke für die Hilfe!!!

By the way: Was fehlte zum Minimalbeispiel? :)
 

Emma der Hund

MacUser Mitglied
Mitglied seit
08.10.2005
Beiträge
415
Danke für die Hilfe!!!

By the way: Was fehlte zum Minimalbeispiel? :)
Bitte gerne; freut mich, dass es jetzt läuft :)

Zum Minimalbeispiel fehlte nichts –*ganz im Gegenteil: Es war zu lang ;)

Ein Minimalbeispiel ist die kürzeste, aber lauffähige! Version des Codes, die den gesuchten Fehler reproduziert.
Meistens findet man die Probleme dann schon selbst, wenn man den eigentlichen Code zusammenkürzt :)

Siehe auch hier: http://minimalbeispiel.de/mini.html
 

Emma der Hund

MacUser Mitglied
Mitglied seit
08.10.2005
Beiträge
415
Noch etwas:
Ein Teil der Optionen bei der documentclass sind redundant - da kannst Du noch was kürzen- a4 ist bei KOMA default, 12pt glaube ich auch :)

Einfügen müsstest Du (am Ende) noch \printbibliography, damit die Bibliographie ausgegeben wird.
 

thetransformer

Mitglied
Thread Starter
Mitglied seit
13.07.2008
Beiträge
523
Soooo ... da ich nun doch noch zwei Kleinigkeiten habe, versuche ich es einfach noch mal hier - hat ja heut morgen schon mal geklappt :)

Nachdem nun vieles klappt, habe ich mit dem o.g. Paket "geschichtsfrkl" noch zwei Probleme, die ich auch mit Hilfe der Dokumentation des Pakets nicht lösen kann. Zum einen bekomme ich die Bibliographie am Ende nicht so formatiert, dass die einzelnen Literaturtitel linksbündig bzw. im Blocksatz erscheinen. Zum anderen erscheint eine Art Kopfzeile mit dem Stichwort "Literatur" welches ich nicht wegbekomme.

Hier ein Bild: Bildschirmfoto 2012-04-28 um 00.15.51.jpg

Hier mal ein (hoffentlich besseres) Minimalbeispiel meiner .tex-Datei:

Code:
Inhalt nur für registrierte User sichtbar  Logge dich ein oder registriere dich jetzt.
Zwar sagt mir die Dokumentation zu geschichtsfrkl direkt auf Seite 2, man müsse an geeigneter Stelle den \printbibliography-Befehl aufrufen, um eine Bibliographie zu erzeugen und könne diese kann biblatex-typisch formatieren, aber alle meine Versuche scheiterten. Und ich habe auch diese bibLaTex-Dokumentation jetzt zwei Stunden lang hoch und runter gescrollt und durchsucht - aber alles ohne Erfolg. Bereits aufgegeben habe ich die Suche nach einer Lösung des Problems, dass Namenszusätze bei der alphabetischen Sortierung ignoriert werden. "te Heesen" müsste eigentlich (ich hab da leider Vorgaben) unter "t" und nicht wie hier unter "h" erscheinen.
 
Oben