LaTeX via Emacs im Terminal: Umlaute etc.

Dieses Thema im Forum "Mac OS - Unix & Terminal" wurde erstellt von Peisistratos, 06.04.2006.

  1. Peisistratos

    Peisistratos Thread Starter

    Hallo mit einander,

    falls jemand von Euch auch auf die verrückte Idee kommen sollte, LaTeX-Dokumente mit dem Emacs via Terminal (Mac OS X 10.4.3, Emacs 21.2.1) editieren zu wollen und auf das leidige Thema Umlaute stoßen sollte: Leider funktionieren die ergoogelten Tipps - zumindest auf dem Mac - nicht immer, und die Foren sind manchmal recht mager zu diesem Thema.

    http://www.emacswiki.org/cgi-bin/emacs-de/EmacsOnGermanMac
    http://kaiser-edv.de/news/MacOS/UmlauteShell.shtml
    und
    http://user.cs.tu-berlin.de/~eserte/FreeBSD/doc/umlaute/umlaute.html
    bieten einen saumäßig guten Einstieg, aber die Umlaute im Emacs funzen damit seltsamerweise nicht.

    Da ich in diesem Forum schon etliche wertvolle Hinweise gefunden habe, möchte ich die Ergebnisse meiner Recherchen zusammenfassend hier posten, bzw. mit welchen Einträgen es bei mir klappt.

    Damit lernt die bash Umlaute:

    ~/.bash_profile:
    LANG=de_DE.UTF-8
    MM_Charset=UTF-8
    export LANG MM_Charset

    ~/.inputrc
    set meta-flag ON
    set input-meta On
    set conver-meta Off
    set output-meta On
    set show-all-if-ambiguous On

    Beim emacs haut's folgendermaßen hin. Der Eintrag (standard-display-european t) hat leider nicht funktioniert, nur (set-keyboard-coding-system 'utf-8) ist zu wenig.

    ~/.emacs
    (setq locale-coding-system 'utf-8)
    (set-terminal-coding-system 'utf-8)
    (set-keyboard-coding-system 'utf-8)
    (set-selection-coding-system 'utf-8)
    (prefer-coding-system 'utf-8)

    Wenn man dann noch

    \usepackage[utf-8]{inputenc}

    in der Präambel des Latexdokumentes eingibt, läuft das wie geschmiert.

    Herzliche Grüße, Peisistratos
     
Die Seite wird geladen...

Diese Seite empfehlen