Latex mit TexShop, TexLive2008 eps Dateien und psfraq

HerrDesChaos

Neues Mitglied
Thread Starter
Dabei seit
06.04.2007
Beiträge
45
Punkte Reaktionen
0
Hi zusammen,

ich versuche meine Diplomarbeit mit TexShop zu schreiben. Habe eine Vorlage bekommen die unter mikTex und TexnicCenter einwandfrei funktioniert.

TexShop bekommts es aber nicht au die Reihe.
In der Vorlage werden eps Grafiken eingebunden und psfraq wird acuh verwendet.

Ich habe bereits eigestellt, das tex + Ghortscript benutzt werden soll zu setzen. Trotzdem taucht beim setzen immer wieder die Ansage "This is pdfTex" auf. Und pdfTex ist ja gerade das, was ich nicht verwenden will.

Hat hier vielleicht jemand Rat?
Es kann doch nicht sein, dass ich zum LaTex schreiben wieder zu Windows wechseln muß.

Es wäre auch schön wenn das LaTex File im Endeffekt mit beidem Laufen würde. TexnicCenter und TexShop. Weil inner Uni Windows Rechner verwendet werden.

Mfg,
HDC
 

pseudogc

Mitglied
Dabei seit
19.12.2005
Beiträge
704
Punkte Reaktionen
83
geneigte Leser,

Fehlermeldungen, Beispieldokumente, was soll "TexShop bekommts es aber nicht au die Reihe." bitte genau bedeuten?

cheers,
pseudogc
 

HerrDesChaos

Neues Mitglied
Thread Starter
Dabei seit
06.04.2007
Beiträge
45
Punkte Reaktionen
0
Das ist was er mir sagt. Und das klingt für mich nicht gut.
Bin für jeden Ratschlag dankbar.

### This is /usr/texbin/simpdftex, Version 20070809
### /usr/texbin/latex NT_Diplomarbeit.tex
This is pdfTeXk, Version 3.1415926-1.40.9 (Web2C 7.5.7)
%&-line parsing enabled.
entering extended mode
(./NT_Diplomarbeit.tex
LaTeX2e <2005/12/01>
Babel <v3.8l> and hyphenation patterns for english, usenglishmax, dumylang, noh
yphenation, german-x-2008-06-18, ngerman-x-2008-06-18, ancientgreek, ibycus, ar
abic, basque, bulgarian, catalan, pinyin, coptic, croatian, czech, danish, dutc
h, esperanto, estonian, farsi, finnish, french, galician, german, ngerman, mono
greek, greek, hungarian, icelandic, indonesian, interlingua, irish, italian, la
tin, mongolian, mongolian2a, bokmal, nynorsk, polish, portuguese, romanian, rus
sian, sanskrit, serbian, slovak, slovenian, spanish, swedish, turkish, ukenglis
h, ukrainian, uppersorbian, welsh, loaded.
(/usr/local/texlive/2008/texmf-dist/tex/latex/koma-script/scrbook.cls
Document Class: scrbook 2007/12/24 v2.98 KOMA-Script document class (book)
(/usr/local/texlive/2008/texmf-dist/tex/latex/koma-script/scrkbase.sty
(/usr/local/texlive/2008/texmf-dist/tex/latex/graphics/keyval.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/koma-script/scrlfile.sty
Package scrlfile, 2007/12/18 v2.98 KOMA-Script package (loading files)
Copyright (C) Markus Kohm

)) (/usr/local/texlive/2008/texmf-dist/tex/latex/base/bk12.clo)
(/usr/local/texlive/2008/texmf-dist/tex/latex/koma-script/typearea.sty
Package typearea, 2007/12/24 v2.98 KOMA-Script package (type area)
Copyright (C) Frank Neukam, 1992-1994
Copyright (C) Markus Kohm, 1994-


Package scrkbase Warning: You've used obsolete option `dvips'.
(scrkbase) \KOMAExecuteOptions{pagesize=dvips} will be
(scrkbase) used instead.
(scrkbase) You may simply replace `dvips'
(scrkbase) by `pagesize=dvips' on input line 451.

)) (/usr/local/texlive/2008/texmf-dist/tex/latex/koma-script/scrpage2.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/ae/ae.sty
(/usr/local/texlive/2008/texmf-dist/tex/latex/base/fontenc.sty
(/usr/local/texlive/2008/texmf-dist/tex/latex/base/t1enc.def)
(/usr/local/texlive/2008/texmf-dist/tex/latex/ae/t1aer.fd)))
(/usr/local/texlive/2008/texmf-dist/tex/latex/base/inputenc.sty
(/usr/local/texlive/2008/texmf-dist/tex/latex/base/latin1.def))
(/usr/local/texlive/2008/texmf-dist/tex/generic/babel/babel.sty
(/usr/local/texlive/2008/texmf-dist/tex/generic/babel/ngermanb.ldf
(/usr/local/texlive/2008/texmf-dist/tex/generic/babel/babel.def)))
(/usr/local/texlive/2008/texmf-dist/tex/latex/base/fontenc.sty
(/usr/local/texlive/2008/texmf-dist/tex/latex/base/t1enc.def))
(/usr/local/texlive/2008/texmf-dist/tex/latex/tools/verbatim.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/caption/caption2.sty

Package caption2 Warning: ****************************************************
(caption2) THIS PACKAGE IS OBSOLETE:
(caption2) This package attempts to provide an `caption2'
(caption2) package v2.0/2.1 author environment so that OLD
(caption2) documents can be successfully processed. It should
(caption2) NOT be used for NEW documents! New documents should
(caption2) use the regular `caption' package v3.x instead.
(caption2) ****************************************************

(/usr/local/texlive/2008/texmf-dist/tex/latex/caption/caption3.sty))
(/usr/local/texlive/2008/texmf-dist/tex/latex/graphics/graphicx.sty
(/usr/local/texlive/2008/texmf-dist/tex/latex/graphics/graphics.sty
(/usr/local/texlive/2008/texmf-dist/tex/latex/graphics/trig.sty)
(/usr/local/texlive/2008/texmf/tex/latex/config/graphics.cfg)
(/usr/local/texlive/2008/texmf-dist/tex/latex/graphics/dvips.def)))
(/usr/local/texlive/2008/texmf-dist/tex/latex/psfrag/psfrag.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/amsmath/amsmath.sty
For additional information on amsmath, use the `?' option.
(/usr/local/texlive/2008/texmf-dist/tex/latex/amsmath/amstext.sty
(/usr/local/texlive/2008/texmf-dist/tex/latex/amsmath/amsgen.sty))
(/usr/local/texlive/2008/texmf-dist/tex/latex/amsmath/amsbsy.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/amsmath/amsopn.sty))
(/usr/local/texlive/2008/texmf-dist/tex/latex/amsfonts/amsfonts.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/amsfonts/amssymb.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/graphics/color.sty
(/usr/local/texlive/2008/texmf/tex/latex/config/color.cfg)
(/usr/local/texlive/2008/texmf-dist/tex/latex/graphics/dvipsnam.def))
(/usr/local/texlive/2008/texmf-dist/tex/latex/tools/xspace.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/tools/bm.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/bbm/bbm.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/slashbox/slashbox.sty
slashbox style by K.Yasuoka, May 1993.
) (/usr/local/texlive/2008/texmf-dist/tex/latex/booktabs/booktabs.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/tools/longtable.sty)

Class scrbook Warning: you've loaded package caption2 before package
(scrbook) longtable!
(scrbook) Because of this package caption2 isn't able to control
(scrbook) \caption at longtables. After loading package caption2
(scrbook) KOMA-Script also doesn't control \caption.
(scrbook) I think, you should load package caption after package
(scrbook) longtable and use the new interface on input line 22.

(/usr/local/texlive/2008/texmf-dist/tex/latex/tools/array.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/ltxmisc/url.sty)
(/usr/local/texlive/2008/texmf-dist/tex/latex/nomencl/nomencl.sty)
Writing glossary file NT_Diplomarbeit.glo
(/usr/local/texlive/2008/texmf-dist/tex/latex/ltxmisc/ulem.sty)

Class scrbook Warning: You're using package caption2.
(scrbook) Because of this you should also use \captionstyle
(scrbook) instead of \setcaphang on input line 132.


Class scrbook Warning: `pagehead' and `pagefoot' are aliases for the same
(scrbook) font element, changed on input line 136.

(./NT_Diplomarbeit.aux (./title.aux) (./statement_of_originality.aux)
(./symbols.aux) (./chapter_1.aux) (./bibliography.aux) (./appendix_a.aux))
(./title.tex <bilder/uni_logo.eps> [1]) [2] (./statement_of_originality.tex
(/usr/local/texlive/2008/texmf-dist/tex/latex/ae/t1aess.fd)
Underfull \hbox (badness 10000) in paragraph at lines 4--7

) [3] [4] (./NT_Diplomarbeit.toc
(/usr/local/texlive/2008/texmf-dist/tex/latex/amsfonts/umsa.fd)
(/usr/local/texlive/2008/texmf-dist/tex/latex/amsfonts/umsb.fd)) [1]
(./NT_Diplomarbeit.lof) [2] (./NT_Diplomarbeit.lot) [3] (./symbols.tex)
[4]
! Undefined control sequence.
l.174 \printglossary

?
[5] (./chapter_1.tex
Kapitel 1.
[1] <bilder/beispiel.eps>
Underfull \hbox (badness 10000) in paragraph at lines 54--88

) [2] (./bibliography.tex
(/usr/local/texlive/2008/texmf-dist/tex/latex/ae/t1aett.fd)) [3]
(./appendix_a.tex
Anhang A.
(/usr/local/texlive/2008/texmf-dist/tex/latex/ae/omsaer.fd)) [4]
(./NT_Diplomarbeit.aux (./title.aux) (./statement_of_originality.aux)
(./symbols.aux) (./chapter_1.aux) (./bibliography.aux) (./appendix_a.aux)) )
Output written on NT_Diplomarbeit.dvi (13 pages, 18112 bytes).
Transcript written on NT_Diplomarbeit.log.
### WARNING: TeX returned non zero exit status
### /usr/texbin/dvips -R -Poutline -o /tmp/altpdflatex.458-1233956088/NT_Diplomarbeit.ps NT_Diplomarbeit.dvi
This is dvips(k) 5.97 Copyright 2008 Radical Eye Software (www.radicaleye.com)
' TeX output 2009.02.06:2234' -> /tmp/altpdflatex.458-1233956088/NT_Diplomarbeit.ps
</usr/local/texlive/2008/texmf/dvips/base/tex.pro>
</usr/local/texlive/2008/texmf-dist/dvips/psfrag/psfrag.pro>
</usr/local/texlive/2008/texmf/dvips/base/texps.pro>
</usr/local/texlive/2008/texmf/dvips/base/special.pro>
</usr/local/texlive/2008/texmf/dvips/base/color.pro>.
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmtt12.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmssbx10.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmmi6.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmr8.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmex10.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmsy8.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmmi8.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmcsc10.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmti12.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmsl12.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmr10.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmr12.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmbx12.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmsy10.pfb>
</usr/local/texlive/2008/texmf-dist/fonts/type1/bluesky/cm/cmmi12.pfb>[1
<./bilder/uni_logo.eps>] [2] [3] [4] [1] [2] [3] [4] [5] [1] [2
<./bilder/beispiel.eps>] [3] [4]
### ps2pdf13 /tmp/altpdflatex.458-1233956088/NT_Diplomarbeit.ps /tmp/altpdflatex.458-1233956088/NT_Diplomarbeit.pdf
### Copying/moving pdf file /tmp/altpdflatex.458-1233956088/NT_Diplomarbeit.pdf to NT_Diplomarbeit.pdf
### Succesfully generated NT_Diplomarbeit.dvi and NT_Diplomarbeit.pdf
 

pseudogc

Mitglied
Dabei seit
19.12.2005
Beiträge
704
Punkte Reaktionen
83
geneigte Leser,

mmh, das \printglossary-Problem löst Du am einfachsten durch Einbinden des nomencl-Paketes (\usepackage[compatible]{nomencl}); dann \makeglossary durch \makenomenclature, und \printglossary mit \printnomenclature ersetzen.

Ansonsten den Anregungen folgen: caption2 nach longtable laden; \captionstyle
(scrbook) anstelle von dem von Dir in Zeile 132 verwendeten \setcaphang, usw.

Mit einem aktuellen MikTeX unter Windows rennst Du im übrigen ziemlich sicher in die gleichen Probleme (z.B.: bezüglich glossary, etc.).

cheers,
pseudogc
 

HerrDesChaos

Neues Mitglied
Thread Starter
Dabei seit
06.04.2007
Beiträge
45
Punkte Reaktionen
0
Hm... Danke.
Dann werd ich mein Glück damit mal versuchen.
Für nen LaTex Anfänger irgendwie ärgerlich, wenn er an die Aussage glaubt, dieses File müsse auf jeden Fall laufen. Blicke durch die ganze Materie bisher nur mäßig durch.

Danke schon mal fürs ansehen und die Ratschläge!

Hab irgendwo was von nem falsch eingebundenen nomencl Paket bei TexLive gelesen. Ist das mit 2008 immer noch der Fall? Hoffe ienfach mal nicht...
Was ist der Unterschied zwischen \makenomencl und \makeglossary ? Weiß man das oder ändert man das einfach nur, weil TexShop das sagt und hofft das es zum gewünschten Ergebnis führt?

Mfg,
HDC
 

pseudogc

Mitglied
Dabei seit
19.12.2005
Beiträge
704
Punkte Reaktionen
83
geneigte Leser,

Für nen LaTex Anfänger irgendwie ärgerlich, wenn er an die Aussage glaubt, dieses File müsse auf jeden Fall laufen.

a.) wer das zu Dir sagt, sollte das ja auch irgendwie belegen können ;) b.) die Datei durchläuft ja das Setzen mittels LaTeX, es gibt halt nur ein paar Warnungen, und das Glossar wird nicht angelegt.

Was ist der Unterschied zwischen \makenomencl und \makeglossary ? Weiß man das oder ändert man das einfach nur, weil TexShop das sagt und hofft das es zum gewünschten Ergebnis führt?

Das hat schlicht nichts mit TeXShop zu tun, sondern mit neueren TeX-Distribution (TeXLive/MikTeX) und auf welche Weise das Dokument gesetzt wird. Details zum nomencl-Paket findest Du in der zugehörigen Dokumentation. Neben den Vorschlägen die LaTeX/TeX direkt anbietet, findest Du z.B.: per google auf der Suche nach Antworten zu "Undefined control sequence \printglossary" direkt die Lösung; davon inspieriertes Vorgehen sollte auch für alles Weitere helfen :D Ist also "Wissen"… "Hoffen" bringt einen ohnehin nicht so weit beim Erstellen von z.B.: Dokumenten :hehehe:

Viel Spass beim (La)TeXen, cheers,

pseudogc
 

HerrDesChaos

Neues Mitglied
Thread Starter
Dabei seit
06.04.2007
Beiträge
45
Punkte Reaktionen
0
TexShop schafft mich.
Ich bin offensichtlich zu blöd für LaTeX.

Ich versuch diese Warning zu entfernen. Also die Ursache zu beseitigen:

Package scrkbase Warning: You've used obsolete option `dvips'.
(scrkbase) \KOMAExecuteOptions{pagesize=dvips} will be
(scrkbase) used instead.
(scrkbase) You may simply replace `dvips'
(scrkbase) by `pagesize=dvips' on input line 451.

Der Jump to Line Befehl macht nichts.
Kann man sich im Editor die Linenumbers anzeigen lassen?

Wenn ich nach dem Befehl:
\KOMAExecuteOptions{pagesize=dvips}
Suche finde ich diesen im EditorFenster nicht. Keine Ahnung wo dieser Befehl sein soll.
Ich verstehe das mit der Warning so, dass ich aus
\KOMAExecuteOptions{dvips}
ein
\KOMAExecuteOptions{pagesize=dvips}
machen soll, oder nicht?

Ich bin mal wieder etwas Ratlos.
Kann mir irgendwer auf die Sprünge helfen?

Mfg,
HDC
 

HerrDesChaos

Neues Mitglied
Thread Starter
Dabei seit
06.04.2007
Beiträge
45
Punkte Reaktionen
0
Ich habe noch eine weitere kleine Frage.
Ich bastel ja an dem Tex Dokument rum, damit es ohne Warnings und Fehler sauber getextet wird.

Wie ist das mit Sonderzeichen? Es gibt ja nen Package das ä ö ü ersetzt. Nun ist es ja aber so (oder so hab ich es verstanden), dass ö ä ü unter MacOS und Windows nicht gleich sind.
Die .Tex Datei sollte später aber unter beiden Betriebssystemen problemlos kompiliert werden. Wie bekomm ich das hin?

Bin für jeden kleinen Tip sehr dankbar!

Mfg,
HDC
 

helge42

Mitglied
Dabei seit
12.10.2005
Beiträge
242
Punkte Reaktionen
20
Ich habe noch eine weitere kleine Frage.
Ich bastel ja an dem Tex Dokument rum, damit es ohne Warnings und Fehler sauber getextet wird.

Wie ist das mit Sonderzeichen? Es gibt ja nen Package das ä ö ü ersetzt. Nun ist es ja aber so (oder so hab ich es verstanden), dass ö ä ü unter MacOS und Windows nicht gleich sind.
Die .Tex Datei sollte später aber unter beiden Betriebssystemen problemlos kompiliert werden. Wie bekomm ich das hin?

Du musst eine Text-Kodierung verwenden, die du auf beiden Systemen bearbeiten kannst. Und diese jeweils in der TeX-Datei und in den Editoren einstellen. Eine Möglichkeit ist ISO-8859-1, was ungefähr Windows-ANSI entspricht.

Zu deinen anderen Problemen: Wahrscheinlich hast du in den Optionen der Dokumentklasse dvips verwendet. Das sollte einfach raus.
Ansonsten können wir hier auch nur raten, da wir nicht wissen, wie dein Header aussieht, also welche Optionen und Pakete du verwendest.

Weiterhin solltest du mal eine Anleitung zu LaTeX lesen sowie zu den verwendeten Paketen etc. damit du nicht mehr raten und probieren musst, sondern weisst was du tust.
 

HerrDesChaos

Neues Mitglied
Thread Starter
Dabei seit
06.04.2007
Beiträge
45
Punkte Reaktionen
0
Bin ja dabei mir Sachen durchzulesen.
Die Vorlage verwendet nur relativ viel Zeugs. Da weiß man teils gar nicht wo man anfangen soll.
Aber es wird.
Danke für die Tips.

Mfg,
HDC
 

HerrDesChaos

Neues Mitglied
Thread Starter
Dabei seit
06.04.2007
Beiträge
45
Punkte Reaktionen
0
Servus,

ich hab heute nich mal probiert das Latex Dokument am Mac zu editieren.
Die ä ö ü's welche bereits in der Vorlage waren sind alle zu kommas oder proMill zeichen geworden.
Wenn ich ä ö ü's eingebe, dann passiert wahlweise folgendes:
Mit TexShop Preferences : Encoding Latin1 (was dem oben empfohlenen entspricht), beschwert er sich es gäbe diese Charakters nicht.
"! Package inputenc Error: Keyboard Charakter used is undefined
(inputenc) in inputencoding 'latin1'."

Ich dachte die Preference Einstellung sorgt dafür, das die Zeichen im .tex File nach Latin1 Norm gespeichert sind.
Und der inputenc Befehl im Tex Dokument sorgt dafür, das sie auch als Solche wieder gelesen und getextet werden. Ein ä also ein ä bleibt.
Funktioniert aber so wohl nicht.
Was mache ich falsch?

Und diese Einstellung mit Encoding unter Preferences, ein Äquivalent hab ich bei TexnicCenter bisher nicht gefunden.
Es soll ja letztendlich auf beiden Systemen laufen.

Darüber hinaus, wie beseitige ich sowas?
"Underfull \hbox (badness 10000) in paragraph at lines 54--88"
und
"Class scrbook Warning: `pagehead' and `pagefoot' are aliases for the same
(scrbook) font element, changed on input line 136."
?

Netten Gruß vom verwirrten
HDC
 
Zuletzt bearbeitet:

helge42

Mitglied
Dabei seit
12.10.2005
Beiträge
242
Punkte Reaktionen
20
ich hab heute nich mal probiert das Latex Dokument am Mac zu editieren.
Die ä ö ü's welche bereits in der Vorlage waren sind alle zu kommas oder proMill zeichen geworden.

Wenn ich ä ö ü's eingebe, dann passiert wahlweise folgendes:
Mit TexShop Preferences : Encoding Latin1 (was dem oben empfohlenen entspricht), beschwert er sich es gäbe diese Charakters nicht.
"! Package inputenc Error: Keyboard Charakter used is undefined
(inputenc) in inputencoding 'latin1'."

Ich dachte die Preference Einstellung sorgt dafür, das die Zeichen im .tex File nach Latin1 Norm gespeichert sind.
Und der inputenc Befehl im Tex Dokument sorgt dafür, das sie auch als Solche wieder gelesen und getextet werden. Ein ä also ein ä bleibt.
Funktioniert aber so wohl nicht.
Was mache ich falsch?

Dann ist beim Zwischenspeichern schon was passiert mit der Kodierung.
Nur weil du die Kodierung für den Editor umgestellt hast, werden die vorhandenen Zeichen nicht automatisch umkodiert ...
Welche Option verwendest du bei inputenc in der TeX-Datei?

Also am Besten mal einen einfachen Text schreiben mit der richtigen Kodierung im Editor und als Option beim inputenc, dann setzen und freuen, dass die Zeichen so bleiben wie sie sollen. Anschließend die Vorlage nochmal runterladen, passend speichern, umkodieren, was auch immer, und ebenso verfahren.

Darüber hinaus, wie beseitige ich sowas?
"Underfull \hbox (badness 10000) in paragraph at lines 54--88"
und
"Class scrbook Warning: `pagehead' and `pagefoot' are aliases for the same
(scrbook) font element, changed on input line 136."
?
Ersteres ist ein Umbruch-"fehler", meist verursacht durch einen falschen manuellen Umbruch. Da wird eben eine Zeile nicht so weit gefüllt, wie LaTeX das will.
Zweiteres ist eine Warnung vom KOMA-Script-Paket, welche besagt, dass du sowohl den Font für pagehead als auch für pagefoot definierst, dieses aber das gleiche bewirkt, also eines der beiden überflüssig ist, wie in der Doku zu lesen ist.

Ciao
Helge
 

HerrDesChaos

Neues Mitglied
Thread Starter
Dabei seit
06.04.2007
Beiträge
45
Punkte Reaktionen
0
Servus...

mittlerweile ist das Erstellen Fehlerfrei *Juhu!*
Die Warnings der zu vollen/ zu leeren Textboxen ignoriere ich derzeit einfach.

Ich bin nun aber auf ein Problem beim Einfügen von Bildern gestoßen.
Diverse Anleitungen und Pdfs zu dem Thema hab ich mir angeschaut, konnte mir aber auch mit deren Hilfe nich wirklich erklären warum ich nicht zu meinem gewünschten Ergebnis komme.

1. Ich möchte mit psfrag Text in der .eps Grafik ersetzen. Ich habe mir 2 Grafiken erstellt zum rumprobieren. Die eine (A) hab ich unter Windows mit DIA erstellt und als eps exportiert. Die zweite (B) hab ich mit OmniGraffle erstellt und als eps exportiert.
Nun funktioniert das ersetzen in Grafik A einwadnfrei, aber in Grafik B ersetzt er nichts. Die Grafiken sind völlig identisch eingbunden. Muß der zu ersetzende Text irgendwelchen Anforderungen entsprechen die beim Standard Text unter DIA erfüllt sind, bei OmniGraffle aber nicht?
Oder exportiert mir OmniGraffle unsaubere eps Files?

Ich würde gern mit OmniGraffle arbeiten, weils nen nettes Programm ist, aber ich muß Texte mit psfrag ersetzen können.

2. Ich möchte die Grafik mittels
\begin {figure}[h]
positionieren. Mit h als Zusatz, sollte die Grafik ja "here", also an der Stelle wo ich sie im .tex Dokument einfüge, im Pdf auftauchen. Tut sie aber nicht immer.

Folgende Pakete werden eingefügt:

usepackage{graphicx,psfrag}

Genau lautet mein Einfügen:

\begin{figure}[h]
\begin{center}
\resizebox{\textwidth}{!}
{
\psfrag{A}[][c]{Guten Tag}
\psfrag{Ab}[][c]{Werbung}
\includegraphics{bilder/Bild}
}
\end{center}
\caption{Bildunterschrift}
\label{UniqueLable}
\end{figure}

Ohne die Zeile \resizebox{\textwidth}{!} funktionert dies einwadnfrei. Mit dieser Zeile jedoch nicht. Dann bekomme ich folgenden Fehler:
LaTeX Warning: `h' float specifier changed to `ht'
Das Bild erscheint auf der nachfolgenden Seite und nicht an der Stelle im Text wo es sein soll.

Was mich wundert ist, das genau dieses Einfügen im Beispiel Kapitel (die Kapitel sind mit include eingefügt) jedoch fuktionert. Nur der Bildname und die psfrag Tags wurden ersetzt. Kann mir das nicht erklären.

Gruß,
HDC
 
Oben Unten