Langer Bootvorgang MBP 2013 Retina mit Samsung 970 Evo

chaijen

Neues Mitglied
Thread Starter
Mitglied seit
17.11.2018
Beiträge
25
Ich habe die M2 SSD meines 2013 MBP (i5,8GB , ) gegen eine Samsung 970 Evo getauscht.Habe die alte SSD auf eine externe Platte geklont, dann ssd umgebaut, von der ext Platte gebootet und mit CarbonCC den klon auf die neue ssd gespielt.
Performance und Read Write sind ok. Hatte zuerst Catalina probiert, da aber die Peformance schwach war und der Lüfter dauernd anging bin ich wieder zu High Sierra zurueck.
Mein Problem:
der Bootvorgang geht sehr lange.
Es dauert locker 20 Sekunden bis ueberhaupt der Apfel erscheint.
Erfolglose durchgefuehrte Massnahmen:
-Startvolume neu definiert
-Trim enabled
-PVR Ram Reset
-sudo pmset standby 0
Der Startvorgang bleibt unveraendert lang. Bin schon am ueberlegen wieder zur Apple M2 SSD zurueckzugehen.

Irgendwelche Tips (ausser meiner bereits durchgefuehrten Massnahmen )um den Bootvorgang zu beschleunigen?
 

Macschrauber

Aktives Mitglied
Mitglied seit
08.02.2014
Beiträge
6.752
Nvme in guid formatiert?
Startvolume überprüfen, das ist nach nvram reset wieder weg.

Für die Wissenschaft auch drei mal unmittelbar in Folge einen nvram reset machen, beim Mac Pro löscht das tiefer und setzt Hardwaredaten zurück.

Vielleicht hilfts, Schaden tuts nicht:)
 

OmarDLittle

Aktives Mitglied
Mitglied seit
21.05.2017
Beiträge
1.967
Sicher dass es an der SSD liegt? Halte mal beim Einschalten die Alt-Taste gedrückt, um zur Bootauswahl zu kommen. Das wird vermutlich auch schon so lange dauern, oder? Das haben ältere Macs manchmal, diese lange Denkpause beim Einschalten - Lösung ist mir keine bekannt. Doof gesagt würde ich das Ding einfach hauptsächlich in den Schlafmodus schicken, wie oft musst du es denn wirklich komplett ausschalten?
 

chaijen

Neues Mitglied
Thread Starter
Mitglied seit
17.11.2018
Beiträge
25
Naja mit der eigenen SSD des Macbooks passiert das nicht..
 

dg2rbf

Aktives Mitglied
Mitglied seit
08.05.2010
Beiträge
6.994
Hi,
dann hat der Adapter einen Macke, ich nehme nur die langen Adaper her, die kurzen machen viel zu oft Probleme.
Franz
 

dg2rbf

Aktives Mitglied
Mitglied seit
08.05.2010
Beiträge
6.994
Hi,
wenn NVME SSD, dann in dieser Ausführung, wenn du einen kurzen Adapter verbaut hast, dann diesen Umtauschen.
Franz
 

thorstenhirsch

Mitglied
Mitglied seit
17.03.2015
Beiträge
793
Probier's mal noch mit dieser Einstellung:
sudo nvram enable-legacy-orom-behavior=1
edit: Probier's lieber doch nicht. Ich hab' gerade gesehen, dass diese Einstellung bei mir verschwunden ist (ich hatte sie mal vor langer Zeit gesetzt) und jetzt kann ich gar nicht mehr booten. o_O Hach... was muss ich auch immer so viel ausprobieren...
 
Zuletzt bearbeitet:

Macschrauber

Aktives Mitglied
Mitglied seit
08.02.2014
Beiträge
6.752
Nvme ist eine andere Technik wie die Ahci der Original Platte. Theoretisch wird die als letzte in der Bootreihenfolge berücksichtigt.

Firmware ist aktuell? Wurde einiges in Richtung nvme getan.
 
  • Gefällt mir
Reaktionen: chaijen

OmarDLittle

Aktives Mitglied
Mitglied seit
21.05.2017
Beiträge
1.967
Die Adapter sollten alle passiv sein, also nur die Position der Pins verändern. Daher sollte die Adapterwahl in dieser Hinsicht keine Rolle spielen. Wohl aber haben manche ein Problem, dass Pins tw. freiliegen und in Kontakt mit etwas kommen können, sodass es zu einem Kurzschluss kommen kann.
 

OmarDLittle

Aktives Mitglied
Mitglied seit
21.05.2017
Beiträge
1.967
Nochmal, warum schaltest du das Gerät einfach nicht aus? Natürlich keine Lösung in dem Sinne, eher ein Workaround, aber wenn die Performance sonst passt...

Es gibt bei den insanelymac-Foren übrigens einen Sammelthread zu NVMe-SSD-Erweiterungen bei den MBPs, schau dir den mal an. Es gibt durchaus Einschränkungen bei älteren Geräten (zB was Standby/Sleep betrifft) und auch Hinweise zur Kompatibilität, gerade bei Samsung sind nicht alle SSDs kompatibel. Und komplett ohne Einschränkung laufen die SSDs ausschließlich beim Early-2015-MBP. Das kann ich mehr oder weniger bestätigen, da ich selbst zwei davon mit Adapter nutze. Früher sind beide Geräte ab und zu mit einer kernelpanic abgestürzt, die sich direkt auf die SSD zurückführen ließ. Mit Mojave/Catalina hat das aber aufgehört, d.h. da ist wirklich alles einwandfrei.

Vielleicht findest du dort im Forum einen Hinweis.
 
  • Gefällt mir
Reaktionen: chaijen und dg2rbf

chaijen

Neues Mitglied
Thread Starter
Mitglied seit
17.11.2018
Beiträge
25
Danke also das https://eclecticlight.co/lockrattler-systhist/ hat wohl doch was gebracht. Erst hat es nur einen Sicherheitspatch gemeldet. Aber gestern hatt das MBP bei einem Neustart fast 30min installiert. im moment dauerts noch ca 10 sekunden bis der Apfel kommt. Damit kann ich leben. Vielen Dank fuer eure Hilfe!
 

mausfang

Aktives Mitglied
Mitglied seit
04.08.2016
Beiträge
1.849
Gerne mal gemachter Fehler ...

Explizit den neuen Datenträger als Startvolume auswählen ...
Sonst dauert es lange, bis der Apfel erscheint.
 
Oben