Benutzerdefinierte Suche

Kleines problem mit MS Excel unter Win

  1. Bart Beckett

    Bart Beckett Thread StarterMacUser Mitglied

    Mitglied seit:
    22.11.2004
    Beiträge:
    390
    Zustimmungen:
    0
    Ich hoffe ich werde nicht dafür gesteinigt hier eine solche frage zu posten aber ich hoffe dass mir hier dennoch jemand schnell helfen kann.


    Ich habe eine liste mit produkten und eine spalte ist auschlaggebend für den rabatt. Nun sind das immer buchstabenkombinationen wie "BC", "BA" und ähnliches. Ich habe mmir nun gedacht einfach eine nette =wenn zeile schreiben und das haut schon hin. Denkste.

    Hier mal einer meiner versuche: (zur ergänzung: in C9 steht der preis und in D9 der rabattcode, der die höhe des rabatts bestimmt)

    Ich habe zuerst probiert gehabt statt dem "PRODUKT(C9*0,8)" einfach nur "C9*0,8" zzu schreiben, ging aber genauso wenig.

    Das problem ist, dass er nichts ausrechnet sondern immer nur "FALSCH" hinschreibt. knn natürlich sein dass ich einen falschen befehl verwende da ich so gut wie nie mit Excel arbeite aber mit dem runden hat das mit einem verschachtelten "WENN" befehl auch wunderbar geklappt.

    Bitte hilfe, ich möchte bei dem ca 800 zeilen langen file nicht jede zeile extra eingeben, ausserdem ist da dann auch die gefahr von fehlern höher.
     
    Bart Beckett, 04.07.2005
  2. HäckMäc_2

    HäckMäc_2MacUser Mitglied

    Mitglied seit:
    26.04.2005
    Beiträge:
    4.208
    Zustimmungen:
    288
    Das Ergebnis "FALSCH" kommt nur, wenn keiner der genannten Rabattcodes zutrifft. Es fehlt der letzte "else"-Teil.

    =WENN(D9="BA";C9*0,8;WENN(D9="DA";C9*0,8;WENN(D9="BC";C9*0,7;WENN(D9="GC";C9*0,7;C9))))
     
    HäckMäc_2, 04.07.2005
  3. mackay

    mackayMacUser Mitglied

    Mitglied seit:
    05.01.2003
    Beiträge:
    2.435
    Zustimmungen:
    7
    kannst du mir bitte kurz erklären was deine Buchstabenkombinationen für eine Bedeutung haben?
    Nur so zum besseren Verständnis.

    Kay ;)
     
    mackay, 04.07.2005
  4. romi0815

    romi0815MacUser Mitglied

    Mitglied seit:
    02.11.2004
    Beiträge:
    809
    Zustimmungen:
    43
    FALSCH erscheint immer dann, wenn keines der kürzel in den Feldern steht. Gibst du ein Rabatt-kürzel ein, so erscheint auch der richtige Betrag.

    Du solltest noch ein WENN mit "keinem Rabatt" eingeben. Das sollte helfen.

    Gruß,
    romano
     
    romi0815, 04.07.2005
  5. Mac Donath

    Mac DonathMacUser Mitglied

    Mitglied seit:
    21.06.2005
    Beiträge:
    42
    Zustimmungen:
    0
    grüß dich,

    denke das problem ist einfach nur das Produkt. drumm Das kannst du nämlich weg lassen. C3 musste halt durch c9 ersetzten. ;-)

    =WENN(C3="BA";(B3*0,8);WENN(C3="DA";(B3*0,8);WENN(C3="BC";(B3*0,7);WENN(C3="GC";(B3*0,7)))))


    ;)
     
    Mac Donath, 04.07.2005
  6. Bart Beckett

    Bart Beckett Thread StarterMacUser Mitglied

    Mitglied seit:
    22.11.2004
    Beiträge:
    390
    Zustimmungen:
    0
    Danke einmal für die schnelle hilfe.

    Was die rabattcaodes ganue bedeuten weiss ich leider auch nicht. Ich weiss nur für welchen prozentsatz sie stehen (ausserdem helfe ich auch nur aus da bei einem computer crash vieles verlorengegangen ist und halt neu eingetragen werden muss).

    Habe jetzt den ansatz von HäckMäc probiert mit dem resultat dass er mir nur den wert von C9 hinschreibt. In der D spalte stehen aber diese buchstabenkombinationen drinnen, und sonst nichts, keine formel oder ähnliches. Kann es sein dass ich das "=" durch etwas anderes ersetzen muss? kopfkratz
     
    Bart Beckett, 04.07.2005
  7. HäckMäc_2

    HäckMäc_2MacUser Mitglied

    Mitglied seit:
    26.04.2005
    Beiträge:
    4.208
    Zustimmungen:
    288
    Klar, kein Rabattcode, kein Rabatt.
    Oder?


    Gibts vielleicht Probleme mit der Groß- bzw. Kleinschreibung? Dann müsste noch "Gross" ergänzt werden:
    =WENN(GROSS(D9)="BA";C9*0,8;WENN(GROSS(D9)="DA";C9*0,8;WENN(GROSS(D9)="BC";C9*0,7;WENN(GROSS(D9)="GC";C9*0,7;C9))))
     
    HäckMäc_2, 04.07.2005
  8. Mac Donath

    Mac DonathMacUser Mitglied

    Mitglied seit:
    21.06.2005
    Beiträge:
    42
    Zustimmungen:
    0
    nee groß klein dürfte eigentlich kein problem sein

    =WENN(D9="BA";(C9*0,8);WENN(D9="DA";(C9*0,8);WENN(D9="BC";(C9*0,7);WENN(D9="GC";(C9*0,7)))))
     
    Mac Donath, 04.07.2005
  9. Jabba

    JabbaMacUser Mitglied

    Mitglied seit:
    21.11.2003
    Beiträge:
    4.458
    Zustimmungen:
    109
    Hallo Ihr Excelprofis... :p
    =WENN(ODER(D9="BA";D9="DA");C9*0,8;WENN(ODER(D9="BC";D9="GC");C9*0,7;""))

    So ist die Formel erstmal etwas übersichtlicher.
    Wie HäckMäc schon richtig sagt, musst Du entscheiden, was passiert, wenn kein Code zutrifft... das geschieht zwischen den letzten beiden Anführungszeichen. In meiner Formel passiert einfach nichts... Du könntest aber auch einen weiteren Faktor eingeben, 0,6 wäre hier logisch. (C9*0,6)
    D.h. wenn alle vorgegebenen Codes nicht zutreffen, dann wird halt 0,6 genommen.

    Eine sverweis-Formel wäre hier natürlich wesentlich eleganter, zumal übersichtlicher und weiter ausbaubar, wenn noch ein paar Codes hinzukommen sollten.

    ps: Grossklein = egal
    HTH
     
    Jabba, 04.07.2005
  10. HäckMäc_2

    HäckMäc_2MacUser Mitglied

    Mitglied seit:
    26.04.2005
    Beiträge:
    4.208
    Zustimmungen:
    288
    Ich meinte eigentlich die Zelle D9.
    "BA" <> "ba", aber
    "BA" = Gross("ba")
     
    HäckMäc_2, 04.07.2005
Die Seite wird geladen...
Ähnliche Themen - Kleines problem Excel
  1. falkgottschalk
    Antworten:
    29
    Aufrufe:
    9.181
    falkgottschalk
    04.04.2013
  2. DoubleP
    Antworten:
    1
    Aufrufe:
    561
  3. Rettrambo112
    Antworten:
    12
    Aufrufe:
    8.872
  4. joachimschwante
    Antworten:
    1
    Aufrufe:
    404
  5. j-man
    Antworten:
    19
    Aufrufe:
    1.135
Benutzerdefinierte Suche