Kein Zugriff auf Windows Drucker

  1. andybauer

    andybauer Thread Starter MacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    44
    Zustimmungen:
    0
    Hi,

    auf dem Windows PC (XP) ist der Drucker freigeben. Vom Powerbook aus sehe ich den Drucker auch, jedoch wenn ich im Druckerdienstprogramm beim Hinzufügen, den Computer auswähle, will er einen Benutzernamen und Passwort von mir. Wenn ich da irend was hineinschreibe, bekomme ich eine Fehlermeldung, dass der Zugriff mit diesem Passwort und Benutzernamen nicht möglich sei.
    Wenn ich mit selbigem Benutzername und Passwort aber auf ein Freigegebenes Verzeichnis zugreifen will, funktioniert es. Unter smbutil sehe ich mit dem selben Benutzernamen und Passwort sogar den freigegebenen Drucker.
    Auf dem Windows Computer ist der Drucker einfach freigegeben. Ich konnte da nirgends ein Passwort oder Benutzer einstellen.
    Mein Powerbook und der PC sind in der selben Benutzergruppe. Habe auch schon probiert die zu ändern/den Namen des PCs geändert
    Kann mir jemand bei meinem Problem helfen? Das ganze hat auch schon mal funktioniert.

    Danke
     
  2. ricci007

    ricci007 MacUser Mitglied

    Mitglied seit:
    11.10.2004
    Beiträge:
    2.478
    Zustimmungen:
    13
    Richte unter XP genau den selben User mit genau dem selben Passwort wie unter Mac OS X ein, dann sollte es gehen.

    Viel Spasz.
     
  3. andybauer

    andybauer Thread Starter MacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    44
    Zustimmungen:
    0
    hat leider nicht funktioniert. Bekomme noch immer die Fehlermeldung Verbindung zum Server ist mit angegebene Benutzernamen und Kennwort nicht möglich. Fehler256" Wenn ich mit smbutil view mir anzeigen lasse, was auf dem PC freigegeben ist, wird der Drucker ja angezeigt, egal welches Kennwort und Benutzername ich verwende.
     
  4. ricci007

    ricci007 MacUser Mitglied

    Mitglied seit:
    11.10.2004
    Beiträge:
    2.478
    Zustimmungen:
    13
    very strange. keine ahnung, bin ich etz auch ueberfragt!?!?!? sorry!
     
  5. elastico

    elastico MacUser Mitglied

    Mitglied seit:
    25.08.2004
    Beiträge:
    5.050
    Zustimmungen:
    77
    Groß/Kleinschreibung bei User und Passwort beachtet?
    Unter XP in der Freigabe den User hinzugefügt?
     
  6. ricci007

    ricci007 MacUser Mitglied

    Mitglied seit:
    11.10.2004
    Beiträge:
    2.478
    Zustimmungen:
    13
    :D dau-frage :D
     
  7. andybauer

    andybauer Thread Starter MacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    44
    Zustimmungen:
    0
    das hat auch schon mal mit beliebigem Benutzernamen funktioniert. Selbst wenn ich das Powerbook auswähle, bekomme ich die gleiche Fehlermeldung, obwohl ich mein Mac OS Passwort und Benutzername richtig geschrieben habe.
     
  8. roenz

    roenz MacUser Mitglied

    Mitglied seit:
    04.11.2003
    Beiträge:
    85
    Zustimmungen:
    1
    Probier doch mal den "Umweg" via CUPS:

    - im Web Browser CUPS aufrufen: http://localhost:631
    - unter "Do Administration Tasks" "Add Printer" auswählen
    - Printer Namen angeben => erscheint dann im PrintCenter (keine Leer- und Sonderzeichen verwenden!)
    - unter "Device" "Windows Printer via SAMBA" auswählen
    - Device URL angeben: Synthax => "smb://Workgroup;Username:passwort@Windows-Rechner/Druckerfreigabename"
    - Druckermodell auswählen (Tipp: Die Auswahlliste wird mit "Gimp-Print" um ca. 400 weitere Modelle erweitert)
    - ab jetzt steht der Drucker im MacOS X PrintCenter zur Verfügung

    Sollte auch das nicht klappen, so scheint ev. irgendwo im WinXP Bereich der "Wurm" in den Berechtigungen zu liegen.

    Unter WinXP kannst Du nicht für eine Druckerfreigabe spezielle/separate UserID's/Pw's vergeben. WinXP verwendet hierfür die lokale Benutzer Datenbank. Man kann einzig User od. Gruppen aus der WinXP Benutzer Datenbank den Zugriff auf einen Drucker gewähren resp. verweigern.

    Gruss
    Roenz
     
  9. MacChico

    MacChico MacUser Mitglied

    Mitglied seit:
    08.02.2005
    Beiträge:
    317
    Zustimmungen:
    74
    Ich hab' ein ähnliches Problem.

    Notebook mit WIN XP SP2 und Canon iPX 4000
    iMAC mit OS X 10.3.8

    Drucker hinzufügen >> Windows-Drucker >> MSHeimnetz >> Notebook: Drucker wird erkannt.

    Wenn ich jetzt vom MAC etwas ausdrucken will, wird der Drucker auch gestartet, obwohl er nicht 'mal eingeschaltet ist - aber es "kommt nichts an". Keine Fehlermeldung o.ä. - nichts.

    Was mir nicht einleuchtet: Anmeldung am NB bzw. MAC funktioniert, Datenaustausch in beide Richtungen klappt auch, aber so etwas profanes wie die beiderseitige Nutzung des Druckers klappt (immer) noch nicht ...

    Dies ist ja (für mich) kein neues Problem, darüber ärgere ich mich schon seit dem Kauf des iMAC's, aber als ich in der letzten Woche OS X neu installiert habe und dann bei der Druckereinrichtung gleich das "Erfolgserlebnis" hatte, hoffte ich, daß das leidige Problem endlich gelöst wäre - leider nicht.

    Die Versuche mit "Gimps" und "Cups" hab' ich erst gar nicht probiert, das hat schon früher nicht geklappt ...

    Für hilfreiche Tipps im voraus dankend grüßt
    MacChico

    PS: Wenn der Drucker am iMAC angeschlossen ist, passiert vom NB genau das Gleiche: Drucker wird erkannt, Druckauftrag wird gestartet, aber auch hier "kommt nichts an" ...
     
  10. andybauer

    andybauer Thread Starter MacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    44
    Zustimmungen:
    0
    @Rorenz: hab ich so gemacht. Jetzt bekomme ich aber, wenn ich etwas drucken will NT_STATUS_BAD_DEVICE_TYPE als Fehler. Weiß jemand was das zu bedeuten hat?
     
Die Seite wird geladen...