Kein Login möglich

thobie

thobie

Mitglied
Thread Starter
Dabei seit
23.04.2006
Beiträge
636
Punkte Reaktionen
111
(…) Das Frontend ist mittlerweile ja auch vom 500 error betroffen.
Das hing an der htaccess, die ich auf Deinen Rat im ursprünglichen Zustand von WordPress eingesetzt hatte. Ich habe wieder die alte htaccess eingerichtet, jetzt läuft zumindest das Frontend und vom Kunden kann keine Kritik kommen.
Gute und sinnvolle Idee.
Ja, die Webserver-Logfiles sollten ab morgen aktiv sein.
Wenn du den Anmeldebereich (wp-login.php) von Wordpress schützen willst, dann mache dies lieber über htaccess und htpasswd.
https://www.df.eu/blog/htaccess-passwortschutz-und-zugangsbeschraenkung-fuer-webseiten/
Das habe ich auch so eingerichtet, mich wundert aber auch, warum das nicht beim Login aktiv ist und die Abfrage von Benutzername und Passwort über htaccess erfolgt.
 
thobie

thobie

Mitglied
Thread Starter
Dabei seit
23.04.2006
Beiträge
636
Punkte Reaktionen
111
Kurzes Status-Update:
Die Logfiles sind nicht, wie der Hoster angibt, auf dem Webspace der Domain zu finden. Ich habe dem Support des Hosters eine Anfrage geschickt, wo ich die Logfiles finden kann.
 
thobie

thobie

Mitglied
Thread Starter
Dabei seit
23.04.2006
Beiträge
636
Punkte Reaktionen
111
Das Problem ist gelöst.

Der Techniker des Hosters hat mir geantwortet und gleich die Lösung mitgeliefert.

In der .htaccess-Datei stand ein Befehl drin, der mir merkwürdigerweise auch unbekannt und anscheinend ungültig war. Das Logfile lieferte folgende Fehlermeldung:

/xyz/xyz/hv-management/wp-admin/.htaccess: Invalid command 'AuthPGAuthoritative', perhaps misspelled or defined by a module not included in the server configuration.

In der .htaccess-Datei stand tasächlich der Befehl „AuthPGAuthoritative off“. Nachdem ich ihn gelöscht hatte, ist das Login, auch wieder mit dem bekannten WP-Login, möglich.
 
Difool

Difool

Frontend Admin
Dabei seit
18.03.2004
Beiträge
17.117
Punkte Reaktionen
12.581
Dann war mal irgendwann eine .htpasswd angelegt worden und "AuthPGAuthoritative off" weißt darauf hin,
dass die Authortative halt "off" ist/war und es zwingend "valid-user" bedarf.
Deswegen dann der 500 Server-Error.

Erwartet hat der Server z.B. folgendes:
Code:
# .htaccess-Datei für Passwortschutz
AuthType Basic
AuthName "Geschützter Bereich - Bitte geben Sie ein Passwort ein!"
AuthUserFile /Individueller/Pfad/.htpasswd
Require valid-user

edit:
Aber sagtest du nicht, dass du zwischenzeitlich mal die .htaccess mit der Wordpress-Standard .htaccess ersetzt hattest?
Dann wäre dieser Fehler ja nicht mehr vorhanden gewesen.
 
thobie

thobie

Mitglied
Thread Starter
Dabei seit
23.04.2006
Beiträge
636
Punkte Reaktionen
111
DomainFacfory hat eine andere Vorgehensweise für htaccess-Dateien als andere Hoster.

Bei diesem Hoster muss zwingend eine htaccess-Datei in den wp-admin-Ordner und in das root-Verzeichnis.

Ich hatte nur die htaccess-Datei im root-Verzeichnis durch die originäre Datei ersetzt, nicht die Datei im wp-admin-Ordner.
 

Ähnliche Themen

Oben