JavaScript funktioniert nicht mit Mozilla/Firefox

  1. tate

    tate Thread StarterMacUser Mitglied

    Mitglied seit:
    27.01.2004
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo!

    Auf einer Kunden-Website habe ich dessen Navigation mithilfe von Javascript umgesetzt. Das funktioniert bei Safari und IE auch ganz hervorragend, aber leider so gar nicht bei Mozilla und Firefox. Wenn man dort mit der Mouse über die Buttons fährt, bleiben die aktiven (Mouse-On) Versionen sichtbar. Also wenn man dort ein bischen rumspielt, sind am ende fast alle Butoons aktiv :-( Und das ist nur auf den Folgeseiten so, die Startseite funktioniert wie es sein soll.

    Kann mir jemand verraten was ich falsch gemacht habe?

    Lieber Gruss von Tate
     
    tate, 28.02.2005
  2. tate

    tate Thread StarterMacUser Mitglied

    Mitglied seit:
    27.01.2004
    Beiträge:
    6
    Zustimmungen:
    0
    nochmal nachgedacht...

    könnte es eventuell daran liegen, das ich auf der jeweiligen seite den aktiven button nicht mehr als link einsetze, sondern ihn mit einem L vor dem HREF praktsiche still lege?

    ------------------------------------
    <A HREF="partner.html"
    onMouseOver="toggle_image('partner','on'); return true"
    onMouseOut="toggle_image('partner','off'); return true"><IMG
    SRC="Icons/nav_partner.gif" ALT="Partner" NAME="partner"
    WIDTH="123" HEIGHT="22" BORDER="0"></A><BR>
    <L HREF="referenzen.html"
    onMouseOver="toggle_image('referenzen','on'); return true"
    onMouseOut="toggle_image('referenzen','off'); return true"><IMG
    SRC="Icons/nav_referenzen_on.gif" ALT="Referenzen" NAME="referenzen"
    WIDTH="123" HEIGHT="22" BORDER="0"></A><BR>
     
    tate, 28.02.2005
Die Seite wird geladen...