Java 5 (NUR für Tiger)

  1. Badener

    Badener Thread Starter

    Auf der Apple HP steht Java 5 zum Download bereit.

    Allerdings nur ab Tiger aufwärts.

    Klasse - jetzt muß ich für etwas, das jede Dose kann, bei Apple ein neues OS kaufen? Wenn die so weitermachen, switche ich echt wieder zu Windows zurück....

    Daß kann es ja wohl wirklich nicht sein.....
     
    Badener, 30.04.2005
  2. RETRAX

    RETRAX Thread Starter

    Mal an die Fachleute gefragt.

    Muss ich das als normaler Anwender installieren? Bringt mir das irgendwelche Vorteile im Web?

    In der Software-Aktualisierung ist es nämlich nicht zu laden.


    Gruss

    Retrax
     
    RETRAX, 30.04.2005
  3. admartinator

    admartinatorMacUser Mitglied

    Mitglied seit:
    09.09.2003
    Beiträge:
    15.283
    Zustimmungen:
    290
    Stimmt. Es muss das heißen... ;)
     
    admartinator, 30.04.2005
  4. Badener

    Badener Thread Starter

    @admartinator: Nach alter Rechtschreibreform aber nicht... und an die Neue halte ich mich nicht - bin da zu blöd für

    @retrax: Java 5 ist tatsächlich Leistungsfähiger und in einigen Bereichen einfacher zu proggen als Java 1.4.
    Beispiele:
    - Einlesen von Tastatur
    - java.lang.StringBuilder vs. java.lang.StringBuffer
    - Traversierung der Elementen in einer Schleife
    usw.

    Bei uns an der FH ist das Softwareentwicklungsskript für Java5 geschrieben, d.h. wenn ich mit 1.4 angehumpelt komme, muß ich teilweise erst mühsam recherchieren, wie es mit 1.4 geht.... Mich nervt das. Jede Dose hat seit "Ewigkeiten" Java5 zur Verfügung, Linux auch.... Nur die Macs mal wieder nicht!

    Für normale Java-Applets im Internet glaube ich nicht, daß man da unbedingt Java5 braucht... Aber die Zeit wird kommen.....
     
    Badener, 30.04.2005
  5. Sym

    SymMacUser Mitglied

    Mitglied seit:
    11.06.2003
    Beiträge:
    1.899
    Zustimmungen:
    38
    Für JavaWeb-Anwendungen wirst Du es eher nicht benötigen. Es kommt darauf an, was für sontige Software Du verwendest, aber meist ist Java5-Software noch sehr exotisch.
    Ich empfinde es als Unding, dass Apple es für Panther nicht zur Verfügung stellt. Java5 ist nun wirklich lang genug draussen.
     
  6. Sym

    SymMacUser Mitglied

    Mitglied seit:
    11.06.2003
    Beiträge:
    1.899
    Zustimmungen:
    38
    Na das halte ich aber für ein Gerücht. Oder über was für ein Alter sprichst Du hier?
     
  7. Badener

    Badener Thread Starter

    @Sym:

    Laßt uns hier nicht über meine Rechtschreibung diskutieren, sondern über Java und Apple.

    Sonst fange ich auch mal an, hier Artikel zu korrigieren..... was meint Ihr, wie schnell dann das Board voll ist!

    Außerdem bin ich grad viel zu sehr angekotzt von Apple und Java, als daß ich mir da einen Kopf drum mache.....
     
    Badener, 30.04.2005
  8. Sym

    SymMacUser Mitglied

    Mitglied seit:
    11.06.2003
    Beiträge:
    1.899
    Zustimmungen:
    38
    Sorry, aber diese Vorlage war einfach zu gut. ;)

    Deinen Ärger kann ich aber nachvollziehen. Mir geht es da ähnlich. Langsam sollte Apple genug Zeit zur Portierung gehabt haben!
     
  9. RETRAX

    RETRAX Thread Starter

    ad qualifiziert sich mal wieder als MacUser Guru mit hochqualifizierten Kommentaren.

    Setzen! Sechs.


    Gruss

    Retrax
     
    RETRAX, 30.04.2005
  10. wegus

    wegusMacUser Mitglied

    Mitglied seit:
    13.09.2004
    Beiträge:
    14.982
    Zustimmungen:
    1.545
    Badener:
    Danke! Mir reicht schon die Syntaxpingeligkeit so manchen Compilers! Wie schön, daß unsereins da flexibler ist ;) back to content!
     
    wegus, 30.04.2005
Die Seite wird geladen...