Java 1.4.2 für Mac OS 9.2

  1. Rotzbuab

    Rotzbuab Thread StarterMacUser Mitglied

    Mitglied seit:
    15.09.2004
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo zusammen,

    gleich vornweg ich habe keine Ahnung von Mac, ausser das die Windows-taste Apfeltaste heißt ;)

    Wir haben bei einem Kunden das Problem, dass wir für eine Software einen Browser mit Java 1.4.2 benötigen. Auf dem Rechner ist Mac OS 9.2 installiert, nun haben wir das Problem, dass wir dieses Java nur finden für Version 10.x.

    Gibt es eine Möglichkeit auf Mac OS 9.2 das Java 1.4.2 zum laufen zu kriegen ?

    Bedanke mich im vorraus für eure Mühe

    Lars
     
    Rotzbuab, 15.09.2004
  2. snax

    snaxMacUser Mitglied

    Mitglied seit:
    25.01.2004
    Beiträge:
    93
    Zustimmungen:
    0
    mal noch eine grundsätzliche Frage, benötigt ihr das JRE (Java Runtime Environment) oder das JSDK (Java Software Developer Kit)..

    hmm habe gerade noch etwas nachgeforscht hier (Frage 5) steht leider nicht viel ermutigendes..

    die letzte Verfügbare Version für OS 9 war anscheinend 1.1.8.. und die Herausgabe neuerer Version für 9.x ist leider auch nicht geplant!

    für was braucht ihr denn unbedingt die version 1.4.2?

    >der snax
     
    snax, 15.09.2004
  3. Rotzbuab

    Rotzbuab Thread StarterMacUser Mitglied

    Mitglied seit:
    15.09.2004
    Beiträge:
    3
    Zustimmungen:
    0
    Denke mal das JRE ist es was wir benötigen.
    Also momentan läuft auf dem Mac das Java 1.4.1, haben wir auch über das automatische Update von Mac bekommen.
    Java 1.4.2 benötigen wir für eine CTI Software zum ansteuern der Telefone. Diese Software läuft über den Browser aber leider nur ab Java 1.4.2 :( Die Datei die geöffnet wird, ist eine .jnlp - Datei, diese wird bei Java 1.4.1 als unbekannt "ignoriert"
     
    Rotzbuab, 15.09.2004
  4. snax

    snaxMacUser Mitglied

    Mitglied seit:
    25.01.2004
    Beiträge:
    93
    Zustimmungen:
    0
    so mal ein bisschen nachgeforscht.. aaalso 1.4.x gibt es definitiv nicht für ältere Systeme als OS X, auf der Suche danach bin ich aber auf eine VM gestossen die auch auf OS 9 lauffähig sein sollte, das ganze nennt sich MRJ (Mac OS Runtime for Java) und ist in der "aktuellen" Version 2.2.6 verfügbar die Anfangs 2003 geupdatet wurde..

    wenn du Glück hast läuft das ganze dann mit dem Applet im Browser dass ihr benötigt.. (btw: was für einen Browser benutzt ihr unter OS 9 um auf das Applet zuzugreifen?) Denn der Browser sollte die Version 2.2.6 MRJ als Java Umgebung erkennen und dann diese verwenden.. dass sind mal ein paar wenige shortnews die ich herausgefunden habe!

    probier es einfach einmal aus und berichte uns von einem Erfolg, oder wenns sein muss auch von einem Nichterfolg :D

    good luck
    >der snax
     
    snax, 15.09.2004
  5. Rotzbuab

    Rotzbuab Thread StarterMacUser Mitglied

    Mitglied seit:
    15.09.2004
    Beiträge:
    3
    Zustimmungen:
    0
    Hi Snax,
    auf dem Kundenrechner läuft IE 5.0. Aber wenn ein anderer Browser besser geeignet ist, habe ich kein Problem damit dem Kunden das zu sagen ;)
    Hauptsache unsere Software läuft.
    Bedanke mich erstmal für deine Mühe, wir werden das ganze mal am Freitag testen und werde Erfolge bzw. Misserfolge melden.

    schönen abend noch
     
    Rotzbuab, 15.09.2004
  6. cilly

    cilly

    Java und OS 9 ist etwas, was sich schlecht unter einen Hut bekommen lässt. Java ist in OS 9 so schlecht und fehlerhaft implementiert, dass ich davon abrate.

    Meine Empfehlung: OS X installieren, da ist Java 1.4.2 dabei.

    carro cumber banana pepp
     
    cilly, 15.09.2004
  7. snax

    snaxMacUser Mitglied

    Mitglied seit:
    25.01.2004
    Beiträge:
    93
    Zustimmungen:
    0
    tja cilly das wäre natürlich sicherlich die einfachste Lösung, und natürlich auch die naheliegenste.. das ist soweit klar! Nur das Problem ist halt hier sicher dass sich wahrscheinlich der Kunde an dem OS 9 klammert.. das ist Alltag, mir auch schon oft passiert, gerade wenn es um grössere Updates geht dann werden Kunden plötzlich uneinsichtig :D

    eins ist allerdings klar, wenn es mit der MRJ nicht funktioniert dann kannst du es wirklich getrost vergessen, und dem Kunden raten er solle auf OS X updaten..

    denn wie cilly schon geschrieben hat ist Java in OS 9 grottenschlecht implementiert, und quasi nicht zu gebrauchen.. unter OS X allerdings läuft es sauber und ich hatte bis anhin noch bei keinem Rechner Probleme mit Java ;)

    in diesem Sinne noch heiteres ausproieren :D
    >der snax
     
    snax, 15.09.2004
  8. snax

    snaxMacUser Mitglied

    Mitglied seit:
    25.01.2004
    Beiträge:
    93
    Zustimmungen:
    0
    Hallo Rotzbuab,

    Wie sieht es aus mit dem MRJ auf OS 9?
    ich hoffe ihr könnt einen Erfolg verzeichnen.. :D

    liebe grüsse
    >der snax
     
    snax, 17.09.2004
Die Seite wird geladen...