iTunes Zuordnungsprobleme und dadurch fehlende Titelinformationen und Covers

aetzchen

Mitglied
Thread Starter
Mitglied seit
12.01.2007
Beiträge
154
Hallo liebe Leute,

heute Abend hat sich meine Musikbibliothek 'verabschiedet' im Sinne von, dass jeder Titel mit einem Ausrufezeichen versehen ist. Die Dateien liegen auf einer externen Festplatte und an der Verzeichnisstruktur wurde nichts geändert.
Natürlich wäre es sehr einfach einfach die Bibliothek zu leeren und neu einzurichten, wenn ich nicht zu einzelnen Titeln und Alben eine Menge extra Informationen angelegt hätte. (Das war ganz schöne Tipparbeit die ich nun den Bach runter gehen sehe und es im ganzen mehrere Wochen Arbeit wären, dies wieder herzustellen)
Die Frage ist warum die Dateien nicht mehr zugeordnet werden können? Verstehe ich einfach nicht. Von hier auf jetzt ist noch viel unlogischer. Hatte eine Rechtereperatur vorgenommen, aber daran kann es ja nicht liegen, oder?
Habe die letzte Mac OS Version drauf...

Nun ist die Überlegung folgende. Die Bibliothek wirklich einfach neu anlegen und einfach die Libary.xml in das iTunes-Verzeichnis zu kopieren und fertig ist der Lack. Aber auf der anderen Seite habe ich Angst meine Mediathek nun vollends zu zerschiessen...

Vielleicht weiss jemand von euch Rat? Ich wäre zu tiefstem Dank verpflichtet...
Diverse Recherche hat nichts gebracht. Aber vielleicht ist das Problem ja doch irgendwie bekannt? SuFu bringt nicht wirklich was und Doktor-Google auch nicht...

Beste Grüße,
a.
 

Suendenbock

Aktives Mitglied
Mitglied seit
30.07.2008
Beiträge
1.826
Versuche mal folgendes. Beim Starten von iTunes die Alt-Taste(Wahltaste) gedrückt lassen. Anschließend wirst Du aufgefordert, deine iTunes-Mediathek auzuwählen. Hier gibst Du dann den iTunes-Ordner auf der externen Festplatte an.
 

aetzchen

Mitglied
Thread Starter
Mitglied seit
12.01.2007
Beiträge
154
hmmmm.mir sagt das system leider, dass es keine libary-datei ist, die er annehmen würde (weil halt keine libary-datei)...
komisch ist, dass alle alben eigentlich angezeigt werden, nur dass der zugriff fehlt, die informationen als auch die covers.
ich bin ziemlich ratlos und verstehe es auch nicht wirklich. problematisch ist, dass ich es auch per ferndiagnose mache, da es nicht um meine bibliothek geht, sondern es geht um den neuen mac mini meines vaters. :-/

kann es sein, dass es mit der rechtereparatur zusammenhängt?
weil die sortierung sowie titel-, alben-, und ordnungsinformationen noch vorhanden sind
, die zusatzinformationen fehlen halt.
 
Zuletzt bearbeitet:

KaiAmMac

Aktives Mitglied
Mitglied seit
04.06.2008
Beiträge
6.995
Die Bibliothek ist normalerweise in Deinem Homeverzeichnis, kann aber auf Dateien auf einem anderen Laufwerk verweisen.

Falls Du die Library -auch- auf der externen Festplatte hast, muss Du auf den dortigen "iTunes" - Ordner verweisen, nicht auf iTunes - Musik.

KaiAmMac
 

Suendenbock

Aktives Mitglied
Mitglied seit
30.07.2008
Beiträge
1.826
Du hättest auch noch die Möglichkeit, im iTunes-Ordner den Ordner Previous Itunes Libraries auszuwählen. Dort sind die älteren Libraries, also die Backups, mit Datum abgespeichert.

Wie man das Ganze macht: Beim aktuellsten Backup fügst Du die Endung .itl an. Also beispielsweise iTunes Library 2011-03-07.itl. Dann nochmal die Geschichte mit dem Auswählen und dann in dem Ordner die .itl-Datei auswählen.
 

aetzchen

Mitglied
Thread Starter
Mitglied seit
12.01.2007
Beiträge
154
ja, das ist soweit klar. mein vater weiss nur nicht, welche biblitoheksdatei es nun ist...
anscheinend legt itunes immer wieder neue bibliotheken auf der externen an, was ich als zeichen dafür deute, dass dies der ursprungsordner ist. anscheinend hat er die bibliotheken wahllos 'verschoben' und nun ist es unklar, wo nun welche liegt. vielleicht sind die auch schon 'zerschossen'! :(
 

aetzchen

Mitglied
Thread Starter
Mitglied seit
12.01.2007
Beiträge
154
das mit den prevoius war ne gute idee, und es ist auch eine da, aber leider bleiben die ausrufezeichen stehen und die datei kann nicht gefunden werden...
 

aetzchen

Mitglied
Thread Starter
Mitglied seit
12.01.2007
Beiträge
154
was ist das mit dem .itl?
die dateien die auf der internen sind, werden übrigens immer erkannt, die auf der externen sind das problem und mit aufrufezeichen versehen.
 

Suendenbock

Aktives Mitglied
Mitglied seit
30.07.2008
Beiträge
1.826
was ist das mit dem .itl?
Ist die Dateiendung für Windows-iTunes. Gleichzeitig kann man mit der Endung absolut ohne Probleme seine Bibliothek unter OS X einbinden.

die dateien die auf der internen sind, werden übrigens immer erkannt, die auf der externen sind das problem und mit aufrufezeichen versehen.
Bitte beantworte mir folgende Frage. Sind auf der externen Festplatte im Ordner iTunes die Dateien iTunes Library und iTunes Library.xml?
 

aetzchen

Mitglied
Thread Starter
Mitglied seit
12.01.2007
Beiträge
154
ja, sind sie beide. kopiere ich sie anscheinend in einen anderen ordner (sicherung) und öffne eine ältere bibliotheksdatei, werden wieder neue angelegt. die ausrufezeichen bleiben logischerweise bestehen.
 

Suendenbock

Aktives Mitglied
Mitglied seit
30.07.2008
Beiträge
1.826
Ok. Was wir jetzt noch ausprobieren können, wäre ein Symlink (Symbolische Verknüpfung) zu erstellen. Dazu öffnest Du das Terminal und gibst ein. ln -s [Pfad zum externen iTunes-Ordner]. Am besten Du ziehst nach dem Befehl ln -s den Ordner iTunes von der externen Festplatte in das Terminal-Fenster, um den Pfad nicht händisch ins Terminal eingeben zu müssen. Danach Enter drücken. Anschließend in deinen Benutzerordner gehen. Dort findest Du den iTunes-Symlink und fügst ihn in den Ordner Musik ein. Vorher dann den von iTunes angelegten Ordner löschen und sich vergewissern, dass dort keine benutze Bibliothek vorhanden ist. Anschließend dann iTunes starten.
 

aetzchen

Mitglied
Thread Starter
Mitglied seit
12.01.2007
Beiträge
154
Die Idee ist sehr gut. Vielen Dank. Bei mir funktioniert das soweit auch, nur bei meinem Vater blieben konsequent die Ausrufezeichen stehen. Der neu erzeugte symlink war auf der Externen; habe den dann in den Musikordner kopiert und die Bibliothek geöffnet - funktioniert soweit, aber die Ausrufezeichen bleiben leider. Dann muss das Problem eigentlich woanders liegen, denn mit dem Symlink funktioniert es immer noch nicht, was rein logisch ja nicht funktionieren kann, denn dort werden Verknüpfungen ja neu hergestellt... oder?
Wahrscheinlich sollte ich mir den mac mini zu schicken lassen.

dennoch schonmal vielen Dank für die Hilfe.
 

LosDosos

Aktives Mitglied
Mitglied seit
09.03.2008
Beiträge
18.538
Vielleicht ist Dein Vater nicht mit einem Adminaccount unterwegs?
 
Oben