Internet Problem mit Cisco AnyConnect Client / legt MacBook Air 2020 lahm

Anneke20

Neues Mitglied
Thread Starter
Registriert
09.07.2021
Beiträge
7
Moin zusammen,

vorab einmal: entschuldigt, dass ich keine ausgereifte Fachsprache verwende, ich hoffe ich kann mein Problem trotzdem halbwegs verständlich rüberbringen.

Also: Um in das Netzwerk meiner Uni zu kommen, haben wir einen Cisco AnyConnect VPN Client, den ich mir genau nach Anweisung der Uni installiert habe.
Ich habe ein MacBook Air von 2020 und das macOS Big Sur 11.4 Betriebssystem.
Ich hatte von ca. November 2020 bis ca. Mitte Mai 2021 keinerlei Internetverbindungsprobleme, Beachballprobleme oder überhaupt eine hörbare Lüftung.
Mitte Mai (eventuell seit dem letzten macOs Update? Ich weiß es nicht genau) fing es an, dass bspw. Safari extrem lang gebraucht hat, um Seiten zu laden. Mir wurde angezeigt, dass das Zeitlimit beim Laden der Seite überschritten wurde oder die Internetseiten haben gar nicht mehr geladen. Hinzu kamen Probleme mit Zoom, da keine Verbindung hergestellt werden konnte.
Da ich in den ersten Tagen dachte, es läge an meinem WLAN habe ich alle gängigen Tipps, wie Router neu starten, WLAN-Verbindung komplett zurücksetzen etc. durchprobiert, es hat jedoch nichts gebracht.
Irgendwann ist mir aufgefallen, dass die Lüftung meines MacBooks, selbst wenn ich nur ein Programm geöffnet hatte, sehr laut war und habe mir die Aktivitätsanzeige angeschaut. Mir ist aufgefallen, dass der Cisco Client permanent ca. 120% vom CPU ausgelastet hat, auch wenn ich den VPN Client gar nicht verwendet habe.

Mithilfe eines Kommilitonen habe ich dann noch andere Problemdiagnosen versucht und den Client letztendlich deinstalliert, weil ich nicht mehr an Vorlesungen teilnehmen konnte, wenn über Zoom keine Verbindung hergestellt werden konnte.
Sobald ich den Client deinstalliert hatte, lief alles wieder einwandfrei also gehe ich ganz stark davon aus, dass es tatsächlich mit Cisco zusammenhing.

Weil ich den Client jetzt aber wieder brauche, um Hausarbeiten schreiben zu können, habe ich ihn mir vor einigen Tagen wieder heruntergeladen und sofort fingen die Probleme wieder an. Ich habe mich mit dem Rechenzentrum der Uni in Verbindung gesetzt, aber die meinen es kann nur an mir liegen, weil niemand sonst solche Probleme hat, einen anderen VPN-Client haben sie nicht und sie können mir auch nicht weiterhelfen, wie ich den Client verwenden und trotzdem ins Internet kommen kann...

Jetzt ist meine Frage, ob das irgendwie ein bekanntes Problem ist, oder ob ich irgendwie die Möglichkeit habe, eine Einstellung vorzunehmen, damit alles wieder einwandfrei läuft.

Ich hoffe, ich konnte mein Problem halbwegs nachvollziehbar erklären und danke schonmal :)
 

SirVikon

Aktives Mitglied
Registriert
05.10.2005
Beiträge
8.401
Aber jetzt einmal zur Nutzungsweise des VPN der Hochschule.
Du brauchst es doch nur für die Recherche. Also Literatur laden und dann wieder aus.

Welche Version nutzt du denn von AnyConnect? Hier läuft es unter BigSur „einwandfrei“. Natürlich läuft es langsamer als ohne, aber um im Beck-Online zu recherchieren oder in der Bib Bücher zu laden klappt es.
 

Anneke20

Neues Mitglied
Thread Starter
Registriert
09.07.2021
Beiträge
7
Code:
EtreCheckPro version: 6.4.4 (6E015)

Report generated: 2021-07-09 12:30:43

Download EtreCheckPro from https://etrecheck.com

Runtime: 3:15


Performance: Excellent

Problem: Other problem

Description: 

Safari hat Probleme Seiten zu laden sobald Cisco AnyConnect Mobile Cli

ent heruntergeladen ist


Major Issues:
    Anything that appears on this list needs immediate attention.


    No Time Machine backup - Time Machine backup not found.


Minor Issues: None

Hardware Information:
    MacBook Air (Retina, 13-inch, 2020)
    MacBook Air Model: MacBookAir9,1
    1,1 GHz Dual-Core Intel Core i3 (i3-1000NG4) CPU: 2-core
    8 GB RAM - Not upgradeable
        BANK 0/ChannelA-DIMM0 - 4 GB LPDDR4X 3733
        BANK 2/ChannelB-DIMM0 - 4 GB LPDDR4X 3733
    Battery: Health = Normal - Cycle count = 85

Video Information:
    Intel Iris Plus Graphics - VRAM: 1536 MB
        Color LCD (built-in) 2880 x 1800
        HSG1392 1920 x 1080

Drives:
    disk0 - APPLE SSD AP0256N 251.00 GB (Solid State - TRIM: Yes)
    Internal PCI-Express 8.0 GT/s x4 NVM Express
        disk0s1 - EFI [EFI] 315 MB
        disk0s2 [APFS Container] 250.69 GB
            disk1 [APFS Virtual drive] 250.69 GB (Shared by 6 volumes)
                disk1s1 (APFS) [APFS Container] (Shared - 15.31 GB used)
                    disk1s1s1 - Macintosh HD (APFS) [APFS Snapshot] (Shared - 15.31 GB used)
                disk1s2 - Macintosh HD - Data (APFS) [APFS Virtual drive] (Shared - 58.70 GB used)
                disk1s3 - Preboot (APFS) [APFS Preboot] (Shared - 516 MB used)
                disk1s4 - Recovery (APFS) [Recovery] (Shared - 623 MB used)
                disk1s5 - VM (APFS) [APFS VM] (Shared - 2.15 GB used)
                disk1s6 - Update (APFS) (Shared - 4 MB used)

Mounted Volumes:
    disk1s1s1 - Macintosh HD [APFS Snapshot]
        250.69 GB (Shared - 15.31 GB used, 188.49 GB available, 173.25 GB free)
        APFS
        Mount point: /
        Read-only: Yes
    disk1s2 - Macintosh HD - Data [APFS Virtual drive]
        250.69 GB (Shared - 58.70 GB used, 188.49 GB available, 173.25 GB free)
        APFS
        Mount point: /System/Volumes/Data
        Encrypted
    disk1s3 - Preboot [APFS Preboot]
        250.69 GB (Shared - 516 MB used, 173.25 GB free)
        APFS
        Mount point: /System/Volumes/Preboot
    disk1s5 - VM [APFS VM]
        250.69 GB (Shared - 2.15 GB used, 173.25 GB free)
        APFS
        Mount point: /System/Volumes/VM
    disk1s6 - Update
        250.69 GB (Shared - 4 MB used, 173.25 GB free)
        APFS
        Mount point: /System/Volumes/Update
    disk2s2 - G***********e
        249 MB (249 MB used)
        Mac OS Extended
        Disk Image
        Mount point: /Volumes/G***********e
        Owners enabled: No
        Read-only: Yes

Network:
    Interface en0: Wi-Fi
        802.11 a/b/g/n/ac
        Proxy Auto Discovery
    Interface en4: Bluetooth PAN
    Interface bridge0: Thunderbolt Bridge
    iCloud Quota: 1.75 TB available

System Software:
    macOS Big Sur 11.4 (20F71)
    Time since boot: About 6 days

Security:
    Gatekeeper: App Store and identified developers

    System Integrity Protection: Enabled


    Antivirus software: Apple


System Extensions:
    [Removed after restart] Cisco AnyConnect Socket Filter Extension - version 4.10.01075 (Cisco)
        Application: /Applications/Cisco/Cisco AnyConnect Socket Filter.app - version 4.10.01075
        Description: This system extension provides socket filter capabilities.

System Launch Agents:
    [Not Loaded] 16 Apple tasks

    [Loaded] 161 Apple tasks

    [Running] 157 Apple tasks


System Launch Daemons:
    [Not Loaded] 36 Apple tasks

    [Loaded] 167 Apple tasks

    [Running] 158 Apple tasks

    [Other] One Apple task


Launch Daemons:
    [Loaded] com.AngularTech.OsxHelper.plist (AngularTech Inc. - installed 2021-06-18)


User Login Items:
    [Not Loaded] HandShakerAgent (App Store - installed 2021-05-14)
        Modern Login Item
        /Applications/HandShaker.app/Contents/Library/LoginItems/HandShakerAgent.app
    [Running] OneDrive (Microsoft Corporation - installed 2021-06-16)
        Application
        /Applications/OneDrive.app
    [Not Loaded] Launcher Disabler (Microsoft Corporation - installed 2021-06-16)
        Modern Login Item
        /Applications/OneDrive.app/Contents/Library/LoginItems/Launcher Disabler.app
    [Not Loaded] OneDrive Launcher (Microsoft Corporation - installed 2021-06-16)
        Modern Login Item
        /Applications/OneDrive.app/Contents/Library/LoginItems/OneDrive Launcher.app

Backup:
    Time Machine Not Configured!

Performance:
    System Load: 2.09 (1 min ago) 2.15 (5 min ago) 2.12 (15 min ago)
    Nominal I/O speed: 0.55 MB/s
    File system: 20.98 seconds
    Write speed: 1032 MB/s
    Read speed: 1249 MB/s

CPU Usage Snapshot:
    Type Overall

    System: 4 %

    User: 8 %

    Idle: 88 %


Top Processes Snapshot by CPU:
    Process (count) CPU (Source - Location)

    WindowServer 25.76 % (Apple)

    EtreCheckPro 10.84 % (Etresoft, Inc.)

    sysmond 3.78 % (Apple)

    kernel_task 3.38 % (Apple)

    loginwindow 2.66 % (Apple)


Top Processes Snapshot by Memory:
    Process (count) RAM usage (Source - Location)

    com.apple.WebKit.WebContent (20) 1.72 GB (Apple)

    EtreCheckPro 232 MB (Etresoft, Inc.)

    kernel_task 207 MB (Apple)

    AppleSpell 112 MB (Apple)

    Safari 111 MB (Apple)


Top Processes Snapshot by Network Use:
    Process Input / Output (Source - Location)

    mDNSResponder 12 MB / 3 MB (Apple)

    com.apple.WebKit.Networking 388 KB / 244 KB (Apple)

    remoted 149 KB / 203 KB (Apple)

    cloudd 151 KB / 88 KB (Apple)

    netbiosd 55 KB / 32 KB (Apple)


Top Processes Snapshot by Energy Use:
    Process (count) Energy (0-100) (Source - Location)

    WindowServer 10 (Apple)

    cloudd (2) 2 (Apple)

    sysmond 1 (Apple)

    Activity Monitor 1 (Apple)

    com.apple.WebKit.WebContent (20) 0 (Apple)


Virtual Memory Information:
    Physical RAM: 8 GB


    Free RAM: 41 MB

    Used RAM: 6.55 GB

    Cached files: 1.41 GB


    Available RAM: 1.45 GB

    Swap Used: 1007 MB


Diagnostics Information (past 7-30 days):
    2021-07-08 14:41:29 mDNSResponder - High CPU Use
        Executable: /usr/sbin/mDNSResponder
    2021-07-08 14:39:08 com.cisco.anyconnect.macos.acsockext - High CPU Use
        Executable: /Library/SystemExtensions/*/com.cisco.anyconnect.macos.acsockext
    2021-07-08 11:00:11 WindowServer - High CPU Use
        Executable: /System/Library/PrivateFrameworks/SkyLight.framework/Versions/A/Resources/WindowServer

End of report
 
Zuletzt bearbeitet von einem Moderator:

SirVikon

Aktives Mitglied
Registriert
05.10.2005
Beiträge
8.401
Hast du denn im Netzwerk die drei „Sachen“ von Cisco aktiviert? Also die verschiedenen Filter. Du scheinst Version 4.10.xxx zu nutzen. Das sollte reichen, denn ab 4.9 funktioniert das auch unter BigSur. Aber wie gesagt, mach doch den VPN nur zur Recherche an.

Bildschirmfoto 2021-07-09 um 12.50.28.png


Und der i3 in deinem Air wird natürlich durch den VPN belastet. Wobei AnyConnect bei mir nur wenige % CPU-Last erzeugt.
 
Zuletzt bearbeitet:

SirVikon

Aktives Mitglied
Registriert
05.10.2005
Beiträge
8.401
Ach ja, für Zoom braucht ihr bei euch den VPN? Beiname läuft halt alles als SSO über den Server der Hochschule. Wenn ich das mit dem VPN versuchen würde, dann ginge das bei mir bestimmt auch nicht.
 

walfreiheit

Aktives Mitglied
Registriert
06.06.2004
Beiträge
35.322
Ich sehe da keine grundsätzlichen Probleme im System. Aber Cisco ist doch noch drauf, dachte das wäre runter?

Hast du OneDrive aus dem AppStore geladen, oder von der Microsoft-Seite? Unbedingt die aus dem AppStore verwenden, die andere macht Probleme.
 

Anneke20

Neues Mitglied
Thread Starter
Registriert
09.07.2021
Beiträge
7
Hast du denn im Netzwerk die drei „Sachen“ von Cisco aktiviert? Also die verschiedenen Filter. Du scheinst Version 4.10.xxx zu nutzen. Das sollte reichen, denn ab 4.9 funktioniert das auch unter BigSur. Aber wie gesagt, mach doch den VPN nur zur Recherche an.

Anhang anzeigen 336653

Und der i3 in deinem Air wird natürlich durch den VPN belastet. Wobei AnyConnect bei mir nur wenige % CPU-Last erzeugt.
Ja ich hatte den VPN auch wenn nur zur Recherche an, das war auch das, was mich so gewundert hat. Auch wenn ich Cisco beendet habe hat er weiterhin die hohen % CPU-Last erzeugt. Also das Problem ist quasi, dass Safari etc. spinnen sobald ich Cisco nur installiere, auch wenn ich den VPN gar nicht verwende. Macht das irgendwie Sinn? :/

Und ich habe Cisco momentan ja wieder deinstalliert, aber ich glaube bei mir waren immer nur zwei von den drei Filtern verbunden....
 

Anneke20

Neues Mitglied
Thread Starter
Registriert
09.07.2021
Beiträge
7
Ach ja, für Zoom braucht ihr bei euch den VPN? Beiname läuft halt alles als SSO über den Server der Hochschule. Wenn ich das mit dem VPN versuchen würde, dann ginge das bei mir bestimmt auch nicht.
Nein für Zoom brauche ich an sich keinen VPN, da ist das Problem aber genau dasselbe wie bei Safari. Also auch wenn ich Cisco gar nicht verwende, sondern nur installiert habe, hat Zoom fast immer sehr lange für einen Verbindungsaufbau gebraucht, bzw. es konnte gar keine Verbindung hergestellt werden. Und sobald ich Cisco wieder deinstalliert, läuft alles wieder einwandfrei
 

Anneke20

Neues Mitglied
Thread Starter
Registriert
09.07.2021
Beiträge
7
Ich sehe da keine grundsätzlichen Probleme im System. Aber Cisco ist doch noch drauf, dachte das wäre runter?

Hast du OneDrive aus dem AppStore geladen, oder von der Microsoft-Seite? Unbedingt die aus dem AppStore verwenden, die andere macht Probleme.
Eigentlich habe ich Cisco wieder deinstalliert... Wird mir bei Programmen auch nicht mehr angezeigt

Ich glaube, ich habe OneDrive von der Microsoft-Seite geladen, über einen Link von der Uni. Soll ich das am besten wieder deinstallieren und über den App-Store neu laden?
 

SirVikon

Aktives Mitglied
Registriert
05.10.2005
Beiträge
8.401
Wie in #5 beschrieben, laufen da einige Filter im Hintergrund … auch wenn der VPN nicht aktiv ist. Die kann man aber trennen.

Wobei die eigentlich keine Probleme machen sollten. Vielleicht hast du Little Snitch (oder andere Netzwerkverkehrblocker) installiert und dort etwas blockiert?
 

Anneke20

Neues Mitglied
Thread Starter
Registriert
09.07.2021
Beiträge
7
Wie in #5 beschrieben, laufen da einige Filter im Hintergrund … auch wenn der VPN nicht aktiv ist. Die kann man aber trennen.

Wobei die eigentlich keine Probleme machen sollten. Vielleicht hast du Little Snitch (oder andere Netzwerkverkehrblocker) installiert und dort etwas blockiert?
Ahh okay, jetzt verstehe ich.

Ich hab eigentlich nichts wie Netzwerkverkehrblocker oder so installiert.
 

Anneke20

Neues Mitglied
Thread Starter
Registriert
09.07.2021
Beiträge
7
Eigentlich habe ich Cisco wieder deinstalliert... Wird mir bei Programmen auch nicht mehr angezeigt

Ich glaube, ich habe OneDrive von der Microsoft-Seite geladen, über einen Link von der Uni. Soll ich das am besten wieder deinstallieren und über den App-Store neu laden?
Ich habe noch eine Frage zum Deinstallieren von OneDrive...Ich hab mich bei Word und co. jetzt abgemeldet damit onedrive nicht mehr verwendet wird, aber kann es trotzdem nicht deinstallieren, weil mir immer angezeigt wird, dass es noch geöffnet ist. Was muss ich machen, damit ich OneDrive deinstallieren kann?
 

chicken1112

Registriert
Registriert
14.07.2021
Beiträge
3
Ich habe exakt das gleich Problem mit meinem MacBookPro 2020. Ich hatte mein Mac schon bei der Reparatur/ Diagnose, weil ich so verzweifelt war und rein gar nichts mehr funktioniert hat.
Heute Abend kam ich dann auf die Idee mit dem Cisco Client. Ich brauche diesen nämlich Ende des Monats für eine Online Klausur.
Ich hoffe es finden sich noch ein paar Leute mit dem selben Problem und es wird eine Lösung dafür gefunden.
 

chicken1112

Registriert
Registriert
14.07.2021
Beiträge
3
Hast du denn im Netzwerk die drei „Sachen“ von Cisco aktiviert? Also die verschiedenen Filter. Du scheinst Version 4.10.xxx zu nutzen. Das sollte reichen, denn ab 4.9 funktioniert das auch unter BigSur. Aber wie gesagt, mach doch den VPN nur zur Recherche an.

Anhang anzeigen 336653

Und der i3 in deinem Air wird natürlich durch den VPN belastet. Wobei AnyConnect bei mir nur wenige % CPU-Last erzeugt.
Diese Lösung habe ih vorhin versucht, allerdings kann ich diese Verbindungen nicht einfach trennen. Denn ich soll dazu den Socket Filter öffnen um zu bearbeiten. Wenn ich den öffnen will, öffnet sich leider gar nichts. Folglich kann ich die Verbindungen nicht deaktivieren. Aktivieren ich Sie direkt von Anfang an nicht, dann erscheint ständig ein Popup Fenster, dass ich es erlauben soll.
 

chicken1112

Registriert
Registriert
14.07.2021
Beiträge
3
…keine Lösung, aber ein Workaround: Versuch mal anstelle vom Cisci Anyconnect Client den Openconnect-Gui Client, am einfachsten hier herunterzuladen:

https://www.uni-due.de/zim/services/internetzugang/openconnect-mac.php

Der Client ist zwar nicht hübsch und schon älter, funktioniert aber einwandfrei.
Aktuell für mich die beste Lösung. Habe den Client direkt installiert und bisher keine Probleme.
Ich hoffe nur, dass das von Seiten der Uni auch mit dem Client in Ordnung geht, ich denke mal, das sollte kein Problem sein oder?
Danke !
 

bowman

Aktives Mitglied
Registriert
08.10.2003
Beiträge
2.864
…das kann nur die Uni entscheiden, praktisch sollte das aber kein Problem sein. Der Cisco Anyconnect-Client erlaubt zusätzliche Einschränkungen wie z.B. das zwangsweise Tunneln aller Netzwerkverbindungen durch das VPN - damit sind aber lokale Netzwerktessourcen dann nicht mehr erreichbar. Das ist der Grund, warum ich Openconnect nutze - unter Linux ist das ohnehin die m.W. einzige Lösung…
 

SMario

Mitglied
Registriert
16.09.2005
Beiträge
88
Ein riesen Dankeschön für diesen Thread und die Lösung durch OpenConnect. :)(y)

Hab schon fast selber an mir gezweifelt o_O, bei der Suche nach dem Übeltäter für den auf ein Mal auftretende zähen Seitenaufbau.
Interessanterweise konnte ich das in allen Browsern (Chrome, Firefox, Edge) nachvollziehen. Nur in Safari war es bei mir flüssig. Alles sehr eigenartig.
 
Oben Unten