import java.util.ArrayList; ??

  1. Bianca_Bln

    Bianca_Bln Thread Starter MacUser Mitglied

    Mitglied seit:
    24.10.2004
    Beiträge:
    80
    Zustimmungen:
    0
    Java 1.5 installieren, aber wie? *bin Anfänger

    import java.util.ArrayList;

    Ich schreibe ein kleines Programm mittels dem ich auf die Klasse ArrayList zu greifen möchte. Ich arbeite im Moment mit einem kleinen Editor. Habe mir aber gerade Eclipse heruter geladen.

    Frage: Was muss ich tun, damit mein Programm auf diese Klasse zu greifen kann?

    Vielen Dank!

    Bianca

    PS: Die aktuellste Java Version habe ich nicht auf meinem PowerMac.
     
  2. dkreutz

    dkreutz MacUser Mitglied

    Mitglied seit:
    14.05.2005
    Beiträge:
    458
    Zustimmungen:
    18
    Das mit dem "import ..." hast Du schon richtig erkannt. Die passender Bibliothek (jar) muss außerdem in Classpath vorhanden sein. Bei den java.* Packages musst Du, eine normale JRE Installation voraus gesetzt, nichts weiter dafür tun.

    Warum installierst Du nicht ein Java IDE (Eclipse, NetBeans,...), dort gibt es normalerweise automatisch Hilfestellung bei solchen Problemen.
     
  3. Bianca_Bln

    Bianca_Bln Thread Starter MacUser Mitglied

    Mitglied seit:
    24.10.2004
    Beiträge:
    80
    Zustimmungen:
    0
    Wie gesagt, habe gerade Eclipse herutergeladen ... probiere es gleich einmal aus.

    Danke erst einmal!
     
  4. grizto

    grizto MacUser Mitglied

    Mitglied seit:
    27.11.2004
    Beiträge:
    398
    Zustimmungen:
    9
    wobei die Collections in Java1.5 mit Generics arbeiten (was ultimativ angenehm ist) und in 1.4 noch nich.
    Also würde ich mir das aktualisieren auf 1.5 mal überlegen :)
     
  5. Bianca_Bln

    Bianca_Bln Thread Starter MacUser Mitglied

    Mitglied seit:
    24.10.2004
    Beiträge:
    80
    Zustimmungen:
    0
    Schwierigkeiten.

    Ich habe mit der Klasse ArrayList trotz Eclipse Schwierigkeiten.

    "Multiple makers at this line
    - Syntax error ..."

    Liegt es in der Tat daran, dass ich kein Java 1.5 habe? Kann ich Java 1.5 auf Mac OSX 10.3.9 installieren?

    (Ich recherchiere einfach mal ...)

    Danke!
     
  6. dkreutz

    dkreutz MacUser Mitglied

    Mitglied seit:
    14.05.2005
    Beiträge:
    458
    Zustimmungen:
    18
    Poste doch einfach mal das betreffende Codefragment...
     
  7. deus-ex

    deus-ex MacUser Mitglied

    Mitglied seit:
    04.11.2005
    Beiträge:
    553
    Zustimmungen:
    9
    Jo, poste mal deinen Code.

    ansonsten hier ein kleines Bespiel.

    ===========================

    import java.util.ArrayList;


    public class Test {

    public static void main(String[] args)
    {
    ArrayList al = new ArrayList();
    }
    }


    Gruß
    Deus-ex (der JGod :D )
     
  8. Bianca_Bln

    Bianca_Bln Thread Starter MacUser Mitglied

    Mitglied seit:
    24.10.2004
    Beiträge:
    80
    Zustimmungen:
    0
    Ich muss Java 1.5 installieren, aber wie?

    Es geht wohl um die <> bei ArrayList. Dazu benötige ich Java 1.5.

    Ich habe in diesem Forum und auch im www recherchiert, leider sind mir die Auskünfte, wie man Java 1.5 installiert zu "kompliziert".

    Da ich ein gebranntes Kind bin, weil ein Kommilitone bei mir Java 1.5 installieren wollte, er es aber mehr kaputt gemacht hat, muss ich nun selber ran. *oweia

    Kann mir vielleicht jemand weiterhelfen? Ich habe einen Power Mac G4 (OSX 10.4.3).

    Inzwischen habe ich "J2SE50Release3.dmg" herunter geladen. Wie muss ich nun vorgehen?

    Vielen Dank!
    Bianca
     
  9. Bianca_Bln

    Bianca_Bln Thread Starter MacUser Mitglied

    Mitglied seit:
    24.10.2004
    Beiträge:
    80
    Zustimmungen:
    0
    Also unter Eclipse gibt er folgende Fehlermeldung aus:

     
  10. gishmo

    gishmo MacUser Mitglied

    Mitglied seit:
    16.03.2004
    Beiträge:
    813
    Zustimmungen:
    23
    Poste mal deinen Code.
    ArrayList gibt es auch schon vor Java 1.5.

    Du kannst auch mehrere VMs auf deinem Rechner fahren und kannst beliebigt durch Ändern der Prefs zwischen diesen wechseln. Wie das geht, such mal im Forum oder in dne Apple Discussion Groups.

    Und die Fehlermeldung deuten darauf hin, dass Du NICHT mit 1.5 arbeitest.

    Gib mal im Terminal java -version ein.
     
Die Seite wird geladen...