IE (Win) zeigt Seite anders an

  1. Mauki

    Mauki Thread StarterMacUser Mitglied

    Mitglied seit:
    24.07.2002
    Beiträge:
    14.816
    Zustimmungen:
    138
    Bin gerade dabei mit Rapidweaver ne Seite zu erstellen. Mein selbsterstelltes Template sieht leider im IE (Win) nicht ganz perfekt aus und ich weiß nicht warum

    Es gibt 3 Anzeigebugs im IE - Klick mich

    1. Bei einigen Seiten ist die Grafik vom Faux-Columns breiter als die Navi!
    2. Oben in der Navigation sind die Trennstriche nach unten versetzt!
    3. Bei fast allen Seiten wird der Breadcrumb nicht angezeigt.

    Hätte eigentlich das dies auch im IE korrekt aussieht [​IMG]
     
    Mauki, 09.05.2006
  2. Mauki

    Mauki Thread StarterMacUser Mitglied

    Mitglied seit:
    24.07.2002
    Beiträge:
    14.816
    Zustimmungen:
    138
    *schubs*
     
    Mauki, 11.05.2006
  3. AndreasE

    AndreasEMacUser Mitglied

    Mitglied seit:
    21.01.2004
    Beiträge:
    2.655
    Zustimmungen:
    143
    Hi Mauki,

    drück mal auf dem XHTML-Button im Impressum der Seite, löst die Beseitigung der dort aufgeführten Fehler dein Problem?
     
    AndreasE, 11.05.2006
  4. heldausberlin

    heldausberlinMacUser Mitglied

    Mitglied seit:
    01.05.2004
    Beiträge:
    13.832
    Zustimmungen:
    302
    Hast du’s schon korrigiert? Ich finde grade beim IE6 keinen Fehler.
    Ansonsten empfehle ich dir, die XML-Declaration im Page-Inspektor zu deaktivieren, da der IE das nicht so gut interpretieren kann.
     
    heldausberlin, 11.05.2006
  5. Mauki

    Mauki Thread StarterMacUser Mitglied

    Mitglied seit:
    24.07.2002
    Beiträge:
    14.816
    Zustimmungen:
    138
    Ne die Fehler haben damit nichts zu tun. Da bin ich aber noch dran, die zu korrigieren, ebenso wie die CSS Warnungen.


    Ne habs noch nicht korrigiert, beim mir treten die Fehler noch auf.

    Aha das mit der XML-Declaration höre ich zum ersten mal. Die ist doch dafür da das der Code XML Konform ist oder?
     
    Mauki, 11.05.2006
  6. midroth

    midrothMacUser Mitglied

    Mitglied seit:
    27.10.2004
    Beiträge:
    1.263
    Zustimmungen:
    31
    Da wirste alt. Der IE hält sich nicht an Standards, er interpretiert sie.
     
    midroth, 11.05.2006
  7. heldausberlin

    heldausberlinMacUser Mitglied

    Mitglied seit:
    01.05.2004
    Beiträge:
    13.832
    Zustimmungen:
    302
    Auf Rapidweaver.de war mal ne Beschreibung, warum der IE das falsch interpretiert.
    Eine meiner Seiten wurde davon auch mal nur mit Quellcode dargestellt.
     
    heldausberlin, 11.05.2006
  8. heldausberlin

    heldausberlinMacUser Mitglied

    Mitglied seit:
    01.05.2004
    Beiträge:
    13.832
    Zustimmungen:
    302
    Ah, ich glaub, das könnte der Fehler sein:

    Ändere mal deinen Doctype von Strict in Transitional um.
    Also
    HTML:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
        "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    
     
    heldausberlin, 11.05.2006
  9. Mauki

    Mauki Thread StarterMacUser Mitglied

    Mitglied seit:
    24.07.2002
    Beiträge:
    14.816
    Zustimmungen:
    138
    Wo kann ich den in RW den Doctype ändern ?
     
    Mauki, 11.05.2006
  10. heldausberlin

    heldausberlinMacUser Mitglied

    Mitglied seit:
    01.05.2004
    Beiträge:
    13.832
    Zustimmungen:
    302
    Bei deinem Theme in der Themeleiste mit Rechtsklick den „Content“ öffnen.
    Dort die index.html mit TextEdit oder jedem x-beliebigen Text-/HTML-Editor öffnen.
    Die erste Zeile dann korrigieren.
     
    heldausberlin, 11.05.2006
Die Seite wird geladen...
Ähnliche Themen - (Win) zeigt Seite
  1. hightime-fan
    Antworten:
    2
    Aufrufe:
    1.389
    hightime-fan
    03.06.2010
  2. markusch
    Antworten:
    0
    Aufrufe:
    507
    markusch
    17.10.2009
  3. Fabi87
    Antworten:
    6
    Aufrufe:
    829
    JoeSixpack
    17.03.2009
  4. LuMac_2
    Antworten:
    6
    Aufrufe:
    693
    falkgottschalk
    17.02.2009
  5. ulik
    Antworten:
    5
    Aufrufe:
    383
    rm -r *
    05.02.2009