iBook G3 startet nicht mehr

gismo16

Neues Mitglied
Thread Starter
Mitglied seit
07.08.2005
Beiträge
14
Hallo,

vielleicht koennen mir die Spezialisten hier weiter helfen: habe gestern ein altes iBook G3 geschenkt bekommen, welches rund lief. Da ich aus der Ecke der x86-er stamme, BSD-User bin und ich nicht sehr begeistert von MacOS X bin, wollte ich mir NetBSD installieren. Wollte es ueber NetBoot installieren, also schnell aus meinem Rechner ein TFTP-Server gemacht. Naja, der naechste Schritt, nach einigen, war das Aendern der Einstellungen in der Openfirmware, was moeglicherweise das Verhaengnis von allem war. iBook hat neugestartet, Startton wurde ausgegeben, man hoerte noch die Festplatte (?) und danach kam die Stille. Nichts tat und tut sich mehr. In die Openfirmware gelange ich nicht mehr, NVRAM und PRAM kann ich auch nicht zuruecksetzen (beim Zuruecksetzen des PRAMs warte ich vergeblich auf den zweiten Startton).

Nuja, weisz da jemand vielleicht etwas mehr? Ansonsten muss ich wohl mein kleines Abenteuer mit dem iBook aufgeben.

Ansonsten noch frohe Ostern!

Kacper
 

Naphaneal

unregistriert
Mitglied seit
05.12.2007
Beiträge
5.787
schätze du hast dir die startparameter zerschossen...versuch mal nen reinstall von der mac-cd aus...
 
  • Gefällt mir
Reaktionen: gismo16

gismo16

Neues Mitglied
Thread Starter
Mitglied seit
07.08.2005
Beiträge
14
Ja, jetzt kommt das naechste Problem. Ich kann auch nicht von den CDs booten. War auch vorher so. MacOS X konnte ganz normal die CDs lesen, nur Booten und das Lesen von denen in der Openfirmware hat auch nicht geklappt.
 

Naphaneal

unregistriert
Mitglied seit
05.12.2007
Beiträge
5.787
kommst du ins auswahlmenü per ALT taste? oder zum hardwaretest per D-taste? kannst du per C-taste von CD booten?
 

gismo16

Neues Mitglied
Thread Starter
Mitglied seit
07.08.2005
Beiträge
14
Ins Auswahlmenue komme ich nicht. Hardwaretest startet auch nicht und wie schon oben gesagt, das Booten von der CD mit C geht auch nicht.

Dies macht mich aeuszerst stutzig.
 

Naphaneal

unregistriert
Mitglied seit
05.12.2007
Beiträge
5.787
dann hast du dir das system aber derbe zerschossen...da wird wohl nur ein mactech helfen...da muß das EFI neu aufgespielt werden...(also das BIOS für mac)
 

gismo16

Neues Mitglied
Thread Starter
Mitglied seit
07.08.2005
Beiträge
14
Hoechtwahrscheinlich. Aber schon mal viele Dank fuer Deine Hilfe!
 

bund

Aktives Mitglied
Mitglied seit
13.05.2005
Beiträge
1.503
Damit da nichts durcheinanderkommt: EFI gab es beim Mac erst mit den ersten Intel Rechnern 2006. EFI ist ja eine Intel/Microsoft Weiterentwicklung des BIOS

Das iBook basierte ja noch auf der PowerPC CPU Architektur, was du da in der open Firmware geändert hast sollte durch einen erneuten Start in die Open Firmware mit Befehl-Option-O-F und dem Befehl "reset-all" ein (ohne Anführungszeichen) zurückgesetzt werden können.

Wenn das eingebaute optische Laufwerk nicht funktioniert kannst du auch ein externes Laufwerk per Firewire anschliessen und von diesem booten.

Edit: Wenn du nicht in die OF kommst mal einen reset versuchen, Link für verschiedene Modelle
 
Zuletzt bearbeitet:

Naphaneal

unregistriert
Mitglied seit
05.12.2007
Beiträge
5.787
stimmt..sorry...mein fehler...is richtig...EFI neuere macs...
 

rex1966

Aktives Mitglied
Mitglied seit
10.12.2003
Beiträge
1.019
Damit da nichts durcheinanderkommt: EFI gab es beim Mac erst mit den ersten Intel Rechnern 2006. EFI ist ja eine Intel/Microsoft Weiterentwicklung des BIOS
EFI ist eine reine Intel Entwicklung,da hat MS nichts mit dran getan.
Selbst in Microsofts neustem Spross Vista wird das EFI noch nicht unterstützt.
:Oldno:
 

gismo16

Neues Mitglied
Thread Starter
Mitglied seit
07.08.2005
Beiträge
14
So, das Thema erwacht wieder.

Da ich das iBook in den letzten Monaten total vergessen habe, hier weitere Informationen:
das PMU-Reset habe ich hinbekommen. Er gibt erst einen laengeren, tieferen Ton von sich, danach blinkt die Leuchte fuer drei Sekunden und man hoert den ganz normalen Startton des iBooks. Eigentlich reicht jetzt ein Neustartet und ich sollte wieder in die Open Firmware kommen. Mmmh, aber Pech gehabt. Irgendwie hilft das trotzdem nicht?

Weisz jemand vielleicht mehr?
 

Naphaneal

unregistriert
Mitglied seit
05.12.2007
Beiträge
5.787
versuch mal alles zu resetten, was zu resetten geht...

PRAM, PMU, NVRAM, weiß der geier...

danach alles neu installieren und zum apfelgott beten
 

gismo16

Neues Mitglied
Thread Starter
Mitglied seit
07.08.2005
Beiträge
14
Verdammte Axt. Irgendwie bringt das nichts. Habe alles moegliche resettet, danach versucht im Target Modus zu starten, und andauernd nichts. Wahrscheinlich hilft da nur noch professionelle Hilfe.
 

Naphaneal

unregistriert
Mitglied seit
05.12.2007
Beiträge
5.787
yo...wird wohl mit ziemlicher wahrscheinlichkeit das boot-rom neu geflasht werden müssen, oder was damals verbaut wurde...oder ein neues logicboard...ob sich das aber noch lohnt?
 

Xray

Aktives Mitglied
Mitglied seit
27.03.2005
Beiträge
1.408
Abgeben zum Aufspielen einer neuen Firmware und die Lehre draus ziehen, das man die Pfoten von der Firmware lässt, wenn man keine Ahnung hat.
 
Oben